Mandriva 2008.0 Far funzionare Eclipse

Gio, 11/10/2007 - 08:13

Mandriva 2008.0 Far funzionare Eclipse

Inviato da Moreno 5 commenti

MGSM 0046 11/10/2007 Mandriva 2008.0 Far funzionare Eclipse

A quanto pare c'è un Bug nelle dipendenze di installazione di Eclipse che dimentica di installare dei pacchetti fondamentali.

Installando Eclipse con il classico urpmi eclipse-platform e eseguendo il comando eclipse il programma esce con un errore del tipo

!SESSION 2007-10-11 07:23:56.957 -----------------------------------------------
eclipse.buildId=I20070625-1500
java.version=1.6.0_02
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=it_IT
Framework arguments: -Dgnu.gcj.runtime.VMClassLoader.library_control=never
Command-line arguments: -os linux -ws gtk -arch x86 -Dgnu.gcj.runtime.VMClassLoader.library_control=never

!ENTRY org.eclipse.equinox.app 2007-10-11 07:23:58.814
!MESSAGE Product org.eclipse.sdk.ide could not be found.

!ENTRY org.eclipse.osgi 4 0 2007-10-11 07:23:58.827
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:229)
at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:92)
at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:129)

Non facciamoci spaventare, il problema si risolve in un attimo installando i pacchetti mancanti

# urpmi eclipse-mylyn-pde
#

che installerà altri 12 pacchetti per un totale di 186Mb.

A questo punto Eclipse tornerà a funzionare correttamente.

Ciao Ciao Moreno





Commenti

Ritratto di Astragalo
#1

Inviato da Astragalo il Gio, 11/10/2007 - 08:46.

Mandriva 2008.0 Far funzionare Eclipse

Come al solito sempre celere nel trovare bug e soluzioni!

Volevo farti notare il comando che hai indicato :

urpmi urpmi eclipse-mylyn-pde

è veramente così o è un errore di battitura?

Buona giornata.



Ritratto di Moreno
#2

Inviato da Moreno il Gio, 11/10/2007 - 08:57.

Re: Mandriva 2008.0 Far funzionare Eclipse

Ciao

Hops problemi di copia/incolla, subito corretto.

Grazie per la segnalazione.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.



Ritratto di freed
#3

Inviato da freed il Gio, 11/10/2007 - 17:22.

Re: Mandriva 2008.0 Far funzionare Eclipse

ciao

si ok però i 2 soli pacchetti eclipse-platform e eclipse-mylyn-pde chiamano dipendenze per un totale di 536 mega :-o

---------------------------------------------------------------
- ant-1.7.0-3.3.6mdv2008.0.i586
- ant-antlr-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-bcel-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-bsf-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-log4j-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-oro-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-regexp-1.7.0-3.3.6mdv2008.0.i586
- ant-apache-resolver-1.7.0-3.3.6mdv2008.0.i586
- ant-commons-logging-1.7.0-3.3.6mdv2008.0.i586
- ant-commons-net-1.7.0-3.3.6mdv2008.0.i586
- ant-javamail-1.7.0-3.3.6mdv2008.0.i586
- ant-jdepend-1.7.0-3.3.6mdv2008.0.i586
- ant-jmf-1.7.0-3.3.6mdv2008.0.i586
- ant-jsch-1.7.0-3.3.6mdv2008.0.i586
- ant-junit-1.7.0-3.3.6mdv2008.0.i586
- ant-nodeps-1.7.0-3.3.6mdv2008.0.i586
- ant-swing-1.7.0-3.3.6mdv2008.0.i586
- ant-trax-1.7.0-3.3.6mdv2008.0.i586
- antlr-2.7.7-1.3mdv2008.0.i586
- axis-1.4-2.0.2mdv2008.0.i586
- bcel-5.2-1.5mdv2008.0.i586
- bouncycastle-1.37-1.3mdv2008.0.i586
- bouncycastle-jdk1.4-1.37-1.3mdv2008.0.i586
- bsf-2.4.0-1.3mdv2008.0.i586
- classpathx-jaf-1.1.1-2.4mdv2008.0.i586
- classpathx-mail-1.1.1-4.6mdv2008.0.i586
- eclipse-cvs-client-3.3.0-0.20.8mdv2008.0.i586
- eclipse-ecj-3.3.0-0.20.8mdv2008.0.i586
- eclipse-jdt-3.3.0-0.20.8mdv2008.0.i586
- eclipse-mylyn-2.0.0-0.7.1mdv2008.0.i586
- eclipse-mylyn-ide-2.0.0-0.7.1mdv2008.0.i586
- eclipse-mylyn-java-2.0.0-0.7.1mdv2008.0.i586
- eclipse-mylyn-pde-2.0.0-0.7.1mdv2008.0.i586
- eclipse-pde-3.3.0-0.20.8mdv2008.0.i586
- eclipse-pde-runtime-3.3.0-0.20.8mdv2008.0.i586
- eclipse-platform-3.3.0-0.20.8mdv2008.0.i586
- eclipse-rcp-3.3.0-0.20.8mdv2008.0.i586
- fastjar-0.95-1mdv2008.0.i586
- gcc4.3-4.3-0.20070713.5mdv2008.0.i586
- gcc4.3-cpp-4.3-0.20070713.5mdv2008.0.i586
- gcc4.3-java-4.3-0.20070713.5mdv2008.0.i586
- gcj4.3-tools-4.3-0.20070713.5mdv2008.0.i586
- geronimo-jsp-2.0-api-1.0-3.8.1mdv2008.0.i586
- icu4j-eclipse-3.6.1-1.2.2mdv2008.0.i586
- jakarta-commons-beanutils-1.7.0-4.5mdv2008.0.i586
- jakarta-commons-codec-1.3-8.2.2mdv2008.0.i586
- jakarta-commons-collections-3.2-1.4mdv2008.0.i586
- jakarta-commons-collections-tomcat5-3.2-1.4mdv2008.0.i586
- jakarta-commons-daemon-1.0.1-4.4mdv2008.0.i586
- jakarta-commons-dbcp-1.2.1-10.1.2mdv2008.0.i586
- jakarta-commons-dbcp-tomcat5-1.2.1-10.1.2mdv2008.0.i586
- jakarta-commons-digester-1.7-4.4mdv2008.0.i586
- jakarta-commons-discovery-0.4-2.4mdv2008.0.i586
- jakarta-commons-el-1.0-8.1.2mdv2008.0.i586
- jakarta-commons-fileupload-1.0-5.5mdv2008.0.i586
- jakarta-commons-httpclient-3.0.1-4.0.1mdv2008.0.i586
- jakarta-commons-launcher-1.1-1.4mdv2008.0.i586
- jakarta-commons-logging-1.1-3.3.1mdv2008.0.i586
- jakarta-commons-modeler-2.0-1.3mdv2008.0.i586
- jakarta-commons-net-1.4.1-5.0.0mdv2008.0.i586
- jakarta-commons-pool-1.3-9.2.2mdv2008.0.i586
- jakarta-commons-pool-tomcat5-1.3-9.2.2mdv2008.0.i586
- jakarta-oro-2.0.8-2.6mdv2008.0.i586
- java-1.5.0-gcj-1.5.0.0-14.14mdv2008.0.i586
- java-1.5.0-gcj-devel-1.5.0.0-14.14mdv2008.0.i586
- java-1.5.0-gcj-javadoc-1.5.0.0-14.14mdv2008.0.i586
- java-1.6.0-sun-devel-1.6.0.02-1.0.9mdv2008.0.i586
- java-cup-11a-7mdv2008.0.i586
- jdepend-2.9.1-1.0.2mdv2008.0.i586
- jetty5-5.1.12-1.0.5mdv2008.0.i586
- jline-0.9.9.1-1.0.2mdv2008.0.i586
- jsch-0.1.34-0.0.2mdv2008.0.i586
- junit-3.8.2-1.4mdv2008.0.i586
- junit4-4.3.1-1.2mdv2008.0.i586
- jython-2.2-1.0.2mdv2008.0.i586
- jzlib-1.0.7-5mdv2008.0.i586
- libgcj7-4.1.2-1mdv2007.1.i586
- libgcj7-base-4.1.2-1mdv2007.1.i586
- libgcj9-4.3-0.20070713.5mdv2008.0.i586
- libgcj9-base-4.3-0.20070713.5mdv2008.0.i586
- libgcj9-devel-4.3-0.20070713.5mdv2008.0.i586
- libreadline-java-0.8.1-1.4mdv2008.0.i586
- libswt3-gtk2-3.3.0-0.20.8mdv2008.0.i586
- log4j-1.2.14-8mdv2008.0.i586
- lucene-1.9.1-3.1.3mdv2008.0.i586
- lucene-contrib-1.9.1-3.1.3mdv2008.0.i586
- lucene-demo-1.9.1-3.1.3mdv2008.0.i586
- mx4j-3.0.1-4.7mdv2008.0.i586
- regexp-1.4-3.0.2mdv2008.0.i586
- rhino-1.6-0.r5.4mdv2008.0.i586
- sinjdoc-0.5-4.4mdv2008.0.i586
- tomcat5-5.5.23-9.2.10mdv2008.0.i586
- tomcat5-common-lib-5.5.23-9.2.10mdv2008.0.i586
- tomcat5-jasper-5.5.23-9.2.10mdv2008.0.i586
- tomcat5-jsp-2.0-api-5.5.23-9.2.10mdv2008.0.i586
- tomcat5-server-lib-5.5.23-9.2.10mdv2008.0.i586
- tomcat5-servlet-2.4-api-5.5.23-9.2.10mdv2008.0.i586
- ws-commons-util-1.0.1-6.1.1mdv2008.0.i586
- wsdl4j-1.5.2-3.3mdv2008.0.i586
- xalan-j2-2.7.0-2.7mdv2008.0.noarch
- xerces-j2-2.9.0-6mdv2008.0.i586
- xml-commons-1.3.03-5.5mdv2008.0.i586
- xml-commons-jaxp-1.3-apis-1.3.03-5.5mdv2008.0.i586
- xml-commons-resolver12-1.3.03-5.5mdv2008.0.i586
- xmlrpc3-client-3.0-1.4.3mdv2008.0.i586
- xmlrpc3-common-3.0-1.4.3mdv2008.0.i586
- zlib1-devel-1.2.3-8mdv2008.0.i586

Altri 536MB di spazio disco saranno utilizzati
--------------------------------------------------------------

non è un pò troppo?

ciao
max



Ritratto di Moreno
#4

Inviato da Moreno il Gio, 11/10/2007 - 17:41.

Re: Mandriva 2008.0 Far funzionare Eclipse

Ciao

Non saprei che dire, tieni conto che comunque viene installata tutta l'infrastruttura di sviluppo Java che non è proprio leggerissima.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.



Ritratto di ironmarc
#5

Inviato da ironmarc il Lun, 22/10/2007 - 10:50.

Re: Mandriva 2008.0 Far funzionare Eclipse

Confermo, è tutto normale! Lo so perché con eclipse ci lavoro parecchio Wink