Come ho installato il driver nvidia

Gio, 21/10/2004 - 09:51

Come ho installato il driver nvidia

Inviato da farthest 3 commenti

Salve, sono riuscito ad installare, finalmente, il driver nvidia!

Questa è la mia esperienza:

prima di tutto ho inserito in /etc/modprobe.preload "nvidia".

Poi ho modificato /etc/X11/Xorg.conf:

decommentato load "glx" e cambiato "nv" in "nvidia".

Poi ho estratto così il driver nvidia #./NVIDIA-Linux-x86-1.0-6111-pkg1.run -x

Poi ho modicato /NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv.c alla riga 3697 ho cambiato PM_SAVE_STATE in PM_SUSPEND_MEM.

Poi ho digitato nella cartella /NVIDIA-Linux-x86-1.0-6111-pkg1 #make install ed ho avviato, credevo di averlo installato ma non era così, al riavvio schermo nero.

Allora ho edittato /etc/inittab ho modificato "init:5..." in "init:3..." ed ho riavviato .
Quindi dalla console in /NVIDIA-Linux-x86-1.0-6111-pkg1 ho dgt nvidia-installer e l'istallazione è avvenuta(anche se non ci speravo).

Per ultimo startx e mi è partito!!

Ricordatevi di modificare /etc/inittab in "init:5..." !

Ciao, spero di esservi stato utile Laughing





Commenti

Ritratto di farthest
#1

Inviato da farthest il Gio, 21/10/2004 - 21:54.

FATE ATTENZIONE!

Ciao
dopo tante peripezie siamo arrivati alla conclusione si può disattivare gli agp,
Inserite nel file /etc/X11/XFREE86config nella sezione device: Option "NvAgp" "0" !!

oppure in lilo.conf, nel mio caso, inserite append "mem=nopentium" e attivate gli agp.
Per il momento va, se continua sistemo anche la guida definitivamente!!!

Ah un'altra cosa prima di digitare startx, non dimenticatevi modprobe nvidia da root!

Un ultima cosa, prima di procedere all'installazione sopra descritta ho scaricato il kernel source con il comando #urpmi kernel-source !!

Se avete problemi postatelo e vediamo!

Ciao



Ritratto di cirax
#2

Inviato da cirax il Lun, 25/10/2004 - 10:38.

NVidia Come li ho installati io...

Ho lanciato una console e mi sono loggato come root (su <invio> e relativa password) ed ho digitato telinit 3 (runlevel 3, interfaccia a linea di comado).

Dopo il crollo del server grafico ho effettuato il log-in come root, sono andato dove avevo scaricato il driver Nvidia ed ho eseguito il comando :

sh NVIDIA-Linux-x86-1.0-6111-pkg1.run ( il nome dipende dal driver che avete scaricato)

Parte un'interfaccia testuale che vi guida nell'installazione (io ho dato OK a tutto...)
Alla fine con VIM ho editato il file /etc/X11/XF86Config-4

eseguendo le seguenti modifiche :

Nella sezione "Module":
ho tolto il # a Load "glx" permettendone il caricamento.

Nella sezione "Device":
ho modifichiamo: Driver "nv" con Driver "nvidia".

Finita la procedura ho riavviato il sistema col comando telinit 6...

P.S. Wink mi sono avvicinato a Linux da pochi mesi e non penso di allontanarmi da lui in futuro...


"piscio sui pomponi e sui cilindri dispari!"
da Ed il polso del Joe Bar Team



Ritratto di Pinguino
#3

Inviato da Pinguino il Lun, 25/10/2004 - 23:10.

initlevel

Il problema dell'init pare sia relativo alla distro 10(.0) .. E' capitato anche a me di avere probelemi nello switch tra i vari runlevel..

CMq una volta assicurati di essere al runlevel 3 (senza modificare inittab, dovrebbe essere sufficiente digitare nella striscia di comando "telinit 3") si installano i driver (con le opportune modifiche nel caso dei driver 6111) quindi si modificano i file xfre86config e modules.preload con VI o chi per lui e quindi si riavvia.. tutto dovrebbe andare al suo posto.

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16