Si impalla Tutto!.... :( PROBLEMA Hardware O Software?... Help!...

18 risposte [Ultimo messaggio]
Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

Salve a tutti!....
l'oggetto esprime in manie sintetica e quanto più esplicita possibile il problema!....
il mio notebook è:
-ASUS A6J
-Ram: 2G
-HD: IDE 100G
OS è:
-Mandriva 2010.1(Scaricato dal sito ufficiale!) e aggiornato!
vi racconto la mia storia con la speranza che possiate aiutarmi!...
un mesetto fà o deciso di abbandonare Winzoz!...
da anni ho avuto in dual boot diverse distro di linux (Ubuntu, fedora, etc.)
dal momento in cui ho deciso di eliminare Windows usando più spesso linux ho natato questo problema!...
da allora o provato una buona parte delle distro linux più conosciute!... tutte mi hanno dato lo steaao problema!...
adesso sono approdato in Mandriva (avendone sentito parlare molto bene per stabilità etc.) e inizialmente mi trovavo benissimo!.... fin che il problema non è spuntato fuori nuovamente in questo modo:
meno di una settimana fà ho installato Mandriva 2010(desktop GNOME)
inizialmente tutto ok non avevo grandi problemi!... a parte qualche lacuna tecnica personale!...
dopo poco tempo (e Dopo aver installato qualche programma da add/remove) però il computer ha cominciato ad "impallarsi" continuamente (anche al ritmo di più volte al minuto e per la durata di diversi secondi) alcuni processi vanno in zombie e in quel momento si blocca praticamente tutto per diversi secondi l'unica cosa che mi fà fare è cambiare i desktop...
non sono riuscito a trovare nulla da nessuna parte riguardo questo problema!....
allora ho cominciato procedendo per tentativi!... quindi:
non avevo i driver video giusti installati: ho installato i driver video adatti alla mia scheda (Nvidia GEFORCE GO 7300) adesso funzione tutto 3D etc.
il problema continuava a persistere!....
mi sono detto sarà gnome?...
allora ho installato da aggiungi rimuovi il KDE 4
Il problema ancora persiste!....
ho notato oltresì che i comendi che dò durante i blocchi (come apri cartella sul desktop etc.) non vengono eseguiti subito ma al termine del blocco!...
secondo voi a cosa può essere dovuto tutto questo?....
cosa devo fare per eliminarlo?...
(non sò se le mie info vi bastano... per qualsiasi cosa chiedete!...)
please HELP!... (e scusate se vi stresso ma non ne posso proprio più!...)

Ritratto di johnthejocker
johnthejocker
(Guru)
Offline
Guru
Iscritto: 05/11/2006
Messaggi: 550

Ciao.
Da come lo descrivi sembrerebbe esserci un (o più di un) processo che, ad intervalli regolari, impegna la tua CPU al 100% rilasciando la risorsa quando ha finito di fare quello che deve fare (anche se non è una cosa normale, soprattutto se si considera che, in base a quello che dici, la cosa è avvenuta anche con altre distro)
Prova a verificare (tramite l'uso di top o degli strumenti grafici di sistema) cosa avviene con i processi e vedi se ne identifichi uno che si comporta stranamente. E in ogni caso evita, almeno finché non hai individuato il problema, di appesantire il sistema con gli effetti 3D o altri ammennicoli di utilità esclusivamente estetica.

A parte questo, o un problema hardware, sinceramente non saprei dirti, ma qui c'è gente infinitamente più esperta di me e sicuramente ne verrai fuori.

Desktop: HP m9180.it - Mandriva 2010.1 - Windows Vista HP - e altro... XD
Portatile: Packard Bell W3420 - Mandriva 2010.1 Cooker - Windows XP HE
PC Server Casalingo: Mandriva 2008

Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

Grazie mille per la risposta!.... Smile
avevo pensato al processo ma!...ho provato più volte ad aprire i programmi grafici di gestione del sistema am non me lo permette sino a quando tutto non torna normale!... e se snon già aperti si bloccano quindi nada!... Worried
e devo specificare (prima l'ò dimenticato e ti ringrazio per aver portato alla luc questa dimenticaza) non sono intervalli regolari!.... Worried
esiste qualcosa che registri tutti i processi della sezione in ordine temporale magari su un file di log per poi poterli controllare a posteriori?....
grazie ancora!...

Ritratto di niubbo75
niubbo75
(Monster)
Offline
Monster
Iscritto: 21/10/2008
Messaggi: 410

Quando ti si "impalla tutto" riesci ad accedere ad una consolle? (Ctrl + ALT +F3) Se si, digita il comando top almeno vedi qual'è il processo che impegna tutta la cpu.
Ciao ciao

Linux kernel 2.6.35.4-desktop-nrj.69mib x86_64 AMD Athlon(tm) 64 Processor 3500+ GNU/Linux nVidia GeForce 7300 LE - KDE 4.4.3 on Mandriva Linux 2010.1, ofcourse! Rappresentante Italiano Mandriva (per suggerimenti, critiche o altro contattatemi in privato)

Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

Grazie per la risposta!....
 ma mi apre la consol solo dopo che il blocco è finito e se è già aperta non me la fa usare!...
a quel punto il processo "fallato" non è più in atto o quanto meno non è piò rilevante tale lettura!.... o sbaglio?...
grazie comunque!....

Ritratto di attila_warrior
attila_warrior (non verificato)
()

6 sicuro di aver usato la combinazione di tasti che ti hanno consigliato? (cioè non aprire "konsole" o "gnome-terminal" da interfaccia grafica).
Se non ti fa fare nemmeno il cambio, vuol dire che si incarta a livello di x11 e pertanto l'unica cosa che mi viene in mente è un problema alla scheda video.
Con ogni probabilità si tratta di un problema di driver (se fosse un problema hardware si dovrebbe riavviare il pc) - Non credo che linux riesca a "gestire" un problema di video ram difettosa.
Attendo conferme (in quanto non sono per nulla sicuro di quanto ho scritto)
saluti
attila

PS: cmq mi pareva esistessero dei log dove poter verificare l'attività del pc quando non risponde o da problemi... (nn so dove, ma ci dovrebbero essere)

Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

grazie per la risposta!... Smile
con la giusta sequenza di tasti non mi permette di accedere fino alla fine del blocco!.... Worried
escluderei il problema hardware alla scheda video altrimenti dovrebbe fare caschette anche con winzoz che mi darebbe schermata blu!...(e fortunatamente non lo fà XD)
per quanto riguarda i drivers non saprei!.... mandriva stesso mi ha installato quelli che ha chiamato "driver proprietari" ma ho notato che la mia Nvidia 7300 GO la legge come una 6600 ma funziona tutto bene graficamente lo stesso(forse è compatibile!)!...
potrebbe essere questo il problema?...
se si dove vado a pescare i drivers per la mia scheda video?.... Worried
oppure esiste un modo per aggirnare magari l'X11?
ho trovato solo quello per mac!... Worried
(la cosa che mi rende schettico è che anche con altre distro (es ubuntu o altri) anche più
vecchie si bloccava quindi o non è cambiato il driver o non sò!)
grazie!...

Ritratto di attila_warrior
tom2004 (non verificato)
()

hai mica visto se quando si impalla rimane accesa
fissa la lucetta che segnala attivita' del disco?

Ciao

Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

grazie mille!...
riguardo l'attività disco ho notato che si blocca anche quello (cioè non segnala nulla)!....
fino alla fine del blocco quando ha una forte attività per uno/due secondi circa!...
grazie!...

Ritratto di attila_warrior
tom2004 (non verificato)
()

prova a lanciare questo script:

#!/bin/bash
while [ 1 ]
do
date >> dati.txt
  /bin/ps aufx >> dati.txt
  sleep 120
done

ogni 2 minuti scrive in un file di nome dati.txt
l'ora corrente e un po' di informazioni su
tutti i task che stanno girando nella tua macchina.

se ti si impalla mentre questo script gira potrebbe dirci tante cose...
ciao

Ritratto di niky
niky
(Junior)
Offline
Junior
Iscritto: 15/02/2010
Messaggi: 22

grazie davvero!....
ma lanciando lo script la situazione evolve in maniera normale non si blocca ne restituische errori di sorta!...
(non sò se devo cercare qualcosa di preciso nelle riche del file ma a prima vista sembra tutto normale!...)
grazie mille per l'interessamento!....