processo appesi ad applicazioni chiuse,, memoria non rilasciata

13 risposte [Ultimo messaggio]
Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Salve !

Ho notato, dal monitor di sistema, che alcune applicazioni (segnatamente clementine e firefox) una volta chiuse, restano col processo appeso, e conseguentemente non rilasciano la memoria. C'è un anomalia o è tutto normale? Non mi pare succedesse qualcosa di simile con 2010.2. Ma...non era Windows il SO operativo 'isterico' (cioè con effetto isteresi di memoria) ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 156

per clementine vedi se è il tuo caso:

http://wiki.mandriva.com/en/2011.0_Errata#Clementine_still_uses_100.25_CPU_after_it_is_closed

non è che ce l'hai nella systray, come è successo a me Smile ?

Ciao, Luca.

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Ho tolto dalla barra (systray, vicino a kmix e agli altri), ed il processo rimane appeso, prende anche unpò di CPU. Firefox di sicuro era chiuso.

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Allora:
ho seguito il consiglio al link che mi hai segnalato: ho cambiato la stringa in quel file e pare che ora le cose funzionano per clementine.
I tuoi consiglii sono sempre tempestivi ed efficaci, grazie !

Rimane il problema di firefox...

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 156

e se a naso proviamo:

$ env __GL_NO_DSO_FINALIZER=1 firefox

è un tentativo disperato, lo so.

per firefox faccio fatica ad aiutarti perchè la 2011.0 ce l'ho solo in macchina virtuale quindi un ambiente completamente differente dal tuo.

Però firefox non mi rimane in memoria se non per pochi secondi dopo la chiusura.

Potresti anche provare ad installare una versione più recente di firefox.
Quello che descrivi sembra un problema di "memory leak": il programma chiude, ma non rilascia la memoria utilizzata.
Sul MIB c'è la 9.0.1.

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Ma! Non so...il fatto è che, mentre clementine aveva questo problema in permanenza, firefox lo fa spesso ma non sempre. In effetti, avevo notato qualcosa del genere anche con le versioni di Mandriva precedenti, mi pare proprio con la 2010. Forse è un problema del browser.

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 156

ho modificato il mio messaggio precedente...

la storia di firefox sembra costellata da memory leaks..

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

La versione di firefox su cui scrivo è proprio la 9.0. presa dal MIB.

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 156

tra 9.0 e 9.0.1 dovrebbero aver:

"Fixed several stability issues"

altrimenti io sto usando la 10.0 beta installata a manina che te la puoi installare sotto l'utente e provare senza rimuovere l'altra. tanto per trovare il colpevole

Ciao, Luca.

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Grazie, ma preferisco aspettare il rilascio della versione ufficiale. Temo di fare pasticci, e tutto sommato anche così, le cose funzionano abbastanza bene.

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 156

per curiosità cosa usi per vedere l'uilizzo della memoria?

sembra comunque un problema storico del browser: http://support.mozilla.org/en-US/questions/906432

Ciao, Luca.