Rallentamento improvviso KDE

6 risposte [Ultimo messaggio]
Ritratto di ipplis
ipplis
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 188

Immprovvisamente KDE e' diventato ultralento,risponde ai comandi mouse e tastiera in tempi lunghissimi, al punto che pensavo inizialmente che fosse un blocco di sistema.Il problema riguarda solo l'utente principale e e KDE. L'utente XGuest funziona perfettamente. Il rallentamento si manifesta gia alla schermata iniziale: "Avvio del gestore delle finestre". Al momento del blocco non stavo facendo niente di particolare, avevo appena installato il pacchetto KoverArtist e stavo navigando con Firefox. Ho provato vari riavvi ma la cosa non si sistema. Qualche idea ? Saluti. (Mandriva 2010.2 x 64 , notebook Acer Aspire 5720, kernel 2.6.36.4-desktop-69mib, KDE 4.4.5.

Ritratto di Army75
Army75
(Guru)
Offline
Guru
Iscritto: 19/10/2005
Messaggi: 507

Ciao,
inizia a fare queste operazioni:

apri un terminale (se kde e` lento usa xguest) e vedi se la home dell'utente principale o la root "/" sono pieni, per farlo digita un df -h e posta qui il risultato.
Se riesci entra in kde con l'utente principale e da shell digita top cosi` vedi se c'e` qualche processo che porta la CPU a valori molto alti (98%-100%).

Fammi sapere cosa scopri.

Ciao
Armando

2010.2 Official - KDE 4.4.2 - Gnome 2.30.0 -- kernel 2.6.36.2 server on HP Pavilion dv5- AMD Athlon x2 - only official repo

Ritratto di ipplis
ipplis
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 188

Grazie per il tempestivo consiglio.Fino a lunedi ormai non posso fare nulla , rapidamente ho potuto solo per ora vedere che il volume di /root e' occupato al max per circa il 30%. Vi faro' sapere altro da lunedi' poiche il notebook sta su posto di lavoro. Ciao.

Ritratto di ipplis
ipplis
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 188

Rieccomi. Allora,per lo spazio in uso c'e' questo:

[root@localhost ~]# df -h
File system Dim. Usati Disp. Uso% Montato su
/dev/sda3 49G 5,7G 41G 13% /
/dev/sda4 89G 15G 75G 17% /home
/dev/sda1 157G 32G 125G 21% /media/windows

Il comando "top", di cui non riesco a stampare l'output, non evidenzia occupazione della CPU per nessun processo supeiore al 4% . Ho anche cancellato i contenuti delle cartelle tmp e riavviato, ma senza risultato. Posso solo usare il sistema da konsole o come utente XGuest e basta.

Ritratto di Army75
Army75
(Guru)
Offline
Guru
Iscritto: 19/10/2005
Messaggi: 507

Ciao,
a queso punto credo ci sia una qualche impostazione in kde che causa il rallentamento. Procedi cosi`:
da root in terminale (con kde chiuso/non ancora avviato) fai un
mv /home/tuo_user/.kde4 /home/tuo_user/.kde4.ori
mv /home/tuo_user/.kde /home/tuo_user/.kde.ori
In questo modo resettiamo le impostazioni di kde mantenendone una copia di backup.
Ora puoi avviare nuovamente kde com faresti normalmente..

Fammi sapere cosa accade

Ciao

Armando

2010.2 Official - KDE 4.4.2 - Gnome 2.30.0 -- kernel 2.6.36.2 server on HP Pavilion dv5- AMD Athlon x2 - only official repo

Ritratto di ipplis
ipplis
(Geek)
Offline
Geek
Iscritto: 31/05/2005
Messaggi: 188

Evviva ! E'tornato tutto a posto. Anche se nella fretta ho pasticciato un po'nella sintassi dei due comandi...Comunque mi ha restituito il desktop con le impostazioni originali, e a una prima ricognizione sembra tutto OK. Grazie dell'aiuto. ma cosa puo' essere successo ? Ciao.

Ritratto di Army75
Army75
(Guru)
Offline
Guru
Iscritto: 19/10/2005
Messaggi: 507

Sono contento che abbiamo risolto il problema, non so quale file si e` "sconfigurato" ma sicuramente era dentro la tua .kde4. Ricordati i comandi dati se dovesse riaccaderti.
Ciao

Armando

2010.2 Official - KDE 4.4.2 - Gnome 2.30.0 -- kernel 2.6.36.2 server on HP Pavilion dv5- AMD Athlon x2 - only official repo