Mandrake 10.1/ Problema aMule e VLC

7 risposte [Ultimo messaggio]
Ritratto di Flavio
Flavio
(Junior)
Offline
Junior
Iscritto: 02/08/2005
Messaggi: 7

Buongiorno a tutti,
ho cominciato da poco con Linux, ed ho un problema di installazione del mio Mandrake )2.6.8.1-12mdksmp i686), vorrei far funzionare aMule e VLC.
Dunque, la cosa è così, vado nel Centro di controllo / Gestione Software e comincio a cercare ...... e sperare ....

Sul sito di aMule trovo la fonte:
ftp://mandrivauser.de/rpm/GPL/ise/10.1/RPMS/
Metto a giorno la mia Gestione Sorgenti RPM, Aggiorno, e magia! Trovo la versione di aMule seguente:
amule-2.0.3-2.1.101ise.i586.rpm

Rimuovo tutto quello che inizia con Wx, come indicato su http://www.amule.org/wiki/index.php/HowTo_Compile_In_MDK, installo
wxGTK2 v2.6.1 da ftp://mandrivauser.de[...] )e non la versione 2.5) e amule-2.0.3.

Litigo con il Router, DHCP e annessi vari, e ... FUNZIONA! Scarico allegramente )tra l'altro aMule si è installato solo nel mio account, peccato). Ma, dopo aver scaricato allegramente, decido che i file si devono vedere/ascoltare con VLC.

Un giro su www.videolan.org/vlc/download-mandrake.html, torno nel Centro di controllo, installo vlc-8.2-4.1.101plf con annessi vari e in seguito, provo con wxvlc-0.8.0-0.test2.3plf.

Niente da fare, il solo selezionare wxvlc mi blocca il centro di controllo, casino, reboot. Riprovo, niente, non si può selezionare il pacchetto wxvlc. VLC non parte, morto.

Nei Forum si parla di problemi di Wx con aMule, del fatto che installando wxGTK2 non va VLC, non ho trovato niente di utile.

Boh, aiuto.

Flavio - Ma non mollo Linux-

Ritratto di lillox
lillox
(Guru)
Offline
Guru
Iscritto: 29/10/2004
Messaggi: 803

cerca solo vlc
oppure
#urpmi vlc
una volta installato da amule cerca apri video con e selezioni
/usr/bin/vlc setta pure di scaricare la parte iniziale e finale di un video
dopo aver scaricato una cinquantina di mega potrai vedere l'anteprima
ciao
dimenticavo hai aggiunto i repo plf nei tuoi repos?

linux user 384443

http://counter.li.org/

Ritratto di Flavio
Flavio
(Junior)
Offline
Junior
Iscritto: 02/08/2005
Messaggi: 7

Provato,
vlc c'è ma non parte.

Tutti i repo (plf,....) sono nei miei repos.

Mah....

Grazie, Flavio

Ritratto di lillox
lillox
(Guru)
Offline
Guru
Iscritto: 29/10/2004
Messaggi: 803

da shell vlc
e vedi cosa ti ritorna

linux user 384443

http://counter.li.org/

Ritratto di Flavio
Flavio
(Junior)
Offline
Junior
Iscritto: 02/08/2005
Messaggi: 7

Si fa sempre più interessante,

# urpmi libdvdcss2 libdvdplay0 wxvlc vlc-plugin-a52 vlc-plugin-ogg vlc-plugin-mad
Alcuni dei pacchetti richiesti non possono essere installati:
vlc-0.8.2-4.1.101plf.i586 (perchè manca vlc-plugin-mad-0.8.0-0.test2.2mdk.i586)
vlc-plugin-a52-0.8.2-4.1.101plf.i586 (perchè non è soddisfatto vlc[== 0.8.2])
vlc-plugin-mad-0.8.2-4.1.101plf.i586 (perchè non è soddisfatto vlc[== 0.8.2])
vlc-plugin-ogg-0.8.2-4.1.101plf.i586 (perchè manca vlc-plugin-mad-0.8.0-0.test2.2mdk.i586)
Continue? (S/n) n

E fin qui ho fatto tutto quello che nel sito VLC si diice di fare, poi, non sò, adesso riprovo da capo, vi farò sapere.

Grazie, Flavio

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

Domanda: non so se fa differenza ma: non è che hai installato vlc "a mano" (cioè senza attingere ai repository mandriva?)

Domanda 2: Amule 2.0.3 DOVREBBE esistere anche in PLF, senza attignere a repository esterni prova a rimuovere quel repository che hai aggiunto!

Last but not least: prova semplicemente a lanciare urpmi vlc per installare vlc e vedi che succede.

Ciao.

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di Flavio
Flavio
(Junior)
Offline
Junior
Iscritto: 02/08/2005
Messaggi: 7

Buonasera a tutti,
ecco un'altra tappa del mio penoso tentativo di installare VLC:

In linea di massima non fa differenza come si installa (mi pare che senza comandi contrari, con #urpmi, Mandrake prende i .plf per una questione di ordine nei nomi).

Amule, funziona magicamente: Uploda e Downloda al massimo anche quando è disconnesso (vero).

Ecco poi un paio di tentativi con VLC:

# urpmi libdvdcss2 libdvdplay0 wxvlc vlc-plugin-a52 vlc-plugin-ogg vlc-plugin-mad
Alcuni dei pacchetti richiesti non possono essere installati:
wxvlc-0.8.0-0.test2.2mdk.i586
wxvlc-0.8.0-0.test2.3plf.i586
Continue? (S/n) s
Per soddisfare le dipendenze, saranno installati i seguenti 4 pacchetti (10 MB):
vlc-0.8.2-4.1.101plf.i586
vlc-plugin-a52-0.8.2-4.1.101plf.i586
vlc-plugin-mad-0.8.2-4.1.101plf.i586
vlc-plugin-ogg-0.8.2-4.1.101plf.i586
E' corretto? (S/n) s

ftp://ftp.easynet.fr/plf/mandrake/free/10.1/./i586/vlc-plugin-ogg-0.8.2-4.1.101plf.i586.rpm
ftp://ftp.easynet.fr/plf/mandrake/free/10.1/./i586/vlc-0.8.2-4.1.101plf.i586.rpm
installazione di /var/cache/urpmi/rpms/vlc-plugin-a52-0.8.2-4.1.101plf.i586.rpm /var/cache/urpmi/rpms/vlc-plugin-mad-0.8.2-4.1.101plf.i586.rpm /var/cache/urpmi/rpms/vlc-0.8.2-4.1.101plf.i586.rpm /var/cache/urpmi/rpms/vlc-plugin-ogg-0.8.2-4.1.101plf.i586.rpm
In preparazione... ##################################################
1:vlc-plugin-a52 ##################################################
2:vlc ##################################################
3:vlc-plugin-mad ##################################################
4:vlc-plugin-ogg ##################################################

# urpmi wxvlc

E dopo questo comando si blocca tutto, rimane lì e non si muove.

PS: Ho ri-ri-riaggiornato TUTTE le fonti, cambiando già che c'ero anche i Mirror (boh, non si sa mai)

VLC è installato
$ vlc
VLC media player 0.8.2 Janus
Interfaccia comando a distanza inizializzata, `h' per un menu d'aiuto

Ma parte solo con la GUI Skinned (0.8.2-4.1.101plf) e non con GTK+ (wxGTK2.6)

Sono sconfortato (in più la mia morosa mi domanda come mai sono passato a Linux....)

Per un po' ci rinuncio.
Ciao a tutti e scusate gli sfoghi!
Flavio

Ritratto di peste
peste
(Guru)
Offline
Guru
Iscritto: 28/03/2005
Messaggi: 849

Quote:

Flavio ha scritto:

Sono sconfortato (in più la mia morosa mi domanda come mai sono passato a Linux....)

Per un po' ci rinuncio.
Ciao a tutti e scusate gli sfoghi!
Flavio

ciao,
per VLC non posso aiutarti. pero' alla tua morosa puoi sempre dire che sei passato a linux perché ne avevi abbastanza di schermi blu, di "questo programma ha eseguito un'operazione non valida e sarà terminato", di virus e trojan horses, di programmi che per poterli usare o spendi una cifra o sei costretto a craccarli e la lista potrebbe continuare più o meno all'infinito.
non ti arrendere cosi facilmente... fa parte del "gioco" superare le difficoltà e il bello dell'opensource è che, prima o poi grazie agli altri, ci si riesce!
a presto,
peste Smile

Mandriva 2009.0 Cooker - Kernel 2.6.26-desktop586-rc8
- KDE 4 - P4 3.0Ghz - 1024Mb RAM - ATI Radeon 9600 Pro - Grub Boot Loader