L'audio ha smesso di funzionare-acer 6920g [Risolto]

75 risposte [Ultimo messaggio]
Ritratto di Laf
Laf
(Geek)
Offline
Geek
Iscritto: 10/09/2010
Messaggi: 68

Ciao! Ennesimo problema!
Questa mattina l'audio ha improvvisamente smesso di funzionare..ho guardato un po in giro ma faccio un pò di fatica a capire.. Al centro di controllo se vado in configura audio ho questo: la scheda ora utilizza il driver Alsa "snd_hda_intel" (il driver predefinito era "snd_hda_intel)..
Non so se può aver causato il problema ma ieri dopo aver installato dei pacchetti un messaggio mi ha avvisato dicendo che dei pacchetti erano orfani e che se volevo potevo cancellarli con urpme --auto-orphans o qualcosa del genere.. l'ho fatto, ma dopo comunque tutto funzionava fino a stamattina.
La scheda audio è:
8280 1H (ICH8 Family) HD audio controller
Spero possiate aiutarmi!
Ciaoo

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Temo tu sia un altra vittima dei pacchetti finti orfani, fortunatamente il problema è già stato evidenziato anni fa qui usando il programma rpmorphan.

Dai il comando

urpmi libalsa-plugins libalsa-plugins-jack libalsa-plugins-pulseaudio

e per sicurezza riavvia la macchina.

Dovrebbe tornare tutto alla normalità.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Laf
Laf
(Geek)
Offline
Geek
Iscritto: 10/09/2010
Messaggi: 68

Ciao Moreno, grazie per la tua disponibilità!
Ho eseguito il comando -qualcosa effettivamente mancava, ho riavviato il pc ma il problema purtroppo persiste. Ora che ricordo, l'ultima azione prima del problema è stata l'installazione di alcuni pacchetti per dragon player, non so se questo può aver causato il tutto.

Ritratto di GiuseppeS
GiuseppeS
(Monster)
Offline
Monster
Iscritto: 01/07/2006
Messaggi: 245

Secondo me è un problema dei kernel driver. Per fare andare le cuffie ho dovuto installare il kernel in coocker.
Intanto puoi provare se siano dassi i voluni. Installati un mixer alsa, ce ne sono diversi nei repos. e controlla. Spunta anche il checkbox smart 5.1 e abilita in mcc pulse 5.1.

Se proprio non funziona segui qunto scritto qui sotto. E' una piccola guida che ho scritto trovata in giro su internet per eventuali e future rogne.

Utente che ha trovato la soluzione
http://www.mandrakeitalia.org/utenti/marcin

Ho un portatile Asus N61JQ con mandriva 2010.1 64 bit e con chipset audio Realtek ALC269 (ICH7 southbridge HD-audio) che gestisce un microfono interno, jack microfono, audio stereo per speaker del portatile, jack cuffie, uscita digitale 5.1 s/pdif su jack cuffie, audio HDMI. Il driver utilizzato da alsa è snd_hda_intel. L'audio e il microfono funzionano, ho riportato kmix alle origini disattivando il controllo di pulseaudio come da guida per avere più opzioni dirette sulla scheda. Il problema è che non è presente lo switch "headphone jack sense", neanche su alsamixer, perciò inserendo le cuffie gli altoparlanti del portatile continuano a funzionare.  Non mi è stato possibile trovare un modo per ascoltare dall'uscita cuffie con altoparlanti del pc spenti.

Soluzione

Dal centro di controlo di mandriva selezionare  hardware->elenca e configura l'ardware
Selezionare: schede audio->Device aa60
Selezionare: impostazioni del driver in uso
Completare i campi:
model auto
enable yes

riavviare e torna tutto a posto!!
P.S. i passaggi equivalgono all'aggiunta della riga:

options snd_hda_intel enable=yes model=auto

nel file /etc/modprobe.conf

Soluzione mia:
Abilitare pulse-audio a 5.1 in configura audio.

Link utili:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;h=13cba955cb5af313a2c2cc0866666766ef56a40a;hb=b620cc2cd80393b9a0f9a76806cb7f9e91671dac;f=Documentation/sound/alsa/ALSA-Configuration.txt

http://alsa.opensrc.org/Hda

Scusate la formattazione ma non so come farla con questo sistema.

al posto di questa:
options snd_hda_intel enable=yes model=auto

Puoi mettere anche
options snd_hda_intel enable=yes model=test

e ravviare il tutto.
Test fa dei test all'avvio e sistema alcune cose in un secondo tempo puoi anche toglielo.

Ciao, Giuseppe.

Ciao
Giuseppe

Ritratto di Laf
Laf
(Geek)
Offline
Geek
Iscritto: 10/09/2010
Messaggi: 68

Grazie anche a te Giuseppe, ho eseguito tutto alla lettera ma nulla è cambiato!

Ritratto di GiuseppeS
GiuseppeS
(Monster)
Offline
Monster
Iscritto: 01/07/2006
Messaggi: 245

Purtroppo questa dell'audio è ancora una cosa che mi manda in bestia in questa distro.
Io ho cercato di sistemare con MOLTA pazienza i volumi ma penso sia stata una fortuna farlo funzionare.
@Moreno
qual'è il comando per vedere i file orfani?
Magari dandogli la mia lista torna a funzionare. Non li ho rimossi per prudenza e alla fine credo di aver fatto bene.

Ciao, Giuseppe.

Ciao
Giuseppe

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

La mia era solo una supposizione dovuta alla coincidenza del problema con l'eliminazione dei pacchetti orfani.

Sinceramente non so quali siano i comandi urpmi per gestire i pacchetti orfani, mi pare che questa cosa al momento sia ancora parecchio per aria.

Purtroppo potrebbero benissimo essere i vari tentativi di far ripartire l'audio ad averlo ammazzato definitivamente.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Laf
Laf
(Geek)
Offline
Geek
Iscritto: 10/09/2010
Messaggi: 68

p { margin-bottom: 0.21cm; }

Hola!

Allora ci sono novità, sembra che
l'audio non sia del tutto morto..ieri sera smanettando un po' sono
riuscito a riaverlo, anche se per poco.

Andando su regolazione del volume
pulseaudio->configurazione->profilo, cambiando da Digital
Stereo(IEC958) Output+analog stereo output (che era di default) ad
Analog Sorround 4.0 output + analog stereo input, ho riavuto per
qualche secondo l'audio, che dopo pochi secondi ha iniziato a
gracchiare stranamente fino ad esaurirsi. Ho provato a cambiare varie
impostazioni ma nulla!

A questo punto non credo sia del tutto
morto ed escludo un problema della scheda audio poiché in windows
tutto funziona correttamente.

Cosa ne pensate?

Ritratto di Fabio75
Fabio75
(Guru)
Offline
Guru
Iscritto: 30/04/2007
Messaggi: 829

Prova a cancellare la cartella nascosta di .pulseaudio e a riavviare

Ritratto di GiuseppeS
GiuseppeS
(Monster)
Offline
Monster
Iscritto: 01/07/2006
Messaggi: 245

Bene.
Quando inizia a gracchiare vuol dire che sei sulla strada buona. Infatti anche a me ha iniziato così e poi al riavvio funzionava.

controlla i volumi
io ho dovuto sistemare bene i due front-in finché non gracchiavano. al riavvio si sentiva tutto.

Ciao, Giuseppe.

Ciao
Giuseppe

Ritratto di Laf
Laf
(Geek)
Offline
Geek
Iscritto: 10/09/2010
Messaggi: 68

Ciao. Ho un dubbio:
In /home ho una cartella nascosta .pulse - entrando ho .directory nascosta..
In home/.gconf/system  ho pulseaudio ed entranovi ho sepre .directory..
Cosa devo cancellare?