google earth su 2010.1 /64 non parte

39 risposte [Ultimo messaggio]
Ritratto di LeoEdre
LeoEdre
(Monster)
Offline
Monster
Iscritto: 21/01/2007
Messaggi: 371

Citazione:

@leoedre: che freetype hai? mdv o plf?

 
 mdv

Ritratto di yoshi
yoshi
(Monster)
Offline
Monster
Iscritto: 25/02/2008
Messaggi: 313

Citazione:

@yoshi: l'accelerazione hardware è abilitata? (verifica in mcc -> hardware -> sistema grafico)

  
 

non era abilitato , ho provato ad abilitare ma il risultato è negativo .

cliccando sul icona  appare questo avviso : " KDEInit non è riuscito ad avviare «/home/roberto/google-earth//googleearth»"

grazie

ciao

 

Ritratto di Schizoid
Schizoid
(Guru)
Offline
Guru
Iscritto: 27/10/2006
Messaggi: 695

@leoedre: prova ad abilitare i repo plf e aggiorna quelle librerie, forse (sottolineo forse) risolvi

@yoshi:ma le librerie mesa sono installate? ("urpmi mesa-demos" se le porta tutte in caso)

Mandriva x64 2010.0 MIB
Acer Aspire 5935G (Core2 Duo P7450 - 4Gb RAM - Nvidia GeForce GT 130M)

Ritratto di yoshi
yoshi
(Monster)
Offline
Monster
Iscritto: 25/02/2008
Messaggi: 313

ho installato le " mesa-demos " ora ,  google earth  non parte come al solito ,inoltre  le sue icone ,desktop e menu avvio, con il mappamondo sono sparite ,ora c'è un icona come un file con un "? " . invece dal terminale mi risponde con un : " googleearth  ./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory".
allora , come ho detto sopra ,questa libreria non so dove trovarla , quelle che ho trovato non so se possono andare , (   non 64bit , nvidia , 2010)
grazie
ciao

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

Citazione:

ho installato le " mesa-demos " ora ,  google earth  non parte come al solito ,inoltre  le sue icone ,desktop e menu avvio, con il mappamondo sono sparite ,ora c'è un icona come un file con un "? " . invece dal terminale mi risponde con un : " googleearth  ./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory".
allora , come ho detto sopra ,questa libreria non so dove trovarla , quelle che ho trovato non so se possono andare , (   non 64bit , nvidia , 2010)
grazie
ciao


 Se ricordo bene, questo messaggio indica che il tuo 3d non è attivo.

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di yoshi
yoshi
(Monster)
Offline
Monster
Iscritto: 25/02/2008
Messaggi: 313

accelerazione 3D , avevo già provato ; ma riprovando adesso ,ho visto che non la prende , cioè dal mcc ,opzioni grafiche io spunto acclerazione 3D , poi do ok ,se  riapro la schermata  ,l'accelerazione non è selezionata ; conferma il fatto che non la prende ,non mi chiede di uscire dalla sessione come con tutte le altre modifiche fatte in questa sezione.
grazie in anticipo
ciao

Ritratto di disegnoarch
disegnoarch
(Geek)
Offline
Geek
Iscritto: 25/04/2006
Messaggi: 105

Ciao Ciao a tutti, se non avete già risolto i problemi con questo programma e se volete provare la vostra pazienza  guardate cosa  è capitato a me. Aggiungo che la versione trovata nell'elenco da C.C. mi ha dato  lo stesso genere di problemi che avete illustrato ed anche che ho cercato il sotto riportato plugin libmoon in ,

http://mirror.corbina.net/pub/Linux/mandriva/official/2010.0/i586/media/contrib/relase/
ma non riesco ad installarlo.
[pietro@localhost Scaricati]$ su
Password:

[root@localhost Scaricati]# chmod 777 Google*
[root@localhost Scaricati]# sh GoogleEarthLinux.bin
sh: GoogleEarthLinux.bin: No such file or directory
[root@localhost Scaricati]# ./Google*
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.2.1.1588..............................................................
loki_setup: Valore di dimensione sospetto per l'opzione option

loki_setup: Valore di dimensione sospetto per l'opzione option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...

** (process:8454): WARNING **: libmoonmp-plugin: Could not find Moonlight's libmoonloader plugin
** (process:8454): DEBUG: libmoonmp-plugin: NP_Initialize (0xa6a29cd4, 0xa6a29c98)

** (process:8454): WARNING **: libmoonmp-plugin: Could not call NP_Initialize from libmoonloader (NULL)
djview: QDjViewPlugin::exec() begin
** (process:8454): DEBUG: NP_Initialize
** (process:8454): DEBUG: NP_Initialize succeeded
OpenOffice path is '/usr/lib/ooo'
OpenOffice path is '/usr/lib/ooo'
** (process:8454): DEBUG: NP_Initialize
** (process:8454): DEBUG: NP_Initialize succeeded
** (process:8454): DEBUG: NP_Initialize
** (process:8454): DEBUG: NP_Initialize succeeded

(process:8454): GLib-GObject-CRITICAL **: gtype.c:2706: You forgot to call g_type_init()

(process:8454): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:8454): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Google Earth has caught signal 11.

We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /root/.googleearth/crashlogs/crashlog-4c8a7a42.txt

Please include this file if you submit a bug report to Google.
[root@localhost Scaricati]# java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (mandriva-6.b18mdv2010.1-i386)
OpenJDK Client VM (build 14.0-b16, mixed mode)
Ciao Pietro

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Non ci vedo nulla di strano Google Earth non è compatibile x86_64

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di gioli
gioli
(Monster)
Offline
Monster
Iscritto: 16/12/2006
Messaggi: 382

anche a me dà questo errore cercando di avviarlo da terminale

Citazione:

$ googleearth
./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

      
@ Moreno: vuoi dire che Googleearth non è compatibile con i sistemi  64 bit e che per il momento non c'è verso di farlo funzionare ?

post edit
la soluzione del problema è installare libmesagl1, vedi risposta n° 39

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Tutti i programmi a 32 bit possono essere teoricamente fatti funzionare su di una piattaforma a 64, il problema è quante dipendenze a 32 bit bisogna installare perché il programma funzioni, a volte questo numero è davvero alto e può arrivare anche a compromettere il funzionamento della macchina.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.