GDesklets problema dipendenze

1 risposta [Ultimo messaggio]
Ritratto di Amargosa
Amargosa
(Geek)
Offline
Geek
Iscritto: 30/09/2004
Messaggi: 80

Ho scaricato Gdesklets formato rpm per Mandrake 10.X

Premetto ke io posseggo Mandrake PowerPack 10.0

Avviando l'rpm mi da errore nelle dipendenze

"Alcuni dei pacchetti richiesti non possono essere installati:
gdesklets-0.34.3-1mdk.i586 (perchè non è soddisfatto libhowl.so.0)
confermi? "

scarico libhowl e lo installo

mi dice ke non è soddisfatto /sbin/postun_ldconfig[*]

come ne esco fuori?

ho provato a scaricare i lsorgente e a ricompilarlo
appena digito make mi dice he gnome-python è inferiore alla versione richiesta. Allora scarico gnome-python e mi dice che non posso installarlo perchè la versione di python è inferiore a quella richiesta, scaricho python e mi dice che gnome-python non è inferiore alla versione richiesta.

Sto impazzendo.

Qualcuno ha qualche suggerimento?

I bravi artisti copiano, i grandi artisti rubano. Love Struck Love Struck

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

La situazione è tipica dei tentativi di installazione di pacchetti di altre versioni con dipendenze profonde.

L'unica cosa che si potrebbe tentare è quella di utilizzare l'opzione --nodeps nell'installare i pachhetti ma sicuramente alla fine non funzionerà più niente.
Occorrerebbe infatti comunque conoscere tutte le dipendenze e soddisfarle manualmente e magari arrivare alla fine e scoprire che c'è una dipendenza con gcc.

Direi di lasciare perdere o pensare ad un bell'aggiornamento a LE2005, la trovi in edicola con LinuxMagazine.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.