Freepops

17 risposte [Ultimo messaggio]
Ritratto di Lando
Lando
(Monster)
Offline
Monster
Iscritto: 04/08/2005
Messaggi: 213

Vorrei installare Freepops . L' rpm l' ho scaricato da
http://www.moreno.m-2.it/cookerathome/freepops.html

ma le dipendenze non riesco a trovarle...con google ci sono tanti riferimenti a libc.so.6 e libcurl.so.3 ma mi sembrano far parte di altri prodotti......(anche perche' non so cosa sono !!!).
C'e' una buonanima che mi aiuta ?
Molte grazie !

$ rpm -iv freepops-0.0.31-3ddz.i586.rpm
error: Failed dependencies:
libc.so.6(GLIBC_2.3.4) is needed by freepops-0.0.31-3ddz
libcurl.so.3 is needed by freepops-0.0.31-3ddz

Ritratto di topgun
topgun
(Junior)
Offline
Junior
Iscritto: 26/07/2005
Messaggi: 31

Le librerie che cerchi le dovresti trovare anche attraverso il comando urpmi se hai impostato i mirror.Io ho installato la stessa versione tua di freepops ma non mi ha dato alcun problema di dipendenze.

Ritratto di Lando
Lando
(Monster)
Offline
Monster
Iscritto: 04/08/2005
Messaggi: 213

Quote:

topgun ha scritto:
Le librerie che cerchi le dovresti trovare anche attraverso il comando urpmi se hai impostato i mirror.Io ho installato la stessa versione tua di freepops ma non mi ha dato alcun problema di dipendenze.

Mi puoi dire il nome dei miror da inserire ??????????i

Ritratto di topgun
topgun
(Junior)
Offline
Junior
Iscritto: 26/07/2005
Messaggi: 31

http://www.mandrakeitalia.org/modules/wfsection/article.php?articleid=40

Ti consiglio questa guida. è spiegato tutto molto bene.

Ritratto di Lando
Lando
(Monster)
Offline
Monster
Iscritto: 04/08/2005
Messaggi: 213

Quote:

topgun ha scritto:
http://www.mandrakeitalia.org/modules/wfsection/article.php?articleid=40

Ti consiglio questa guida. è spiegato tutto molto bene.

L'ho usato una volta . Non mi e' chiaro se urpmi update aggiorna il data base per cui e' meglio darlo prima di fare una installazione ......
Ciao,grazie.

Ritratto di Madman
Madman
(Guru)
Offline
Guru
Iscritto: 19/12/2004
Messaggi: 2016

man urpmi.update ha le risposte che cerchi. Wink

Per quanto riguarda le dipendenze irrisolte dovresti cavartela installando le glibc e libcurl3 ovviamente tramite urpmi, dopodichè potrai installare FreePOPs con un semplice rpm -ivh freepops-0.0.31-3ddz.i586.rpm. Wink

Ritratto di Lando
Lando
(Monster)
Offline
Monster
Iscritto: 04/08/2005
Messaggi: 213

Quote:

Madman ha scritto:
man urpmi.update ha le risposte che cerchi. Wink

Per quanto riguarda le dipendenze irrisolte dovresti cavartela installando le glibc e libcurl3 ovviamente tramite urpmi, dopodichè potrai installare FreePOPs con un semplice rpm -ivh freepops-0.0.31-3ddz.i586.rpm. Wink

Non mi trova questo cavolo di libreria !
C' e' un package che la contiene con un altro nome ?
Grazie !

# urpmi libcurl3
no package named libcurl3

# urpmi libcurl.so.3
no package named libcurl.so.3

Ritratto di Madman
Madman
(Guru)
Offline
Guru
Iscritto: 19/12/2004
Messaggi: 2016

Hai aggiunto i repository remoti con urpmi.addmedia come indicato in questa guida?

Prova a cercare questa libreria con urpmf libcurl.so.3 (man urpmf per maggiori informazioni). Wink

Ritratto di Lando
Lando
(Monster)
Offline
Monster
Iscritto: 04/08/2005
Messaggi: 213

Quote:

Madman ha scritto:
Hai aggiunto i repository remoti con urpmi.addmedia come indicato in questa guida?

Prova a cercare questa libreria con urpmf libcurl.so.3 (man urpmf per maggiori informazioni). Wink

Mi sembra che non trovi niente !!! no ?

[lando@localhost lando]$ urpmf --verbose libcurl.so.3
callback is :
sub { my ($urpm, $pkg) = @_;
foreach my $e ($pkg->files) {
local $_ = $pkg->name.":$e";
m{libcurl.so.3} or next;
print "$_\n";
}
1;
}

examining hdlist file [/var/lib/urpmi/hdlist.Installation CD 1 (x86) (cdrom1).cz ]
examining hdlist file [/var/lib/urpmi/hdlist.Installation CD 2 (x86) (cdrom2).cz ]
examining hdlist file [/var/lib/urpmi/hdlist.Installation CD 3 (x86) (cdrom3).cz ]
examining hdlist file [/var/lib/urpmi/hdlist.main.cz]
examining hdlist file [/var/lib/urpmi/hdlist.contrib.cz]
examining hdlist file [/var/lib/urpmi/hdlist.simonzone.cz]
examining hdlist file [/var/lib/urpmi/hdlist.plf-free.cz]
examining hdlist file [/var/lib/urpmi/hdlist.plf-nonfree.cz]
would install instead of upgrade package kernel-multimedia-2.4.22.21mm.2mdk-1-1mdk.i586
would install instead of upgrade package kernel-2.4.25.2mdk-1-1mdk.i586
would install instead of upgrade package kernel24-tmb-2.4.25-2.tmb.1mdk-1-1mdk.i586
would install instead of upgrade package kernel2.4-marcelo-2.4.25-1mdk.i586
would install instead of upgrade package kernel-tmb-i686-up-4GB-2.6.4-1.tmb.5mdk-1-1mdk.i586
would install instead of upgrade package kernel-tmb-2.6.4-1.tmb.5mdk-1-1mdk.i586
would install instead of upgrade package kernel-tmb-enterprise-2.6.4-1.tmb.5mdk-1-1mdk.i586
would install instead of upgrade package kernel-smp-2.4.25.2mdk-1-1mdk.i586
would install instead of upgrade package kernel-secure-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel-enterprise-2.4.25.2mdk-1-1mdk.i586
would install instead of upgrade package kernel-enterprise-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel-i686-up-4GB-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel24-tmb-enterprise-2.4.25-2.tmb.1mdk-1-1mdk.i586
would install instead of upgrade package kernel-multimedia-smp-2.4.22.21mm.2mdk-1-1mdk.i586
would install instead of upgrade package kernel-p3-smp-64GB-2.4.25.2mdk-1-1mdk.i586
would install instead of upgrade package kernel-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel-smp-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel-p3-smp-64GB-2.6.3.7mdk-1-1mdk.i586
would install instead of upgrade package kernel-i686-up-4GB-2.4.25.2mdk-1-1mdk.i586
would install instead of upgrade package kernel22-smp-2.2.20-9mdk.i586
would install instead of upgrade package kernel-linus2.2-2.2.25-1mdk.i586

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

Scusa ma che versione di Mandriva hai installato? Se hai una versione di Mandriva precedente alla 2005 il pacchetto potrebbe essere incompatibile (perché appunto glibc e libcurl3 non sono abbastanza recenti per far funzionare a dovere il pacchetto). La cosa migliore in tal caso è:

a) provare a installarsi il pacchetto mp3 "generico" che trovi sul sito di freepops

Cool compilarlo da sorgente.

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di Madman
Madman
(Guru)
Offline
Guru
Iscritto: 19/12/2004
Messaggi: 2016

Mi permetto di aggiungere una terza opzione:

c) scaricate il pacchetto RPM sorgente (*.src.rpm) dal sito di FreePOPs e ricompilarlo con rpmbuild --rebuild freepops-0.0.31-1.src.rpm. Wink