dispositivi USB in VIrtualBox

25 risposte [Ultimo messaggio]
Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Salve !

Sto provando a far funzionare in VirtualBox alcuni applicativi Windows. Sembra tutto andare bene, compresa la lettura da CRDOM, tranne i dispositivi USB. In particolare, pur avendo io scaricato il patch di Sun per poter configurare i dispositivi USB, all'atto della configurazione VirtualWindows non vede né Webcam, né pennette, né stampante (con annesso scanner), qualunque sia la porta USB in cui sono inseriti i sopraddetti device. Premetto di aver cercato di configurare i cosiddetti filtri USB nelle impostazioni OSE relative al VIrtualWindows installato; mi fa aggiungere un filtro che però, apparentemente, non è collegato ad alcun dispositivo reale. In effetti, nell'elenco degli hardware visti dal SO virtuale compaiono dei dispositivi USB (Controller USB ed anche un paio di HUB segnalati come perfettamente funzionanti)) , ma non sembrano collegati a quelli fisici. Ho mancato di far qualcosa di importante ? Se sì, qualcuno può gentilmente suggerimi cosa fare, magari indirizzandomi alla parte della guida Virtual Box che concerne proprio quest'argomento ? Grazie in ogni caso a tutti !

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Non sono sicuro che la versione open
di virtualbox supporti la USB (anche se installi la patch).
Io ho disinstallato il VB open,
scaricato e installato quello del sito Oracle (con la patch)
e funziona.

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Beh, può darsi. Ma perché mai il manuale cita il supproto a USB ? Si riferisce forse al solo pacchetto SUN ? E perché allora in Windows (virtuale) le USB risultano presenti ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Mah!...

Altre possibilità:
http://news.softpedia.com/news/How-to-Fix-VirtualBox-USB-Support-111715.shtml
http://www.howtogeek.com/howto/31726/mount-usb-devices-in-virtualbox-with-ubuntu/
http://www.virtualbox.org/manual/ch03.html#idp11188688

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Ho dato un occhiata ai riferimenti che mi hai indicato, e tutti sembrano concordi col fatto che occorra disinstallare la versione pacchettizzata e scaricare ed installare quella Oracle, a causa della presenza in quest'ultima di pacchetti proprietari. Mi pare una vera fregatura, sicuramente incomprensibile visto che tutto il resto è open source... resta il mistero che nell'hardware del Windows virtuale risultano presenti i dispositivi USB. Ulteriore stranezza: L'iconcina USB sul bordo della Virtual BOX è attiva, segnalando che nessun dispositivo USB è connesso. Dovrebbe, perché telecamera e stampante sono fisicamente connessi. E nelle impostazioni OSE, volendo aggiungere i dispositivi, avendo creato il filtro, la lista dei device è vuota (nessun dispositivo disponibile). Non mi piace, 'sta storia. Ho provato, seguendo le indicazioni del manuale ad aggiungere il gruppo vboxusers (non era stato creato) e a mettere il mio account name ed anche quello di root agli utenti del gruppo. Ho anche listato le usb utilizzabili Vbox, col comando:

[root@localhost ~]# VBoxManage list usbhost
Host USB Devices:

UUID: bd8c5246-15f5-4ddb-9dc9-352a9dbf0a66
VendorId: 0x045e (045E)
ProductId: 0x0734 (0734)
Revision: 1.0 (0100)
Manufacturer: Liteon
Product: Microsoft® Wireless Receiver 700 v2.0
Address: sysfs:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3//device:/dev/vboxusb/001/003
Current State: Busy

UUID: 383c851f-9650-4ec5-b196-94907e00bfa4
VendorId: 0x046d (046D)
ProductId: 0x0825 (0825)
Revision: 0.16 (0016)
SerialNumber: 2DD7F990
Address: sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3//device:/dev/vboxusb/002/004
Current State: Busy

UUID: 1cf78e6b-2c9c-413d-a753-247454080305
VendorId: 0x04b8 (04B8)
ProductId: 0x0848 (0848)
Revision: 1.0 (0100)
Manufacturer: EPSON
Product: USB2.0 MFP(Hi-Speed)
SerialNumber: 4B504B593134333419
Address: sysfs:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1//device:/dev/vboxusb/002/003
Current State: Busy

Dà qualche lume ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di fredflinstone
fredflinstone
(Junior)
Offline
Junior
Iscritto: 15/03/2008
Messaggi: 43

Ciao !

anche a me succede la stessa cosa con le usb nonostante abbia scaricato VB Oracle e addons conseguenti. L'unica soluzione per me è stata quella di condividere le cartelle.

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Le cartelle io le ho condivido, non è questo il problema, quanto l'utilizzazione di applicativi windows (o Mac) che obiettivamente sono più frendly user e, spesso migliori (so di bestemmiare, ma nel caso almeno di OMNIPAGE, che necessita di scanner, ed ACROBAT, questo è vero, al momento).

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Sinceramente non saprei che altro dire.
L'unica altra cosa che mi viene in mente
è di controllare che siano installate
le "guest addition" sulla macchina virtuale
e i dkms-vboxhost sull'host linux.

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

C'è tutto. Nel caso proverò ad installare i file SUN. Posso comunque caricare i dischi virtuali già preparati ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

In realtà dovrebbe vedere le macchine virtuali già create
esattamente come l'altro.
Altrimenti c'è la possibilità di importarle
o crearne di nuove utilizzando i dischi virtuali già fatti.

PS: senza la versione SUN/Oracle non penso che le usb
possano funzionare: a quanto mi ricordo il problema è legato
a porzioni di codice che non sono opensource nella gestione dell'usb.

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Per installarela versione SUN devo disinstallare tuttodi VirtualBox ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5