Database OpenOffice e Java [RISOLTO]

4 risposte [Ultimo messaggio]
Ritratto di zioandrea
zioandrea
(Junior)
Offline
Junior
Iscritto: 14/12/2004
Messaggi: 14

Salve,
      sto provando ad usare per la prima volta Base di openoffice.
Quando cerco di aprire un nuovo DB, mi dice che la versione JRE installata è difettosa.
Ho provato a disinstallare e reinstallare  openoffice.org-java-common-3.1.1-0.3mdv2009.1, ma non è cambiato nulla?
Suggerimenti? Oltre, ovviamente che quello di aspettare una settimana per la 10.1 Wink

Andrea 

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Da terminale dai i comandi

java -version

rpm -qa | grep java

e posta i risultati.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di zioandrea
zioandrea
(Junior)
Offline
Junior
Iscritto: 14/12/2004
Messaggi: 14

Ciao Moreno 
Probabilmente c'è troppa roba. Quando ho visto che non funzionava in configurazione standard ho cominciato ad aggiungere sul PC di casa tutti i pacchetti java che mi sembravano utili, compreso un nuovo java dal sito Sun.
Comunque, il problema era presente già con l'installazione standard e resiste sul PC di lavoro, dove ho fatto meno pasticci.
Sul wiki di Mandriva ho visto un problema simile per la 2009-ONE, dove avevano omesso un pacchetto, che io ho. 
ciao, andrea 
$ java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (mandriva-2.b18.2mdv2009.1-i386)
OpenJDK Server VM (build 14.0-b16, mixed mode)

$ rpm -qa |grep java
hsqldb-javadoc-1.8.0.10-0.0.2mdv2009.1
java-1.6.0-openjdk-1.6.0.0-2.b18.2mdv2009.1
java-1.6.0-sun-alsa-1.6.0.15-0.1mdv2009.1
java-1.6.0-sun-plugin-1.6.0.15-0.1mdv2009.1
timezone-java-2010i-0.2mdv2009.1
java-1.6.0-sun-fonts-1.6.0.15-0.1mdv2009.1
java-access-bridge-1.26.0-1mdv2009.1
openoffice.org-java-common-3.1.1-0.3mdv2009.1
java-1.6.0-sun-jdbc-1.6.0.15-0.1mdv2009.1
java-1.6.0-sun-1.6.0.15-0.1mdv2009.1
rootcerts-java-20100216.01-1mdv2009.1
 $ rpm -qa |grep -i jdk
java-1.6.0-openjdk-1.6.0.0-2.b18.2mdv2009.1

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Prova ad andare su Strumenti>Opzioni>OpenOffice.org>java
e controlla se è selezionato un JRE.
Se ne trova più di uno potrebbe non saper scegliere....

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di zioandrea
zioandrea
(Junior)
Offline
Junior
Iscritto: 14/12/2004
Messaggi: 14

È  andata Smile
Come al solito il problema era talmente  stupido che da solo non ci sarei mai arrivato. 
OOffice  diceva che JRE era difettoso, quindi pensavo che avesse provato ad usarlo e avesse incontrato dei problemi "interni".
In realtà aveva riconosciuto che cerano prima uno e poi 2 ambienti Java, ma non ne aveva attivato nessuno.Ho l'impressione che ci sia un problema nella traduzione del messaggio d'errore. Proverò a controllarlo. 

grazie  granger75 per la tua frase illuminante

ciao a tutti, Andrea