aggiornamento glib2 e gimp

10 risposte [Ultimo messaggio]
Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

Ciao a tutti.. ieri tra gli aggiornamenti c'erano le glib2 dai repository ufficiali.. non è che aggiornandoli ho perso le ottimizzazioni che avevo con le glibc di mib? cioè ora le ho ancora installate le glibc del mib, però boh? anche queste glib2 sono librerie di sistema, no? e non sono ottimizzate i686..

vabbè cmq, più importante, tra gli aggiornamenti c'era anche gimp (dal repo MIB) e le sue librerie.. le librerie le ha installate, ma il programma no, perché dice

Alcuni dei pacchetti richiesti non possono essere installati:
gimp-2.4.2-1.1.mib2007.1.i686 (perché non è soddisfatto libpoppler-glib.so.2)

ora facendo urpmi poppler lui ha rimosso xpdf e l'ha installato.. ma il problema persiste.. se faccio urpmi libpoppler mi dice

Nessun pacchetto denominato libpoppler
I seguenti pacchetti contengono libpoppler:
libpoppler-qt1
libpoppler-qt1-devel
libpoppler-qt4-1
libpoppler-qt4-1-devel
libpoppler1
libpoppler1-devel

quale installo?

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

Ah, le qt che ho installate sul mio sistema sono
rpm -qa | grep qt

libqtnetwork4-4.2.3-3.2mdv2007.1
libqt3-3.3.8-4.2mdv2007.1
libdbus-qt-1_1-0.70-1mdv2007.1
libqtdesigner1-4.2.3-3.2mdv2007.1
libqtgui4-4.2.3-3.2mdv2007.1
libqtuitools4-4.2.3-3.2mdv2007.1
libqt3-devel-3.3.8-4.2mdv2007.1
python-qt-3.5.6-1mdv2007.1
libpoppler-qt1-0.5.4-3.3mdv2007.1
libqtcore4-4.2.3-3.2mdv2007.1
libqtsql4-4.2.3-3.2mdv2007.1
libavahi-qt3_1-devel-0.6.17-1.1mdv2007.1
gtk-qt-engine-0.8-1.xnc.mib2007.1
libqt3support4-4.2.3-3.2mdv2007.1
libqtxml4-4.2.3-3.2mdv2007.1
pinentry-qt-0.7.2-6mdv2007.0
qt4-common-4.2.3-3.2mdv2007.1
libqtsvg4-4.2.3-3.2mdv2007.1
qt3-common-3.3.8-4.2mdv2007.1
libavahi-qt3_1-0.6.17-1.1mdv2007.1
libqtdbus4-4.2.3-3.2mdv2007.1

..forse mi so risposto da solo.. visto che ho questo pacchetto libpoppler-qt1-0.5.4-3.3mdv2007.1
aggiorno questo?

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

Ma che caz....!!!!!!! ho capito che è successo!!! ho visto sul repository mib che quella versione di gimp è in testing.. ma io il repository testing non l'ho messo!!!!! proprio per non fare casini!!!! però si vede che quelli di mib hanno sbagliato le hd list e a me tra gli aggiornamenti mi ha messo anche quello!!

allora, in /i686 c'è gimp senza le librerie.. e in /testing/gimp c'è ancora lo stesso file gimp e in più le librerie.. che è successo??

Ritratto di Schizoid
Schizoid
(Guru)
Offline
Guru
Iscritto: 27/10/2006
Messaggi: 695

a me gimp (più il normale aggiornamento del resto dei pacchetti ricompilati per farlo andare) si è portato dietro i seguenti pacchetti
Quote:

libgtk+2.0_0-2.12.1-3.1.mib2007.1
libgtk+-x11-2.0_0-2.12.1-3.1.mib2007.1
gtk+2.0-2.12.1-3.1.mib2007.1
libglib2.0_0-2.14.3-1.1.mib2007.1
glib2.0-common-2.14.3-1.1.mib2007.1
xdg-user-dirs-gtk-0.6-2.1.mib2007.1
xdg-user-dirs-0.9-1.1.mib2007.1
libcairo2-1.4.10-3.1.mib2007.1
libpango1.0_0-modules-1.19.0-2.1.mib2007.1
libpango1.0_0-1.19.0-2.1.mib2007.1
libgdk_pixbuf2.0_0-2.12.1-3.1.mib2007.1
pango-1.19.0-2.1.mib2007.1
libthai0-0.1.9-3.1.mib2007.1
thai-data-0.1.9-3.1.mib2007.1
gimp-2.4.2-1.1.mib2007.1
gimp-help-2-0.12-1mdv2007.1
libpoppler-glib2-0.6-1.SoS.2007.1
libpoppler2-0.6-1.SoS.2007.1
poppler-data-0.1-2mdv2007.1
libgimp2.0_0-2.4.2-1.1.mib2007.1

controlla se te ne manca qualcuno o se ci siamo scordati di spostare qualcosa, e non fare caso al fatto che le mie libpoppler vengono da SoS, quelle di Mandriva di certo vanno comunque

edit: probabilmente quì c'è anche qualche pacchetto di troppo... controlla bene

Mandriva x64 2010.0 MIB
Acer Aspire 5935G (Core2 Duo P7450 - 4Gb RAM - Nvidia GeForce GT 130M)

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

ho tutti quei pacchetti che mi hai indicato tranne

libpoppler-glib2-0.6-1.SoS.2007.1
libpoppler2-0.6-1.SoS.2007.1

ma

# urpmi libpoppler-glib2
Nessun pacchetto denominato libpoppler-glib2

e

# urpmi libpoppler2
Nessun pacchetto denominato libpoppler2

che faccio li scarico a mano da rpm bone o da SoS?

ciao, grazie!

Ritratto di Schizoid
Schizoid
(Guru)
Offline
Guru
Iscritto: 27/10/2006
Messaggi: 695

strano che non ci siano, non so che dirti...
intanto allora scaricali da SoS, per quello che ho visto funzionano bene...

Mandriva x64 2010.0 MIB
Acer Aspire 5935G (Core2 Duo P7450 - 4Gb RAM - Nvidia GeForce GT 130M)

Ritratto di grissino
grissino
(Guru)
Offline
Guru
Iscritto: 23/04/2005
Messaggi: 595

Quote:

rob_mdvita ha scritto:
ho tutti quei pacchetti che mi hai indicato tranne

libpoppler-glib2-0.6-1.SoS.2007.1
libpoppler2-0.6-1.SoS.2007.1

ma

# urpmi libpoppler-glib2
Nessun pacchetto denominato libpoppler-glib2

e

# urpmi libpoppler2
Nessun pacchetto denominato libpoppler2

che faccio li scarico a mano da rpm bone o da SoS?

ciao, grazie!

Scusa colpa mia Thinking

Nella fretta ho dimenticato di metterle sul server.

Fra un po' saranno disponibili...

ciao.
grissino.

Mandriva 2007.1 kde 3.5.7 Kernel 2.6.17-14, Mandriva 200.8.1 e 2009.0,
"Si ti vo' sciarriari trovati u cumpagnu."

Ritratto di g-franco
g-franco
(Junior)
Offline
Junior
Iscritto: 09/11/2007
Messaggi: 8

da rob_mdvita su 26/11/2007 14:35:09

ho tutti quei pacchetti che mi hai indicato tranne

libpoppler-glib2-0.6-1.SoS.2007.1
libpoppler2-0.6-1.SoS.2007.1

ma

# urpmi libpoppler-glib2
Nessun pacchetto denominato libpoppler-glib2

e

# urpmi libpoppler2
Nessun pacchetto denominato libpoppler2

che faccio li scarico a mano da rpm bone o da SoS?

ciao
anchio o avuto lo stesso problema ...
adesso risolto .
Non e' che si potrebero avere gli indirizzi (da rpm bone o da SoS?)
grazie x un futuro probl. so gia dove andare

graz. ciao

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

come no? eccoli qua:
http://rpm.pbone.net/
e deselezioni tutto (su advanced search) e poi selezioni solo la mandriva che ti interessa..(o un'altra distro se la usi)
da qua devi scaricare a mano, non lo puoi aggiungere come repository..

per SoS (Seer of Souls) è:
http://seerofsouls.com/
e mi pare che lo puoi proprio aggiungere come repository con urpmi.addmedia (leggi le istruzioni sul sito)

c'è pure questo
http://www.mde.djura.org/
che lo puoi aggiungere proprio come repository.. è bello completo e aggiornato!! io prima di MIB lo usavo tantissimo.. ora MIB li ha stesi tutti!!!! VIVA IL MIB!!!
Laughing Laughing

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

Quote:

rob_mdvita ha scritto:
come no? eccoli qua:
http://rpm.pbone.net/
e deselezioni tutto (su advanced search) e poi selezioni solo la mandriva che ti interessa..(o un'altra distro se la usi)
da qua devi scaricare a mano, non lo puoi aggiungere come repository..

per SoS (Seer of Souls) è:
http://seerofsouls.com/
e mi pare che lo puoi proprio aggiungere come repository con urpmi.addmedia (leggi le istruzioni sul sito)

c'è pure questo
http://www.mde.djura.org/
che lo puoi aggiungere proprio come repository.. è bello completo e aggiornato!! io prima di MIB lo usavo tantissimo.. ora MIB li ha stesi tutti!!!! VIVA IL MIB!!!
Laughing Laughing

ma gimp non viene aggirnata anche da mandriva? a me lo ha fatto...

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

$ rpm -qa | grep gimp
libgimp2.0_0-2.4.2-3.1.mib2007.1
gimp-help-2-0.12-1mdv2007.1
gimp-2.4.2-3.1.mib2007.1
gutenprint-gimp2-5.0.0-3mdv2007.1

boh? io sto messo così..