wi-fi e aggiornamento kernel

17 risposte [Ultimo messaggio]
Ritratto di runner
runner
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 16

Salve a tutti,
dopo aver passato quasi 3 anni su kubuntu mi sono deciso a fare il salto definitivo su mandriva,
piccolo problema la connessione wi-fi.
Devo dire che mi ha sempre dato dei problemi ma con gli aggiornamenti del kernel si è persa totalmente.
Per connettermi devo scegliere il kernel di default della distro, cancellare la connessione e ricrearla sperando che vada bene ...
Qualcun'altro ha gli stessi problemi?
Grazie in anticipo
Luca

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

fai il bravo, almeno dicci come è composto il tuo hw.
Comunque quasi probabilmente ti manca il modulo del nuovo kernel che hai installato, versione del kernel?
con
uname -a

comandi:
lspci
dato da console
e posta il risultato..

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di gioli
gioli
(Monster)
Offline
Monster
Iscritto: 16/12/2006
Messaggi: 382

Il mio wireless ha sempre funzionato egregiamente ma da oggi è in vacanza.
Credo che sia legato agli aggiornamenti che ho scaricato ieri.
Cercando "wifi" nella gestione software non trovo nessun pacchetto installato.
Ho provato anche a scegliere all'avvio versioni precedenti del kernel ma niente da fare.

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

cosi non andiamo avanti... mi si è rotta la sfera di cristallo..

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di fantazaro
fantazaro
(Monster)
Offline
Monster
Iscritto: 01/12/2006
Messaggi: 306

ciao, Picard12 ha ragione, devi fornirci le caratteristiche della scheda (Atheros, intel, broadcom....ecc) solo così potremmo cercare di aiutarti....

ciao andrea

Mandriva2010 free..i586..asus F3M..sempron3400+

Ritratto di gioli
gioli
(Monster)
Offline
Monster
Iscritto: 16/12/2006
Messaggi: 382

Quote:

picard12 ha scritto:
cosi non andiamo avanti... mi si è rotta la sfera di cristallo..

Non hai del tutto torto ! Laughing
Ma davo per scontato che, almeno nel mio, caso le informazioni fossero sufficienti. Infatti dopo aver scaricato tra gli aggiornamenti il kernel “2.6.27.7-desktop-1mnb” il wireless si è bloccato.
Ho installato il pacchetto “madwifi-kernel-2.6.27.7-desktop-1mnb” con un paio di dipendenze e il wireless ha ripreso a funzionare.

Ho un paio di domande e una (possibile) risposta.

Ecco le 2 domande:
1) Per determinare il kernel io usavo “uname -r” voi invece “uname -a” che dà anche la data e informazioni sul processore. Sono le sole differenze ?

2) non so se era possibile evitarlo ma "disinstallare" i pacchetti precedenti con un aggiornamento non è carino ! Io ho parato il colpo grazie ad un po' di esperienza e alla possibilità di usare la LAN. Ma se avessi avuto solo il wireless come avrei dovuto fare ?

E anche la risposta:

Quote:

runner ha scritto:
... la connessione wi-fi.
Devo dire che mi ha sempre dato dei problemi ...
Luca

se il funzionamento del wireless è intermittente forse puoi provare a scegliere il protocollo "dhcpcd" invece del solito "dhcp" durante la creazione della connessione wireless.

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

Quote:

gioli ha scritto:
Quote:
picard12 ha scritto:
cosi non andiamo avanti... mi si è rotta la sfera di cristallo..

Non hai del tutto torto ! Laughing
Ma davo per scontato che, almeno nel mio, caso le informazioni fossero sufficienti. Infatti dopo aver scaricato tra gli aggiornamenti il kernel “2.6.27.7-desktop-1mnb” il wireless si è bloccato.
Ho installato il pacchetto “madwifi-kernel-2.6.27.7-desktop-1mnb” con un paio di dipendenze e il wireless ha ripreso a funzionare.

Ho un paio di domande e una (possibile) risposta.

Ecco le 2 domande:
1) Per determinare il kernel io usavo “uname -r” voi invece “uname -a” che dà anche la data e informazioni sul processore. Sono le sole differenze ?

2) non so se era possibile evitarlo ma "disinstallare" i pacchetti precedenti con un aggiornamento non è carino ! Io ho parato il colpo grazie ad un po' di esperienza e alla possibilità di usare la LAN. Ma se avessi avuto solo il wireless come avrei dovuto fare ?

E anche la risposta:

Quote:

runner ha scritto:
... la connessione wi-fi.
Devo dire che mi ha sempre dato dei problemi ...
Luca

se il funzionamento del wireless è intermittente forse puoi provare a scegliere il protocollo "dhcpcd" invece del solito "dhcp" durante la creazione della connessione wireless.

ciao:
1. non cambia molto l'opzione -a, ti ho suggerito quella perchè la uso solitamente.
2. in realtà non ha disinstallato nulla, perchè tu hai installato il kernel nuovo e anche il modulo precompilato di madwifi relativo

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di gioli
gioli
(Monster)
Offline
Monster
Iscritto: 16/12/2006
Messaggi: 382

Quote:

runner ha scritto:
2. in realtà non ha disinstallato nulla, perchè tu hai installato il kernel nuovo e anche il modulo precompilato di madwifi relativo

Visto che fino a quando ho usato il kernel “2.6.27.7-desktop-1mnb” (cioè fino all'altro ieri) tutto funzionava penso che fosse installato “madwifi-kernel-2.6.27.5-desktop-1mnb” o sbaglio ?
Se è così io non lo ho disinstallato manualmente e quindi ho pensato che sia stato l'aggiornamento.

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

Quote:

gioli ha scritto:
Quote:
runner ha scritto:
2. in realtà non ha disinstallato nulla, perchè tu hai installato il kernel nuovo e anche il modulo precompilato di madwifi relativo

Visto che fino a quando ho usato il kernel “2.6.27.7-desktop-1mnb” (cioè fino all'altro ieri) tutto funzionava penso che fosse installato “madwifi-kernel-2.6.27.5-desktop-1mnb” o sbaglio ?
Se è così io non lo ho disinstallato manualmente e quindi ho pensato che sia stato l'aggiornamento.

per ogni versione del kernel devi avere la stessa versione di madwifi:
kernel-desktop-2.6.27.7-1mnb
madwifi-kernel-2.6.27.7-desktop-1mnb
e non ad esempio:
madwifi-kernel-2.6.27.7-server-1mnb
Anche perchè se le vs del kernel sono differenti, vanno a finire in posti differenti.
ci siamo ora?
scusa ma che modello di scheda hai? le atheros, come la mia, funzionano senza madwifi..
a questo proposito potrebbe essere un conflitto tra il driver madwiifi e il modulo del kernel.
lspci cosa dice?

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di runner
runner
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 16

Per la cronaca questo è il kernel che ho:
Linux localhost 2.6.27.7-desktop-1mnb #1 SMP Thu Dec 11 16:45:35 EST 2008 i686 AMD Athlon(tm) XP 2000+ GNU/Linux

Per quanto riguarda il chipset non mi ricordo e non riesco a trovarlo, però non ho mai avuto problemi, il mio router (belkin router modem G wireless F5D7632ef4A) non mi ha mai dato problemi tant'è che viene riconosciuto al volo dal kernel, per quanto riguarda i moduli madwifi non ne ho nessuno installato.
In questo momento sono connesso con il mio modem, non perdo nemmeno la connessione, soltanto quando mi voglio connettere devo fare queste azioni:
1-selezionare il modulo di kernel di default all'avvio
2-cancellare la vecchia connessione
3-ricrearla dal centro di controllo
4-pregare intensamente che funzioni il tutto
Ora io non sono un niubbo totale ma nemmeno un poweruser e sinceramente non sò dove andare a cercare.
Devo dire che su kubuntu con knetworkmanager non mi ha mai dato problemi.
Devo anche dire che kubuntu in confronto a mandriva è un ferrovecchio lento come una tartaruga soprattutto con kde4.
Luca

Ritratto di runner
runner
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 16

Non sarò un niubbo totale ma poco ci manca...
Per la cronaca:
sono andato nel centro di controllo a vedere in hardware se mi diceva che chip ha il mio router, e magia mi ha chiesto di installare un tot di moduli del kernel e ora funziona tutto...
Non sò che dire, non sò se questa è la soluzione ma ora funziona.
Boooh!