accedere a windows

31 risposte [Ultimo messaggio]
Ritratto di salvo72
salvo72
(Geek)
Offline
Geek
Iscritto: 01/01/2011
Messaggi: 88

ciao ragazzi

nel mio precedente post avevo il problema di come accedere alla partizione nfts ( windows ), grazie all'aiuto principalmente di argos con il comando << mount -t nfts /dev/sda.. -o rw /mnt/windows >> e una modifica al file fstab il problema l'ho risolto

adesso pero non riesco ad accedere in windows all'avvio da grub

Ritratto di salvo72
salvo72
(Geek)
Offline
Geek
Iscritto: 01/01/2011
Messaggi: 88

porto i risultati di alcuni comandi sulla schell:

root@localhost salvo]# ls -la /mnt
totale 24
drwxr-xr-x 6 root root 4096 2011-03-17 23:17 ./
drwxr-xr-x 22 root root 4096 2011-03-18 20:27 ../
drwxr-xr-x 3 root root 4096 2011-01-06 17:47 install/
drwxrwxrwx 1 root root 4096 2011-02-17 22:26 windows/
drwxr-xr-x 2 root root 4096 2011-03-13 12:05 windows1/
drwxr-xr-x 2 root root 4096 2011-03-17 23:17 windows3/

[root@localhost salvo]# mount
/dev/sda8 on / type ext3 (rw)
none on /proc type proc (rw)
/dev/sda5 on /mnt/windows type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sda9 on /home type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
gvfs-fuse-daemon on /home/salvo/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=salvo)

[root@localhost salvo]# nano /etc/emtab

[root@localhost salvo]# nano /etc/fstab
# Entry for /dev/sda5 :
UUID=A0AC3CB6AC3C8934 /mnt/windows ntfs-3g defaults,umask=000 0 0
# Entry for /dev/sda6 :
UUID=A63CE9133CE8DEF5 /mnt/windows1 ntfs-3g defaults,umask=000 0 0# Entry for /dev/sda8 :
UUID=e3c45f01-a4a1-48c9-8851-29167b456239 / ext3 defaults 1 1
# Entry for /dev/sda9 :
UUID=cd0d6c9f-cbf9-4ae9-b5b8-7231c2c4e081 /home ext3 defaults 1 2
none /proc proc defaults 0 0
# Entry for /dev/sda7 :
UUID=3a1d421b-0861-439a-9bb3-0b50ecf9e5fd swap swap defaults 0 0

Ritratto di Argos
Argos
(Geek)
Offline
Geek
Iscritto: 28/04/2008
Messaggi: 107

ciao Smile

Non puoi entrare per questo motivo:

UUID=A63CE9133CE8DEF5 /mnt/windows1 ntfs-3g defaults,umask=000 0 0# Entry for /dev/sda8 :

...che si dovrebbe trovare nella riga successiva di sotto cosi:

UUID=A63CE9133CE8DEF5 /mnt/windows1 ntfs-3g defaults,umask=000 0 0
# Entry for /dev/sda8 :

...ricorda che stiamo parlando del file /etc/fstab ( HAI FATTO BACKUP DI QUESTO FILE COME INDICATO? )

Ho notato che hai una nuova cartella sotto /mnt , la Windows3 ti serve per caso a montare la partizione /dev/sda2 fat16 di circa un giga e mezzo?, ma una curiosità: per cosa usi quella partizione? Rolling Eyes

A dopo

ASUS P5KPL-AM SE, FSB 1600 (O.C) e 1066 (O.C) DDR2, Chipset intel G31 / ICH7, Intel Pentium Dual-Core CPU E5700 @ 3.00GHz, 4 Gb RAM DDR2 800 Mhz PC2-6400 CL5, ATI Radeon HD 4650 1 Gb DDR2, /dev/sda 320 Gb 16 Mb, /dev/sdb 1000 Gb 64 Mb.

Ritratto di salvo72
salvo72
(Geek)
Offline
Geek
Iscritto: 01/01/2011
Messaggi: 88

ciao argos per prima ti devo ringraziare della tua disponibilita mi stai aiutando molto

grazie mille

allora ho aperto il file fstab con nano e ho cambiato la riga come hai detto tu. e ho alvato la modifica pero all'avvio di grub selezionando windows mi da questo errore:

root ( hd0, 1)

error 22 : no such partizion

press any key to continue...

la nuova cartella windows3 e solo una prova per cercare di capire i comandi sulla shell, a proposito mi potesti darmi qualche consiglio dove rovare una guida sui comandi sulla shell per linux?

Ritratto di Paolo77
Paolo77
(Geek)
Offline
Geek
Iscritto: 15/06/2009
Messaggi: 75

Ciao,

A quanto ho capito tu stai parlando dell'avvio del s.o. Windows, non più del montare la partizione contenente i suoi dati da Mandriva giusto?
Innanzitutto di che versione di Windows stiamo parlando?

In questo caso credo che potrebbe essere utile il contenuto del file di configurazione del grub, credo che sia /boot/grub/menu.lst (a meno che nelle ultime versioni di mandriva non sia cambiato qualcosa, sono rimasto un po' indietro Smile )

In alternativa puoi comunque provare a ripristinare la cosa anche graficamente da mcc, in pratica c'è una scheda avvio dove vai ad impostare le varie entry che vedi nella schermata al boot. Sostanzialmente dovrebbe bastare selezionare la partizione corretta!

Ciao, Paolo

Ritratto di Argos
Argos
(Geek)
Offline
Geek
Iscritto: 28/04/2008
Messaggi: 107

Citazione:

root ( hd0, 1)

error 22 : no such partizion

press any key to continue...

...ma dopo che hai modificato il file fstab o già ti dava l'errore prima?, Confused comunque, postaci nuovamente il file /etc/fstab con:

nano /etc/fstab

Citazione:

la nuova cartella windows3 e solo una prova per cercare di capire i comandi sulla shell, a proposito mi potesti darmi qualche consiglio dove rovare una guida sui comandi sulla shell per linux?

...certo, ho trovato questo sito molto interessante ed utile Rolling Eyes :

http://www.linuxguide.it/command_line/linux_command_line-c1_en.html#JUMP

Citazione:

Ciao,

A quanto ho capito tu stai parlando dell'avvio del s.o. Windows, non più del montare la partizione contenente i suoi dati da Mandriva giusto?
Innanzitutto di che versione di Windows stiamo parlando?

In questo caso credo che potrebbe essere utile il contenuto del file di configurazione del grub, credo che sia /boot/grub/menu.lst (a meno che nelle ultime versioni di mandriva non sia cambiato qualcosa, sono rimasto un po' indietro Smile )

In alternativa puoi comunque provare a ripristinare la cosa anche graficamente da mcc, in pratica c'è una scheda avvio dove vai ad impostare le varie entry che vedi nella schermata al boot. Sostanzialmente dovrebbe bastare selezionare la partizione corretta!

Ciao, Paolo

Quoto su tutto, in effetti c'è un'applicazione grafica dal MCC che re-installa grub dallo stage1, altrimenti come ti ha suggerito Paolo77 , postaci l'output di /boot/grub/menu.lst con:

nano /boot/grub/menu.lst

A dopo Smile

ASUS P5KPL-AM SE, FSB 1600 (O.C) e 1066 (O.C) DDR2, Chipset intel G31 / ICH7, Intel Pentium Dual-Core CPU E5700 @ 3.00GHz, 4 Gb RAM DDR2 800 Mhz PC2-6400 CL5, ATI Radeon HD 4650 1 Gb DDR2, /dev/sda 320 Gb 16 Mb, /dev/sdb 1000 Gb 64 Mb.

Ritratto di salvo72
salvo72
(Geek)
Offline
Geek
Iscritto: 01/01/2011
Messaggi: 88

rispondo a paolo:
si mi riferisco all'avvio di grub ( credo di avere pasticciato un po con linux per montare la partizione di windows che non riesco piu accdere )

il responso del file fstab:

# Entry for /dev/sda5 :
UUID=A0AC3CB6AC3C8934 /mnt/windows ntfs-3g defaults,umask=000 0 0
# Entry for /dev/sda6 :
UUID=A63CE9133CE8DEF5 /mnt/windows1 ntfs-3g defaults,umask=000 0 0
# Entry for /dev/sda8 :
UUID=e3c45f01-a4a1-48c9-8851-29167b456239 / ext3 defaults 1 1
# Entry for /dev/sda9 :
UUID=cd0d6c9f-cbf9-4ae9-b5b8-7231c2c4e081 /home ext3 defaults 1 2
none /proc proc defaults 0 0
# Entry for /dev/sda7 :
UUID=3a1d421b-0861-439a-9bb3-0b50ecf9e5fd swap swap defaults 0 0

il file di grub ( con il comando nano /boot/grub/menu.lst )

timeout 10
color black/cyan yellow/cyan
gfxmenu (hd0,7)/boot/gfxmenu
default 0

title linux
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=e3c45f01-a4a1-48c9-8851-29167b456239 nopat resume=UUID=$
initrd (hd0,7)/boot/initrd.img

title windows
root (hd0,1)
makeactive
chainloader +1

title linux-nonfb
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=e3c45f01-a4a1-48c9-8851-29167b456239 resume=UUID=$
initrd (hd0,7)/boot/initrd.img

title failsafe
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=e3c45f01-a4a1-48c9-8851-29167b456239 failsafe
initrd (hd0,7)/boot/initrd.img

Ritratto di francofait
francofait
(Junior)
Offline
Junior
Iscritto: 11/09/2004
Messaggi: 41

edita il file /boot/grub/menu.lst e correggi le direttive per il boot di windows

title windows
root (hd0,1) # l' errore è qui correggi con (hd0,0) , efi grub usa la notazione esadecimale in cui anche 0 ha valore significativo
makeactive
chainloader +1

Ritratto di Argos
Argos
(Geek)
Offline
Geek
Iscritto: 28/04/2008
Messaggi: 107

ciao tutti Smile

In effetti il file fstab non centra con l'avvio ma ben si con il montaggio delle partizioni, la correzione è giusta Smile

Citazione:

edita il file /boot/grub/menu.lst e correggi le direttive per il boot di windows

title windows
root (hd0,1) # l' errore è qui correggi con (hd0,0) , efi grub usa la notazione esadecimale in cui anche 0 ha valore significativo
makeactive
chainloader +1

In effetti il problema d'avvio e dovuto all'impostazione della entry per windows in grub, condivido con francofait, ma, stando alla tabella delle partizioni:

/dev/sda1         2   30216 242701987+   f   W95 Esteso (LBA)
  /dev/sda5         2   7865  63159547     7   HPFS/NTFS
  /dev/sda7        7865 8126  2104483+    82   Linux swap / Solaris
  /dev/sda8        8127 10737 20972826    83   Linux
  /dev/sda9       10738 19769 72549508+   83   Linux
  /dev/sda6       19770 30216 83915496     7   HPFS/NTFS
/dev/sda2    *  30217 30400 1477980      e   W95 FAT16 (LBA)

...non sono sicuro che il boot sector sia su (hd0,0) ma ben si, su (hd0,4) Thinking , il dubbio è dovuto al fatto che windows si trova su una partizione logica, l'MBR e su (hd0) occupato da grub, /dev/sda1 è la partizione estesa (hd0,0) ed il boot sector di windows si trova su /dev/sda5 partizione logica (hd0,4), per cui penso che l'impostazione dovrebbe cambiare leggermente:

title windows
root (hd0,4)
makeactive
chainloader +1

...Ma..., Windows puo partire da una partizione logica? o li viene una crisi isterica per non essere l'unica sul HD ? Laughing

A dopo Smile

ASUS P5KPL-AM SE, FSB 1600 (O.C) e 1066 (O.C) DDR2, Chipset intel G31 / ICH7, Intel Pentium Dual-Core CPU E5700 @ 3.00GHz, 4 Gb RAM DDR2 800 Mhz PC2-6400 CL5, ATI Radeon HD 4650 1 Gb DDR2, /dev/sda 320 Gb 16 Mb, /dev/sdb 1000 Gb 64 Mb.

Ritratto di salvo72
salvo72
(Geek)
Offline
Geek
Iscritto: 01/01/2011
Messaggi: 88

niente da fare Sad

ho editato il file gub con hdo, 0 sia con hd0,4 ma mi da lo stesso errore

p.s rispondo a argos:
gli viene si una crisi isterica ormai e da un paio di mesi che non ci accedo ( sinceramente finora non lo sentito la mancanza )

Ritratto di Argos
Argos
(Geek)
Offline
Geek
Iscritto: 28/04/2008
Messaggi: 107

Citazione:

niente da fare Sad

ho editato il file gub con hdo, 0 sia con hd0,4 ma mi da lo stesso errore

...e se fai come ti ha suggerito francofait? Rolling Eyes io so che windows non parte se viene installato in una partizione logica, credo che bisogna renderla attiva, risolverei la questione con un boot manager, ma bisogna reinstallare grub su /dev/sda8 e non sul MBR, per poi, ripristinare l'MBR di windoz, per poi ed ultimo, installare GAG sul MBR, il quale avra il compito di avviare tutte e due, win e mandirva.

link per GAG : http://gag.sourceforge.net/

A dopo Smile

ASUS P5KPL-AM SE, FSB 1600 (O.C) e 1066 (O.C) DDR2, Chipset intel G31 / ICH7, Intel Pentium Dual-Core CPU E5700 @ 3.00GHz, 4 Gb RAM DDR2 800 Mhz PC2-6400 CL5, ATI Radeon HD 4650 1 Gb DDR2, /dev/sda 320 Gb 16 Mb, /dev/sdb 1000 Gb 64 Mb.