Ripristino di una sessione non grafica

4 risposte [Ultimo messaggio]
Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Salve !

Avendo seguito le indicazioni suggerite da rpmdrake, ho disinstallato alcuni pacchetti rimasti orfani, tra cui la versione del kernel del disco live originale. Questo ha sconquassato qualcosa in avvio, tanto che la versione failsafe non funziona più. Orbene, mi è capitato di installare un driver grafico da konsole, ma un messaggio di errore mi segnalava che non potevo farlo con una sessione X attiva. Ho provato ad uscire con CRTL+Alt+F3, ma ancora c'era una segnalazione di errore: logicamente, visto che una sessione X sotto era ancora attiva. Volevo allora entrare come failsafe, ma non funziona più.
Posso comunque entrare fin dall'inizio senza attivare un sessione grafica ?
E come faccio, eventualmenten a reimpostare una sessione safe ?
Grazie per il vostro contriubuto.

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Modifica in /etc/inittab la riga
id:5:initdefault:
in
id:3:initdefault:

Se sei in init 5, loggati come root in una console carattere e digita
 service dm stop
Questo ferma la sessione grafica.
Per il failsafe, non saprei.

PS. Da quanto ho letto nel post del driver nvidia, hai disinstallato un vecchio kernel.
Può darsi che la voce "failsafe" facesse riferimento a quel kernel.
Puoi provare a postare il contenuto di /boot/grub/menu.lst
e l'output di
rpm -qa | grep kernel | sort

PS2. Non è che anche il problema con dolphin è legato agli "orfani"????

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Possibile...ho provato anche a creare altri utenti, e il problema con dolohin si ripresenta. Solo arrestando i vari dolphi zombie, e ripetutamente dando il comando 'dolphin' da konsole riesco ad aprirne uno. Chuso quello di nuovo daccapo. Intanto dolphin è importante, non vorrei per questo reinstallare di nuovo tutto. Comunque:

ulissebionda@localhost ~]$ rpm -qa | grep kernel | sort
kernel-desktop-2.6.39.4-5.1-mdv2011.0.x86_64
kernel-desktop-devel-2.6.39.4-5.1-mdv2011.0.x86_64
kernel-desktop-devel-latest-2.6.39.4-4-mdv2011.0.x86_64
kernel-desktop-latest-2.6.39.4-4-mdv2011.0.x86_64
kernel-firmware-20110904-1-mdv2011.0.noarch
kernel-firmware-extra-20110817-1-mdv2011.0.noarch
kernel-headers-2.6.39.4-4.2-mdv2011.0.x86_64
nvidia-current-kernel-2.6.39.4-5.1-desktop-280.13-4-mdv2011.0.x86_64
nvidia-current-kernel-desktop-latest-280.13-1.20120104.4-mdv2011.0.x86_64

Mi sembra che gli headers e i latest corrispondano ad un vecchio kernel (però non è quello disinstallato).

[root@localhost ulissebionda]# more /boot/grub/menu.lst
timeout 5
color black/cyan yellow/cyan
gfxmenu (hd0,0)/boot/gfxmenu
default 0

title linux
kernel (hd0,0)/boot/vmlinuz-2.6.39.4-5.1-desktop BOOT_IMAGE=linux root=UUID=0bbffd40-f831-44d6-97fe-9f72104710a2 no
kmsboot logo.nologo quiet resume=UUID=dc998a2a-7879-4f4c-93c1-647f2fdd7ee2 splash=silent vga=788
initrd (hd0,0)/boot/initrd-2.6.39.4-5.1-desktop.img

title linux-nonfb
kernel (hd0,0)/boot/vmlinuz-2.6.39.4-5.1-desktop BOOT_IMAGE=linux-nonfb root=UUID=0bbffd40-f831-44d6-97fe-9f7210471
0a2 nokmsboot resume=UUID=dc998a2a-7879-4f4c-93c1-647f2fdd7ee2
initrd (hd0,0)/boot/initrd-2.6.39.4-5.1-desktop.img

title failsafe
kernel (hd0,0)/boot/vmlinuz-2.6.39.4-5.1-desktop BOOT_IMAGE=failsafe root=UUID=0bbffd40-f831-44d6-97fe-9f72104710a2
nokmsboot failsafe
initrd (hd0,0)/boot/initrd-2.6.39.4-5.1-desktop.img

Bah...

Inquanto a dolphin, con un nuovo utente:

[ulissebionda@localhost ~]$ dolphin
error of sendto: Connessione rifiutata
Error of writeDatagram
dolphin(30595)/kdeui (kdelibs): Attempt to use QAction "show_information_panel" with KXMLGUIFactory!
dolphin(30595)/kdeui (kdelibs): Attempt to use QAction "show_folders_panel" with KXMLGUIFactory!
dolphin(30595)/kdeui (kdelibs): Attempt to use QAction "show_terminal_panel" with KXMLGUIFactory!
dolphin(30595)/kdeui (kdelibs): Attempt to use QAction "show_filter_panel" with KXMLGUIFactory!
dolphin(30595)/kdeui (kdelibs): Attempt to use QAction "show_places_panel" with KXMLGUIFactory!
dolphin(30595) KXMLGUI::ActionList::plug: Index 25 is not within range (0 - 13
[ulissebionda@localhost ~]$ dolphin(30595)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di granger75
granger75
(Geek)
Offline
Geek
Iscritto: 23/01/2008
Messaggi: 136

Non trovo problemi tra i kernel installati e menu.lst
Temo che come al solito il problema sia la funzione "auto-orphans" di urpmi che toglie pacchetti che orfani non sono. Anche gli errori di dolphin potrebbero dipendere dalla mancanza di "strigi" o qualche altro pacchetto (vallo a sapere....)
ERGO:
1) riinstalla che fai prima;
2) non usare più "auto-orphans".

PS: Quando ho provato la 2011.0, ho avuto un po' di problemi anch'io. Se ti serve una "stabile" [stabile!] ti consiglio di tornare alla 2010.2

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Per il problema di dolphin, rimando alìapposito post....

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5