mancato avvio di x in automatico

8 risposte [Ultimo messaggio]
Ritratto di fandango
fandango
(Newbie)
Offline
Newbie
Iscritto: 27/11/2013
Messaggi: 3

Un saluto a tutti, ho installato da 2 giorni Openmandriva Lx 2013 e devi dire che mi ha colpito positivamente, oggi ho aggiornato il sistema e purtroppo al riavvio non mi parte più il server x, in pratica mi si presenta la richiesta di user e password e una volta loggato devo dare uno startx per far partire KDE, sapete come posso risolvere questo piccolo problemino?

Grazie.

Ritratto di kratos839
kratos839
(Junior)
Offline
Junior
Iscritto: 02/05/2010
Messaggi: 6

Citazione:

mancato avvio di x in automatico
Un saluto a tutti, ho installato da 2 giorni Openmandriva Lx 2013 e devi dire che mi ha colpito positivamente, oggi ho aggiornato il sistema e purtroppo al riavvio non mi parte più il server x, in pratica mi si presenta la richiesta di user e password e una volta loggato devo dare uno startx per far partire KDE, sapete come posso risolvere questo piccolo problemino?
Grazie.

Da quello che ho capito il login lo fai testuale... Per risolvere il problema basti che digiti da utente normale e non da root la seguente stinga:

echo "exec /usr/bin/startx" > ~/.xinitrc

fatto ciò riavvii e dovrebbe funzionare...

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 12/07/2009
Messaggi: 181

Una volta partito KDE puoi andare nel centro di controllo e ripristinare l'avvio grafico.

ciao,
mandian

Ritratto di fandango
fandango
(Newbie)
Offline
Newbie
Iscritto: 27/11/2013
Messaggi: 3

Purtroppo dopo aver dato il comando suggerito il problema si è aggravato ed ora non si avvia più il server grafico neppure con startx Sad
Se può servire questa è la foto della videata dopo il comando startx

http://tinyurl.com/oglkrua

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 12/07/2009
Messaggi: 181

Semplicemente cancelli il file

rm ~/.xinitrc

ciao,
mandian

Ritratto di fandango
fandango
(Newbie)
Offline
Newbie
Iscritto: 27/11/2013
Messaggi: 3

Ok, grazie l'ho appena rimosso ora riavvio e faccio sapere, cmq mi spiace di avere questi strani problemi con una installazione pulita anche perché la distribuzione mi aveva colpito positivamente e ea mi sto un po' demoralizzando Sad
Ok ora la grafica si è avviata correttamente ma non in automatico, l'avvio si ferma alla linea di comando e devo inserire user e password e poi avviare x con startx, in pratica sono messo come spiegato nel primo post Sad

Allora, ho rinominato xorg.conf ed è tornato tutto a posto, avvio grafico in automatico, tutto normale insomma però non ha senso che se vado a configurare il sistema grafico mettendo il mio monitor a la risoluzione che ho sempre usato poi al riavvio x non mi funzioni più.

Ritratto di rugyada
rugyada
(Geek)
Offline
Geek
Iscritto: 05/02/2008
Messaggi: 163

Se non ricordo male - non ho la macchina con OpenMandriva sotto mano - bisogna mettere una spunta nella configurazione del sistema grafico: Avvia l'interfaccia grafica al boot.

rugyada
MIB Team - http://mib.pianetalinux.org/

Ritratto di nicco
nicco
(Guru)
Offline
Guru
Iscritto: 02/04/2005
Messaggi: 1395

Non è colpa di OpenMandriva 2013! La colpa è del nuovo server grafico X14!

Fino al server grafico Xorg X12, che era presente in Mandriva 2010, 2011 e ROSA MArathon, era possibile configurare con i driver open, tutti i parametri relativi al display e alle risoluzioni manualmente con la tool XFdrake, che poi salvava tutto in /etc/X11/xorg.conf

Dal server Xorg 13 in poi, è il server a prendere tutte le decisioni in proposito, e spesso davvero mal interpreta ciò che gli viene specificato tramite il file di avvio /etc/X11/xorg.conf

ci sono dei sistemi per definire delle personalizzazioni, e dei parametri differenti, ma bisogna annullare al boot il KMS, via opzioni grub

ciao, NicCo

Professional experience >>> Community Manager and System Admin: http://pianetalinux.org
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.
OpenMandriva 2014.0 x86_64 - OMV + Kernel Farm + MIB - Kernel-nrjQL-desktop-3.15.6

Ritratto di nicco
nicco
(Guru)
Offline
Guru
Iscritto: 02/04/2005
Messaggi: 1395

Non è colpa di OpenMandriva 2013! La colpa è del nuovo server grafico X14!

Fino al server grafico Xorg X12, che era presente in Mandriva 2010, 2011 e ROSA Marathon, era possibile configurare con i driver open, tutti i parametri relativi al display e alle risoluzioni manualmente con la tool XFdrake, che poi salvava tutto in /etc/X11/xorg.conf

Dal server Xorg 13 in poi, è il server a prendere tutte le decisioni in proposito, e spesso davvero mal interpreta ciò che gli viene specificato tramite il file di avvio /etc/X11/xorg.conf

Ci sono dei sistemi per definire delle personalizzazioni, e dei parametri differenti, ma bisogna annullare al boot il KMS, via opzioni grub

Puoi trovare documentazione in giro circa 'Kernel Mode Setting', per esempio > https://wiki.archlinux.org/index.php/Kernel_Mode_Setting




Gli stessi problemi di mancata possibilità di personalizzazione, li soffre attualmente anche ROSA Fresh R1 / R2, dove ora c'è anche X14




ciao, NicCo

Professional experience >>> Community Manager and System Admin: http://pianetalinux.org
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.
OpenMandriva 2014.0 x86_64 - OMV + Kernel Farm + MIB - Kernel-nrjQL-desktop-3.15.6