La WebCam in skype non funziona.

11 risposte [Ultimo messaggio]
Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 79

Un saluto a tutti.
Ho installato Mandriva 2009 PWPx64 bit e non riesco a risolvere il problema della WebCam in skype.
Ho una webCam della Logitech "QuickCam Communicate STX PLUS".
In mandriva 2008.1 era sufficiente installare i drivers "spca5xx" per avere la webcam funzionante. In mandriva 2009 le ho provate tutte, ma senza risultati.
Qualche suggerimento in merito?
Grazie.
Gino.

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

A parte il fatto che hai installato una versione di mandriva ancora non stabile ...non molto da dire.

Detto cio dai il comando (da root):

<br />lsmod | grep spca5xx<br />

così vediamo se il modulo kernel che dice il CCM (centro di controllo mandriva ) è caricato.

Se il comando non restituisce nulla lo siu puo caricare:

<br />modprove spca5xx<br />

in entrambi i casi lancia anche il comando
<br />ls /dev/video0<br />

se restituisce ls: cannot access /dev/video0: No such file or directory allora il dispositivo non è stato creato dal kernel quindi si puo provare a vedere se nel log del kernel dice qualche cosa in merito alla webcam ossia dai il comano

<br />dmesg<br />

_/\/\/\Bemipefe/\/\/\_

Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 79

Grazie delle risposte.
Ma non ho ottenuto risultati!...
Dunque se digito il primo comando: lsmod | grep spca5xx non restituisce nulla.
Con il secondo: #urpmi modprove spca5xx mi dice che è impossibile trovare modprove spca5xx.
Con il terzo mi dice: [root@localhost gino]# ls /dev/video0
/dev/video0
[root@localhost gino]#
Dando il comando: dmesg mi restituisce questo:

[root@localhost gino]# dmesg
Linux version 2.6.27-desktop-0.rc8.2mnb (pterjan@klodia.mandriva.com) (gcc version 4.3.2 (GCC) ) #1 SMP Thu Oct 2 05:49:37 EDT 2008
Command line: BOOT_IMAGE=linux root=UUID=366fa476-ac35-466d-a068-fefb55e352e2 splash=silent vga=788
KERNEL supported cpus:
Intel GenuineIntel
AMD AuthenticAMD
Centaur CentaurHauls
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000007ffb0000 (usable)
BIOS-e820: 000000007ffb0000 - 000000007ffc0000 (ACPI data)
BIOS-e820: 000000007ffc0000 - 000000007fff0000 (ACPI NVS)
BIOS-e820: 000000007fff0000 - 0000000080000000 (reserved)
BIOS-e820: 00000000fed00000 - 00000000fed00400 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ff380000 - 0000000100000000 (reserved)
last_pfn = 0x7ffb0 max_arch_pfn = 0x3ffffffff
x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
init_memory_mapping
0000000000 - 007fe00000 page 2M
007fe00000 - 007ffb0000 page 4k
kernel direct mapping tables up to 7ffb0000 @ 8000-c000
last_map_addr: 7ffb0000 end: 7ffb0000
RAMDISK: 37c19000 - 37fef7d8
DMI present.
ACPI: RSDP 000F91B0, 0014 (r0 ACPIAM)
ACPI: RSDT 7FFB0000, 0034 (r1 A_M_I OEMRSDT 5000702 MSFT 97)
ACPI: FACP 7FFB0200, 0084 (r2 A M I OEMFACP 12000601 MSFT 97)
ACPI: DSDT 7FFB0440, 4B0B (r1 ASR18 ASR18032 32 INTL 2002026)
ACPI: FACS 7FFC0000, 0040
ACPI: APIC 7FFB0390, 006C (r1 A_M_I OEMAPIC 5000702 MSFT 97)
ACPI: MCFG 7FFB0400, 003C (r1 A_M_I OEMMCFG 5000702 MSFT 97)
ACPI: OEMB 7FFC0040, 0046 (r1 A_M_I AMI_OEM 5000702 MSFT 97)
No NUMA configuration found
Faking a node at 0000000000000000-000000007ffb0000
Bootmem setup node 0 0000000000000000-000000007ffb0000
NODE_DATA [0000000000001000 - 0000000000005fff]
bootmap [000000000000a000 - 0000000000019ff7] pages 10
(6 early reservations) ==> bootmem [0000000000 - 007ffb0000]
#0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
#1 [0000006000 - 0000008000] TRAMPOLINE ==> [0000006000 - 0000008000]
#2 [0000200000 - 00007f194c] TEXT DATA BSS ==> [0000200000 - 00007f194c]
#3 [0037c19000 - 0037fef7d8] RAMDISK ==> [0037c19000 - 0037fef7d8]
#4 [000009fc00 - 0000100000] BIOS reserved ==> [000009fc00 - 0000100000]
#5 [0000008000 - 000000a000] PGTABLE ==> [0000008000 - 000000a000]
found SMP MP-table at [ffff8800000ff780] 000ff780
[ffffe20000000000-ffffe20001bfffff] PMD -> [ffff880001200000-ffff880002dfffff] on node 0
Zone PFN ranges:
DMA 0x00000000 -> 0x00001000
DMA32 0x00001000 -> 0x00100000
Normal 0x00100000 -> 0x00100000
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
0: 0x00000000 -> 0x0000009f
0: 0x00000100 -> 0x0007ffb0
On node 0 totalpages: 524111
DMA zone: 2319 pages, LIFO batch:0
DMA32 zone: 513001 pages, LIFO batch:31
ACPI: PM-Timer IO Port: 0x808
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x82] disabled)
ACPI: LAPIC (acpi_id[0x04] lapic_id[0x83] disabled)
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 0, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Setting APIC routing to flat
Using ACPI (MADT) for SMP configuration information
SMP: Allowing 4 CPUs, 2 hotplug CPUs
PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
PM: Registered nosave memory: 00000000000a0000 - 00000000000e4000
PM: Registered nosave memory: 00000000000e4000 - 0000000000100000
Allocating PCI resources starting at 88000000 (gap: 80000000:7ed00000)
PERCPU: Allocating 51744 bytes of per cpu data
NR_CPUS: 32, nr_cpu_ids: 4, nr_node_ids 1
Built 1 zonelists in Node order, mobility grouping on. Total pages: 515320
Policy zone: DMA32
Kernel command line: BOOT_IMAGE=linux root=UUID=366fa476-ac35-466d-a068-fefb55e352e2 splash=silent vga=788
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 32768 bytes)
TSC: PIT calibration confirmed by PMTIMER.
TSC: using PMTIMER calibration value
Detected 2328.190 MHz processor.
Console: colour dummy device 80x25
console [tty0] enabled
Checking aperture...
No AGP bridge found
Calgary: detecting Calgary via BIOS EBDA area
Calgary: Unable to locate Rio Grande table in EBDA - bailing!
Memory: 2057372k/2096832k available (3077k kernel code, 39072k reserved, 1558k data, 540k init)
CPA: page pool initialized 1 of 1 pages preallocated
SLUB: Genslabs=13, HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
Calibrating delay loop (skipped), value calculated using timer frequency.. 4656.38 BogoMIPS (lpj=2328190)
Security Framework initialized
AppArmor: AppArmor disabled by boottime parameter
Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Mount-cache hash table entries: 256
Hook version: 2.6.27-2.3 2008/08/29
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 4096K
CPU 0/0 -> Node 0
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
CPU0: Thermal monitoring enabled (TM2)
using mwait in idle threads.
Early unpacking initramfs... done
Freeing initrd memory: 3929k freed
ACPI: Core revision 20080609
ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz stepping 0b
Using local APIC timer interrupts.
APIC timer calibration result 20787505
Detected 20.787 MHz APIC timer.
Booting processor 1/1 ip 6000
Initializing CPU#1
Calibrating delay using timer specific routine.. 4656.34 BogoMIPS (lpj=2328174)
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 4096K
CPU 1/1 -> Node 0
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
CPU1: Thermal monitoring enabled (TM2)
x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
CPU1: Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz stepping 0b
checking TSC synchronization [CPU#0 -> CPU#1]: passed.
Brought up 2 CPUs
Total of 2 processors activated (9312.72 BogoMIPS).
CPU0 attaching sched-domain:
domain 0: span 0-1 level MC
groups: 0 1
domain 1: span 0-1 level NODE
groups: 0-1
CPU1 attaching sched-domain:
domain 0: span 0-1 level MC
groups: 1 0
domain 1: span 0-1 level NODE
groups: 0-1
net_namespace: 1552 bytes
Booting paravirtualized kernel on bare hardware
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Found Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub with MMCONFIG support.
PCI: Using MMCONFIG at e0000000 - efffffff
PCI: Using configuration type 1 for base access
ACPI: EC: Look up EC in DSDT
ACPI: Interpreter enabled
ACPI: (supports S0 S1 S3 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:01.0: PME# supported from D0 D3hot D3cold
pci 0000:00:01.0: PME# disabled
pci 0000:00:1c.0: PME# supported from D0 D3hot D3cold
pci 0000:00:1c.0: PME# disabled
pci 0000:00:1c.1: PME# supported from D0 D3hot D3cold
pci 0000:00:1c.1: PME# disabled
PCI: 0000:00:1d.0 reg 20 io port: [b480, b49f]
PCI: 0000:00:1d.1 reg 20 io port: [b800, b81f]
PCI: 0000:00:1d.2 reg 20 io port: [b880, b89f]
PCI: 0000:00:1d.3 reg 20 io port: [bc00, bc1f]
PCI: 0000:00:1d.7 reg 10 32bit mmio: [f9effc00, f9efffff]
pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
pci 0000:00:1d.7: PME# disabled
pci 0000:00:1f.0: Force enabled HPET at 0xfed00000
pci 0000:00:1f.0: quirk: region 0800-087f claimed by ICH6 ACPI/GPIO/TCO
pci 0000:00:1f.0: quirk: region 0480-04bf claimed by ICH6 GPIO
PCI: 0000:00:1f.1 reg 10 io port: [0, 7]
PCI: 0000:00:1f.1 reg 14 io port: [0, 3]
PCI: 0000:00:1f.1 reg 18 io port: [8f0, 8f7]
PCI: 0000:00:1f.1 reg 1c io port: [8f8, 8fb]
PCI: 0000:00:1f.1 reg 20 io port: [ffa0, ffaf]
PCI: 0000:00:1f.2 reg 10 io port: [b400, b407]
PCI: 0000:00:1f.2 reg 14 io port: [b080, b083]
PCI: 0000:00:1f.2 reg 18 io port: [b000, b007]
PCI: 0000:00:1f.2 reg 1c io port: [ac00, ac03]
PCI: 0000:00:1f.2 reg 20 io port: [a880, a88f]
pci 0000:00:1f.2: PME# supported from D3hot
pci 0000:00:1f.2: PME# disabled
PCI: 0000:00:1f.3 reg 20 io port: [400, 41f]
PCI: 0000:03:00.0 reg 10 32bit mmio: [fd000000, fdffffff]
PCI: 0000:03:00.0 reg 14 32bit mmio: [c0000000, dfffffff]
PCI: 0000:03:00.0 reg 1c 64bit mmio: [fa000000, fbffffff]
PCI: 0000:03:00.0 reg 24 io port: [dc00, dc7f]
PCI: 0000:03:00.0 reg 30 32bit mmio: [febe0000, febfffff]
PCI: bridge 0000:00:01.0 io port: [d000, dfff]
PCI: bridge 0000:00:01.0 32bit mmio: [fa000000, febfffff]
PCI: bridge 0000:00:01.0 64bit mmio pref: [c0000000, dfffffff]
PCI: bridge 0000:00:1c.0 64bit mmio pref: [bff00000, bfffffff]
PCI: 0000:01:00.0 reg 10 io port: [c800, c8ff]
PCI: 0000:01:00.0 reg 18 64bit mmio: [f9fff000, f9ffffff]
PCI: 0000:01:00.0 reg 30 32bit mmio: [f9fc0000, f9fdffff]
pci 0000:01:00.0: supports D1
pci 0000:01:00.0: supports D2
pci 0000:01:00.0: PME# supported from D1 D2 D3hot D3cold
pci 0000:01:00.0: PME# disabled
Pre-1.1 PCIe device detected, disable ASPM for 0000:00:1c.1. It can be enabled forcedly with 'pcie_aspm=force'
PCI: bridge 0000:00:1c.1 io port: [c000, cfff]
PCI: bridge 0000:00:1c.1 32bit mmio: [f9f00000, f9ffffff]
PCI: 0000:04:01.0 reg 10 io port: [e880, e89f]
pci 0000:04:01.0: supports D1
pci 0000:04:01.0: supports D2
PCI: 0000:04:01.1 reg 10 io port: [ec00, ec07]
pci 0000:04:01.1: supports D1
pci 0000:04:01.1: supports D2
pci 0000:00:1e.0: transparent bridge
PCI: bridge 0000:00:1e.0 io port: [e000, efff]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P2._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P5._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 10 11 12 14 *15)
ACPI Warning (tbutils-0217): Incorrect checksum in table [OEMB] - 29, should be 24 [20080609]
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 17 devices
ACPI: ACPI bus type pnp unregistered
PCI: Using ACPI for IRQ routing
NetLabel: Initializing
NetLabel: domain hash size = 128
NetLabel: protocols = UNLABELED CIPSOv4
NetLabel: unlabeled traffic allowed by default
DMAR:parse DMAR table failure.
PCI-GART: No AMD northbridge found.
hpet clockevent registered
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
hpet0: 3 64-bit timers, 14318180 Hz
ACPI: RTC can wake from S4
system 00:01: iomem range 0xfed13000-0xfed19fff has been reserved
system 00:07: ioport range 0x4d0-0x4d1 has been reserved
system 00:07: ioport range 0x800-0x87f has been reserved
system 00:07: ioport range 0x480-0x4bf has been reserved
system 00:07: ioport range 0x900-0x90f has been reserved
system 00:07: iomem range 0xfed1c000-0xfed1ffff has been reserved
system 00:07: iomem range 0xfed20000-0xfed8ffff has been reserved
system 00:09: iomem range 0xffc00000-0xfff7ffff could not be reserved
system 00:0a: iomem range 0xfec00000-0xfec00fff has been reserved
system 00:0a: iomem range 0xfee00000-0xfee00fff could not be reserved
system 00:0e: ioport range 0x290-0x29f has been reserved
system 00:0f: iomem range 0xe0000000-0xefffffff could not be reserved
system 00:10: iomem range 0x0-0x9ffff could not be reserved
system 00:10: iomem range 0xc0000-0xcffff has been reserved
system 00:10: iomem range 0xe0000-0xfffff could not be reserved
system 00:10: iomem range 0x100000-0x7fffffff could not be reserved
pci 0000:00:01.0: PCI bridge, secondary bus 0000:03
pci 0000:00:01.0: IO window: 0xd000-0xdfff
pci 0000:00:01.0: MEM window: 0xfa000000-0xfebfffff
pci 0000:00:01.0: PREFETCH window: 0x000000c0000000-0x000000dfffffff
pci 0000:00:1c.0: PCI bridge, secondary bus 0000:02
pci 0000:00:1c.0: IO window: disabled
pci 0000:00:1c.0: MEM window: disabled
pci 0000:00:1c.0: PREFETCH window: 0x000000bff00000-0x000000bfffffff
pci 0000:00:1c.1: PCI bridge, secondary bus 0000:01
pci 0000:00:1c.1: IO window: 0xc000-0xcfff
pci 0000:00:1c.1: MEM window: 0xf9f00000-0xf9ffffff
pci 0000:00:1c.1: PREFETCH window: disabled
pci 0000:00:1e.0: PCI bridge, secondary bus 0000:04
pci 0000:00:1e.0: IO window: 0xe000-0xefff
pci 0000:00:1e.0: MEM window: disabled
pci 0000:00:1e.0: PREFETCH window: disabled
pci 0000:00:01.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:01.0: setting latency timer to 64
pci 0000:00:1c.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:1c.0: setting latency timer to 64
pci 0000:00:1c.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
pci 0000:00:1c.1: setting latency timer to 64
pci 0000:00:1e.0: setting latency timer to 64
bus: 00 index 0 io port: [0, ffff]
bus: 00 index 1 mmio: [0, ffffffffffffffff]
bus: 03 index 0 io port: [d000, dfff]
bus: 03 index 1 mmio: [fa000000, febfffff]
bus: 03 index 2 mmio: [c0000000, dfffffff]
bus: 03 index 3 mmio: [0, 0]
bus: 02 index 0 mmio: [0, 0]
bus: 02 index 1 mmio: [0, 0]
bus: 02 index 2 mmio: [bff00000, bfffffff]
bus: 02 index 3 mmio: [0, 0]
bus: 01 index 0 io port: [c000, cfff]
bus: 01 index 1 mmio: [f9f00000, f9ffffff]
bus: 01 index 2 mmio: [0, 0]
bus: 01 index 3 mmio: [0, 0]
bus: 04 index 0 io port: [e000, efff]
bus: 04 index 1 mmio: [0, 0]
bus: 04 index 2 mmio: [0, 0]
bus: 04 index 3 io port: [0, ffff]
bus: 04 index 4 mmio: [0, ffffffffffffffff]
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
NET: Registered protocol family 1
audit: initializing netlink socket (disabled)
type=2000 audit(1224456047.276:1): initialized
HugeTLB registered 2 MB page size, pre-allocated 0 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
msgmni has been set to 4025
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci 0000:03:00.0: Boot video device
pcieport-driver 0000:00:01.0: setting latency timer to 64
pcieport-driver 0000:00:01.0: found MSI capability
pci_express 0000:00:01.0:pcie00: allocate port service
pci_express 0000:00:01.0:pcie03: allocate port service
pcieport-driver 0000:00:1c.0: setting latency timer to 64
pcieport-driver 0000:00:1c.0: found MSI capability
pci_express 0000:00:1c.0:pcie00: allocate port service
pci_express 0000:00:1c.0:pcie02: allocate port service
pci_express 0000:00:1c.0:pcie03: allocate port service
pcieport-driver 0000:00:1c.1: setting latency timer to 64
pcieport-driver 0000:00:1c.1: found MSI capability
pci_express 0000:00:1c.1:pcie00: allocate port service
pci_express 0000:00:1c.1:pcie02: allocate port service
pci_express 0000:00:1c.1:pcie03: allocate port service
vesafb: framebuffer at 0xfb000000, mapped to 0xffffc20010980000, using 1875k, total 14336k
vesafb: mode is 800x600x16, linelength=1600, pages=2
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
Linux agpgart interface v0.103
Serial: 8250/16550 driver4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:0d: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
brd: module loaded
input: Macintosh mouse button emulation as /class/input/input0
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard as /class/input/input1
cpuidle: using governor ladder
cpuidle: using governor menu
TCP cubic registered
registered taskstats version 1
BIOS EDD facility v0.16 2004-Jun-25, 2 devices found
Freeing unused kernel memory: 540k freed
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
ehci_hcd 0000:00:1d.7: setting latency timer to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: debug port 1
ehci_hcd 0000:00:1d.7: cache line size of 32 is not supported
ehci_hcd 0000:00:1d.7: irq 23, io mem 0xf9effc00
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
Switched to high resolution mode on CPU 1
Switched to high resolution mode on CPU 0
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: EHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.27-desktop-0.rc8.2mnb ehci_hcd
usb usb1: SerialNumber: 0000:00:1d.7
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
USB Universal Host Controller Interface driver v3.0
uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
uhci_hcd 0000:00:1d.0: setting latency timer to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 23, io base 0x0000b480
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: UHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.27-desktop-0.rc8.2mnb uhci_hcd
usb usb2: SerialNumber: 0000:00:1d.0
uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
uhci_hcd 0000:00:1d.1: setting latency timer to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 19, io base 0x0000b800
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: UHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.27-desktop-0.rc8.2mnb uhci_hcd
usb usb3: SerialNumber: 0000:00:1d.1
uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
uhci_hcd 0000:00:1d.2: setting latency timer to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 18, io base 0x0000b880
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb4: Product: UHCI Host Controller
usb usb4: Manufacturer: Linux 2.6.27-desktop-0.rc8.2mnb uhci_hcd
usb usb4: SerialNumber: 0000:00:1d.2
uhci_hcd 0000:00:1d.3: PCI INT D -> GSI 16 (level, low) -> IRQ 16
uhci_hcd 0000:00:1d.3: setting latency timer to 64
uhci_hcd 0000:00:1d.3: UHCI Host Controller
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
uhci_hcd 0000:00:1d.3: irq 16, io base 0x0000bc00
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 2 ports detected
usb 3-1: new full speed USB device using uhci_hcd and address 2
input: ImPS/2 Generic Wheel Mouse as /class/input/input2
usb 3-1: configuration #1 chosen from 1 choice
usb 3-1: New USB device found, idVendor=046d, idProduct=08ad
usb 3-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb5: Product: UHCI Host Controller
usb usb5: Manufacturer: Linux 2.6.27-desktop-0.rc8.2mnb uhci_hcd
usb usb5: SerialNumber: 0000:00:1d.3
SCSI subsystem initialized
Driver 'sd' needs updating - please use bus_type methods
No dock devices found.
libata version 3.00 loaded.
ata_piix 0000:00:1f.1: version 2.12
ata_piix 0000:00:1f.1: PCI INT A -> GSI 18 (level, low) -> IRQ 18
ata_piix 0000:00:1f.1: setting latency timer to 64
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
usb 3-2: new full speed USB device using uhci_hcd and address 3
usb 3-2: configuration #1 chosen from 1 choice
usb 3-2: New USB device found, idVendor=03f0, idProduct=0605
usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-2: Product: HP ScanJet 2200C
usb 3-2: Manufacturer: Hewlett-Packard
ata1.00: HPA detected: current 398294975, native 398297088
ata1.00: ATA-7: Maxtor 6L200P0, BAJ41G20, max UDMA/133
ata1.00: 398294975 sectors, multi 16: LBA48
ata1.01: ATAPI: HL-DT-STDVD-RAM GSA-H50L, 1.00, max UDMA/66
ata1.00: configured for UDMA/100
ata1.01: configured for UDMA/66
ata2: port disabled. ignoring.
isa bounce pool size: 16 pages
scsi 0:0:0:0: Direct-Access ATA Maxtor 6L200P0 BAJ4 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 398294975 512-byte hardware sectors (203927 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 398294975 512-byte hardware sectors (203927 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 >
sd 0:0:0:0: [sda] Attached SCSI disk
scsi 0:0:1:0: CD-ROM HL-DT-ST DVD-RAM GSA-H50L 1.00 PQ: 0 ANSI: 5
ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
ata_piix 0000:00:1f.2: setting latency timer to 64
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0xb400 ctl 0xb080 bmdma 0xa880 irq 19
ata4: SATA max UDMA/133 cmd 0xb000 ctl 0xac00 bmdma 0xa888 irq 19
ata3.00: ATA-7: MAXTOR STM3320820AS, 3.AAE, max UDMA/133
ata3.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata3.00: configured for UDMA/133
scsi 2:0:0:0: Direct-Access ATA MAXTOR STM332082 3.AA PQ: 0 ANSI: 5
sd 2:0:0:0: [sdb] 625142448 512-byte hardware sectors (320073 MB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 2:0:0:0: [sdb] 625142448 512-byte hardware sectors (320073 MB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 00 3a 00 00
sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1 sdb2 sdb3 < sdb5 sdb6 sdb7 sdb8 sdb9 sdb10 sdb11 sdb12 sdb13 >
sd 2:0:0:0: [sdb] Attached SCSI disk
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
TomoyoLinux Mandatory Access Control disabled by default.
You need to install ccs-tools if you want to enable it.
sd 0:0:0:0: Attached scsi generic sg0 type 0
scsi 0:0:1:0: Attached scsi generic sg1 type 5
sd 2:0:0:0: Attached scsi generic sg2 type 0
iTCO_vendor_support: vendor-support=0
iTCO_wdt: Intel TCO WatchDog Timer Driver v1.03 (30-Apr-2008)
iTCO_wdt: Found a ICH7 or ICH7R TCO device (Version=2, TCOBASE=0x0860)
iTCO_wdt: initialized. heartbeat=30 sec (nowayout=1)
Driver 'sr' needs updating - please use bus_type methods
sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 0:0:1:0: Attached scsi CD-ROM sr0
parport_pc 00:06: reported by Plug and Play ACPI
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:01:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
r8169 0000:01:00.0: setting latency timer to 64
r8169 0000:01:00.0: no MSI. Back to INTx.
eth0: RTL8101e at 0xffffc20000334000, 00:19:66:26:7d:6f, XID 34000000 IRQ 17
rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0
rtc0: alarms up to one month, hpet irqs
Linux video capture interface: v2.00
usbcore: registered new interface driver snd-usb-audio
gspca: main v2.2.0 registered
gspca: probing 046d:08ad
gameport: EMU10K1 is pci0000:04:01.1/gameport0, io 0xec00, speed 1061kHz
ppdev: user-space parallel port driver
input: Power Button (FF) as /class/input/input3
EMU10K1_Audigy 0000:04:01.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
ACPI: Power Button (FF) [PWRF]
input: Power Button (CM) as /class/input/input4
ACPI: SSDT 7FFC0090, 01D2 (r1 AMI CPU1PM 1 INTL 20051117)
i801_smbus 0000:00:1f.3: PCI INT B -> GSI 19 (level, low) -> IRQ 19
processor ACPI0007:00: registered as cooling_device0
ACPI: SSDT 7FFC0270, 0143 (r1 AMI CPU2PM 1 INTL 20051117)
processor ACPI0007:01: registered as cooling_device1
ACPI: Power Button (CM) [PWRB]
zc3xx: probe 2wr ov vga 0x0000
zc3xx: probe sensor -> 11
zc3xx: Find Sensor HV7131R(c)
gspca: probe ok
usbcore: registered new interface driver zc3xx
zc3xx: registered
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com
EXT3 FS on sda5, internal journal
fuse init (API version 7.9)
loop: module loaded
Adding 1558264k swap on /dev/sda6. Priority:-1 extents:1 across:1558264k
IPVS: Registered protocols (TCP, UDP, AH, ESP)
IPVS: Connection hash table configured (size=4096, memory=64Kbytes)
IPVS: Each connection entry needs 224 bytes at least
IPVS: ipvs loaded.
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: Successfully done.
vboxdrv: Found 2 processor cores.
vboxdrv: fAsync=0 offMin=0x1a4 offMax=0x6ac
vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
vboxdrv: Successfully loaded version 2.0.2_OSE (interface 0x00090000).
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
r8169: eth0: link up
r8169: eth0: link up
NET: Registered protocol family 17
nvidia: module license 'NVIDIA' taints kernel.
nvidia 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
nvidia 0000:03:00.0: setting latency timer to 64
NVRM: loading NVIDIA UNIX x86_64 Kernel Module 177.70 Wed Aug 27 12:46:19 PDT2008
usbcore: registered new interface driver usblp
eth0: no IPv6 routers present
process `skype' is using obsolete setsockopt SO_BSDCOMPAT
[root@localhost gino]#
Io non ci capisco nulla!... e chiedo scusa di questa lunga 'papardella'!...
Come risolvere per potere far sì che la mia webcam QuickCam Communicate STX PLUS possa funzionare?
Grazie di cuore a chi vorrà darmi un aiuto per risolvere questo mio problema che non avevo in Mandriva 2008.1.
Faccio presente che adesso ho installato un Mandriva 2009 X86_64 bit. Tutto il resto mi funziona bene.
Grazie.
Gino

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Allora il primo comando non restituisce nulla perchè il moulo del kernel relativo alla tua webcam in realtà si chiama gspca e non spca5xx.

Il secondo comando va a vuoto perchè ho sbagliato io ....Wink il comando è modprobe e non "modprove" ma in ogni caso non c'è bisogno di caricare niente poichè dal log del kernel risulta che la webcam è caricata.

Ossia:
<br />...<br /><br />gspca: main v2.2.0 registered<br />gspca: probing 046d:08ad  <br /><br />...<br />

In oltre il fatto che il comando ls ti restituisca il dispositivo /dev/video0 è buon segno, questo vol dire che il modulo è stato caricato è il dispositivo è stato associato all'hardware.

Dai il comando lsusb e vedi se il dispositivo 046d:08ad corrisponde alla webcam (io penso proprio di si Laughing.

Se non ti funziona con skype puoi provarla installando camstream dal gestore dei pacchetti o da shell come utente root

<br />urpmi camstream<br />

Facci Sapere

_/\/\/\Bemipefe/\/\/\_

Ritratto di spiderrock
spiderrock
(Geek)
Offline
Geek
Iscritto: 17/03/2006
Messaggi: 124

Ciao
io ho la webcam

Bus 002 Device 002: ID 046d:08da Logitech, Inc. QuickCam Messanger

penso che non sia molto diversa dalla tua

per utilizzarla in skype basta seguire le istruzioni contenute negli errata 2009

http://wiki.mandriva.com/it/2009.0_Errata

n.b. se il tuo sistema è 64 bit devi rimuovere il pacchetto libv4l a 64 bit e sostituirlo con l'omonimo a 32 bit

Facci sapere

Ciao

Mandriva 2010 64 bit - KDE4.4.2 - Intel Pentium Dual E2200 - 4 GB RAM - LVM 1,4 TB - Nvidia GT240

Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 79

Grazie a Bemipefe e a spiderrock per le risposte.
Ho seguito quanto ha detto Bemipefe installando #urpmi camstream e ho anche rimosso libv4l e sostituito con l'omonimo a 32 bit, come suggerito da spiderrock.
In conclusione dopo avere fatto il riavvio, la situazione non cambia: la WebCam QuickCam Communicate STX Plus non funziona!...
Cosa fare ancora? Forse che sia meglio reinstallare mandriva 2009 32 bital posto della 64 bit? Chissà che così funzioni la webcam?....
Grazie dell'aiuto.
Gino

Ritratto di spiderrock
spiderrock
(Geek)
Offline
Geek
Iscritto: 17/03/2006
Messaggi: 124

vai in konsole e digita:

LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

dovrebbe funzionare

ciao

Mandriva 2010 64 bit - KDE4.4.2 - Intel Pentium Dual E2200 - 4 GB RAM - LVM 1,4 TB - Nvidia GT240

Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 79

Grazie, spiderrock.
Avevo già notato questo che dici sopra e già fatto.
Ma digitando: LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype lo skype funziona per parlare al microfono e ricevere la voce da altri. Ma la webcam non funziona! Inoltre quando uno mi chiama, appena rispondo lo skype crasha, cioè 'cade giù' e sparisce... devo richiamarlo di nuovo da K/menu/internet. Lo stesso appena inizia a parlare un altro!
Secondo me dovrebbe trattarsi di qualche driver che non so, poiché se cerco di fare la "Prova" e avviare la webcam nella finestrella appare un movimento di colori vari: verde e rosso..., ma non esce l'immagine.
Cosa tentare di fare anvora?
Grazie.
Gino.

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Nella lista delle webcam supportate :

http://mxhaard.free.fr/spca5xx.html

non compare la tua. Però se dici che con MDV 2008.1 ti funzionava con spca5xx possimao provare a caricare questo.

In particolare:

<br />rmmod gspca<br />modprobe spca5xx <br />dmesg | grep -C 10 spca5xx<br />

se neanche questo funzona puoi provare con un altro driver

<br />rmmod spca5xx <br />rmmod gspca<br />modprobe uvcvideo <br />dmesg | grep -C 10 uvcvideo<br />

Oppure come unltima spiaggia reninstalla Mandriva 2008.1 Wink

_/\/\/\Bemipefe/\/\/\_

Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 09/09/2004
Messaggi: 79

Grazie, bemipefe, della tua risposta. Sei stato gentile e professionale.
Ho eseguito tutto quanto mi hai suggerito senza ottenere risultati positivi!
La risposta ad ogni installazione dei drivers da te datimi, era "nessun pacchetto denominato....". Ad es., "urpmi rmmod gspca", risposta: "Nessun pacchetto denominato rmmod spca" o "spca5xx" ecc., ecc.
Conclusione: Ho reinstallato Mandriva 2008.1 e qui tutto fila liscio: WebCam QuickCam funziona!.... Virtualbox funziona!...., ecc., ecc. Non capisco il perché.
Forse il KDE4 non è ancora 'maturo'!... Non so!
Mi dispiace tornare indietro!..., ma vedremo più avanti se le cose miglioreranno!..
Grazie di tutto.
Gino.

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Uhm ..... ma perchè metti sempre "urpmi" prima dei comandi ?

Non devi metterlo. Urpmi serve per installare pacchetti, quelli che ti ho dato sono comandi che devono essere lanciati così come sono.

KDE4 è abbastanza usabile anche se non è proprio pronto al 100%. Il problema piu che altro è in Mandriva 2009 che è ancora giovane. Bisognerà aspettare appunro il "2009" per avere una release un po piu stabile.

Ora per curiosità vorrei capire che diavolo di driver usa MDV 2008.1 ...
da root dai:
<br />lsmod | grep gspca<br />lsmod | grep uvc<br />lsmod | grep spca<br />

Uno dei tre dovrebbe andare, gli altri non ti restituiranno nulla a video.

CIAO!

_/\/\/\Bemipefe/\/\/\_