kernel 2.6.8.1-10 o -20......help me!!!

9 risposte [Ultimo messaggio]
Ritratto di chiptuttofuso
chiptuttofuso
(Junior)
Offline
Junior
Iscritto: 09/12/2004
Messaggi: 20

ciao sono nuovo,e mi sono innamorato di mandrake! Big Grin
ho installato la 10.1 community....e andava tutto a meraviglia però avevo problemi audio irrisolvibili.....poi ho provato la 10.1 official...e meraviglia!!!! la mia audigy lavora a meraviglia!!!
però....aime non ho fatto i conti con i driver nvidia.....eh si perchè la community montava il kernel 2.6.8.1-10 mentra la official monta il -12....e (siccome io sono proprio sfigato) mi da errore in fase di installazione dei driver nvidia.
ho seguito la guida del vostro sito...con entrambi i driver nvidia la installazione non va abuon fine perchè mi dice che mancano i sorgenti del kernel (premetto che,avendo seguito la guida passo passo i sorgenti del kernel li ho gia installati).
quindi sono giunto alla conclusione che il kernel -12 risulta incompatibile...ma sempre nella guida sta scritto che il -10 con i driver 6629 vanno a meraviglia...e in fondo alla pagina un tizio ha postato che vanno anche a meraviglia con il kernel -20.
la mia domanda è: cosa mi conviene fare??
scaricare da qualche parte il kernel 2.6.8.1-20?? e se si...da dove dato che non lo trovo da nessuna parte??

oppure installo il -10 dal 3 cd di mandrake community???

ps: installando prima la community e poi la official facendo l'aggiornamento da cd...mi da sempre lo stesso erorre!!!
confido un tutti voi....grazie!

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

Ciao, fai attenzione che i tuoi sorgenti del kernel siano della stessa versione del kernle in uso. Cioè. Se hai installato la versione del kernel -12 tali devono essere anche i sorgenti.. Se hai la -10 dei sorgenti, la 6629 non può installarsi..

C'e' anche la possibilità di installare anche il kernel -20 (e relativi sorgenti) io li ho provati e funzionano perfettamente sia con la community 10.1 che con la official!! Ovviamente, in questo caso il driver della 6629 ti chiederà di "ricompilarsi", ma la procedura è identica (per questo trovo strano che non ti funzionino con il tuo kernel)... Abbiamo un post sui driver 6629 e la guida relativa.

RICORDATI DI MODIFICARE I FILE DI CONFIGURAZIONE così come descritto nella guida... I 3/4 delle persone hanno problemi perché NON MODIFICANO LA CONFIGURAZIONE Thinking (l'altro quarto perché ha i sorgenti sbagliati)

se vuoi scaricare i sorgenti della -20 (che non puoi trovare sui CD, xche fanno parte della release cooker - e non offcial - che è la release sperimentale) puoi trovarli qui:

il kernel:
ftp://ftp.proxad.net/pub/Distributions_Linux/Mandrakelinux/devel/cooker/i586/media/main/kernel-2.6.8.1.20mdk-1-1mdk.i586.rpm

i suoi sorgenti.
ftp://ftp.proxad.net/pub/Distributions_Linux/Mandrakelinux/devel/cooker/i586/media/main/kernel-source-2.6-2.6.8.1-20mdk.i586.rpm

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di chiptuttofuso
chiptuttofuso
(Junior)
Offline
Junior
Iscritto: 09/12/2004
Messaggi: 20

grazie pinguino!!!
come ti ho detto non commetto errori nell'isntallazione...infatti con la community che ha kernel -10 tutto ok...con la official e kernel -.12 uin disastro!!!
allora faccio cosi:
installo di sana pianta la official
cambio il kernel (basta solamente lanciare i due rpm che mi hai linkato o devo fare altro??)
installo i driver nvidia e speriamo bene!!!

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

Quote:

installo di sana pianta la official

ma no! basta solo installar il nuovo kernel o controllare di avere kernel e source nella stessa versione

Quote:

cambio il kernel (basta solamente lanciare i due rpm che mi hai linkato o devo fare altro??)

Esatto. Poi riavvia. In Lilo ti comparirannonuove voci, ma tu scegli cmq "linux" (le altre voci si riferiscono al vecchio kernel..che in caso di problemi puoi ancora avviare)

Quote:

installo i driver nvidia e speriamo bene!!!

No. Installa i driver E METTI MANO ALLE CONFIGURAZIONI!

per sicurezza lancia anche un modprobe nvidia (ovviamente come root) e poi il comando init 5... Se va tutto sei a cavallo. Riavvia e controlla che parta tutto all'avvio.

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di chiptuttofuso
chiptuttofuso
(Junior)
Offline
Junior
Iscritto: 09/12/2004
Messaggi: 20

grazie sei gentilissimo!
provo e ti faccio sapere....
ah potresti darmi qualche mirrow per pacchetti rpm??
non ne conosco nemmeno uno.....in particolare cerco kylix...è come delphi ma per linux.....
grazie mille

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

semplice:

vai su http://easyurpmi.zarb.org/ e scegli i mirror che più ti aggradano, seguendo il passo-passo del sito..

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di chiptuttofuso
chiptuttofuso
(Junior)
Offline
Junior
Iscritto: 09/12/2004
Messaggi: 20

pinguino missione compiuta....ora funziona tutto!!!!!!!!!!
devo installare adesso una web cam ed una lavagnetta elettronica...apro un nuovo post o continuiamo la discussione qui???

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

No, apri un nuovo post (meglio 2), così chiunque sappia come risolvere eventuali problemi ti possa dare una mano... quanto a me.. Non ho né webcam né lavagnette.. ma se riesco cercherò cmq di darti una mano!

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di abmcr
abmcr
(Geek)
Offline
Geek
Iscritto: 29/10/2004
Messaggi: 143

Una info: se si installa il nuovo kernel come rpm e poi si vuole cancellare il vecchio come si fa?

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

ovviamente sempre tramite rpm:

apri il Mandrake Control Center, Vai nella sezione software, clicchi su "uninstall" e cerchi "kernel".. ti comparirà una lista di kernel... scegli quello vecchio (occhio a non scegliere il nuovo Wink )

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16