Installazione Mandriva 2006 e Ati Radeon 9600 Pro

17 risposte [Ultimo messaggio]
Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Salve a tutti,
sono 2 giorni che smanetto sulla Mandriva 2006 con risultati nulli o quasi. Il problema è che dopo le schermate di installazione, al riavvio, Mandriva ricompare con una schermata con colori "strani", come se si guardasse un negativo con colori innaturali e molti artefatti e imperfezioni nella grafica. I colori dominanti sono il viola e il verde chiaro con tonalità fosforescenti. Il tutto molto strano. Ho provato anche a scaricare i driver video dal sito Ati e ad installarli secondo le istruzioni lì riportate senza alcun risultato. La scheda grafica che uso è una Ati Radeon 9600 Pro 256 MB su slot Agp.
Con precedenti versioni della Mandriva non ho mai avuto problemi da questo punto di vista.
Spero che mi aiutiate a capire se si tratta di un problema diffuso o se può presumersi la corruzione del file iso scaricato da internet.
Grazie a tutti per gli eventuali interventi.

Sad Sad Sad

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Non ti preoccupare non stai diventandi pazzo.
Pultroppo avrebbero dovuto aspettare ancora qualche giorno a rilasciare Mandriva 2006.

Le soluzioni sono 2:

1) Aggiorni XOrg e solo quello all'ultima release presente in Cooker (Per gli indirizzi vedi mia rubrica su Cooker in home page)

2) Segui quello che spiego qui http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=3020&forum=1&post_id=22689#forumpost22689
da qualche parte. In pratica bisogna fare il downgrade del file xorg o giù di li.

Ovviamente è migliore la prima soluzione ma devi sporcarti le mani con Cooker.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Carissimo, ti ringrazio per la risposta perchè mi fa intravvedere uno spiraglio di luce dopo vari tentativi infruttuosi. Ho visto in home che i tuoi topic sono ben evidenziati e ciò mi lascia solo intuire il grado della tua esperienza e preparazione. Purtroppo il mio livello è parecchio più basso e mi trovo ad affrontare problemi di varia natura nel seguire il tuo consiglio. In effetti, come avrai potuto intuire leggendo il mio messaggio non sono stato in grado di individuare tecnicamente la fonte del problema e di qui la necessità di darne un'indicazione puramente "descrittiva", come hai potuto leggere tu stesso.
Innanzitutto la sequenza dei passi da seguire per introdurre un pacchetto coker, ma a tal proposito mi leggerò con calma la discussione. Piuttosto, il pacchetto che indefinitiva bisogna sostituire è questo che leggo da una tua risposta?

6.9-1.cvs20051011.1mdk

"Finalmente sono riusciti a risolvere i problemi dei CrazyColor relativamente alle vecchie schede ATI.
Con l'aggiornamento alla versione 6.9-1.cvs20051011.1mdk tutto è tornato alla normalità.
Questo BUG ha resistito la bellezza di 34 giorni, doveva essere proprio difficile da beccare."

Immagino si tratti di xorg 6.9-1.cvs20051011.1mdk o sbaglio?
Hai un link dal quale poterlo reperire?
Posso installarlo semplicemete così com'è, pur avendo provato coi driver dell'Ati, oppure devo cancellare qualcosa prima?
Saluti

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Ho trovato questo pacchetto:
xorg-x11-Xprt-6.9-1.cvs20051011.2mdk.i586.rpm
a questo link:
http://rpm.pbone.net/index.php3/stat/22/idpl/2279359/com/changelog.html
E' quello giusto?
Ho qualche dubbio perchè parlano di print server... :-o
Ma perchè l'aggiornamento non è ancora stato messo per la versione official?

Ritratto di lupin
lupin
(Monster)
Offline
Monster
Iscritto: 21/08/2005
Messaggi: 289

Scusa se sono un pò banale, ma perché non provi a scaricarti i files giusti dal sito ufficiale di ATI?
Anche io ho un ATI radeon ed ho risolto in questo modo.
https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27
Ciao e fammi sapere

La conoscenza appartiene al mondo intero !

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Ciao grazie per il suggerimento.
Come ho detto all'inizio, ho provato a scaricare il paccone da 60 MB dal sito dell'Ati (quello con estensione....run) e l'ho installato secondo le istruzioni del sito, ma non si è risolto il problema. A quanto ho capito dalla discussione affrontata da Moreno il problema dovrebbe essere un altro e riguardare il pacchetto XOrg.
Ma non escludo di aver toppato qualcosa nella procedura con l'installer. Tu che passaggi hai seguito? (più o meno) E quale driver hai usato?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Per aggiornare xorg a cooker devi:

1) Aggiungere la sorgente Cooker
urpmi.addmedia --update CookerMainf ftp://ftp.proxad.net/pub/Distributions_Linux/Mandrake/devel/cooker/i586/media/main/ with hdlist.cz

2) Aggiornare la sorgente
urpmi.update -a

3) Lanci MandrivaUpdate
Li selezioni solo i pacchetti di xorg e lannci l'aggiornamento.

Mi raccomando stai attento a non essere risucchiato nel vortice di Cooker.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Ok grazie ti farò sapere...
Dev'essere parecchio pericoloso sto vortice...
Ci sono vantaggi?

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

GRANDISSIMO Moreno Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin :idea:

Ti sto scrivendo da una Mandriva ristabilita!!!!
Ha funzionato!!!!!!!!!
:roll: :roll: :roll: :roll: :roll: :roll:

Grazie mille sei un grande!
Ti dovrei offrire da bere :pint: :pint:

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

A parte un piccolo impuntamento in chiusura, evento saltuario per cui ho dovuto resettare, tutto bene.
Ma perchè non mettono i pacchetti per risolvere il problema dei Crazycolors tra gli aggiornamenti ufficiali e indispensabili?

Ritratto di Carciofone
Carciofone
(Monster)
Offline
Monster
Iscritto: 13/11/2005
Messaggi: 282

Ho trovato questa guida che riporto per comodità:

Accelerazione grafica con driver Ati Radeon Mobility 9200 su Acer Aspire 1350

1. Accelerazione grafica con i driver proprietari sulla Mandriva 2006

Come per il modem interno, durante l'installazione la Mandriva 2006 permette d'installare i driver proprietari di questa scheda video ed i moduli del kernel. Si tratta di tre pacchetti, ati-8.16.20 e ati-kernel, che spesso non abilitano l'accelerazione grafica. Vanno, perciò, disinstallati con i comandi
# urpme ati-8.16.20
# urpme ati-kernel
# urpme dkms-ati-8.16.20.
Successivamente, si consiglia seguire questa procedura:

Riavviare il server grafico con CTRL+ALT+BACKSPACE
Accertarsi di avere installato i sorgenti del kernel in uso con il comando $ rpm -qa | grep kernel
Prelevare dal sito della ati i driver.
Da shell, posizionarsi nella cartella dove sono stati scaricati i driver e dare, da root, questo comando: # sh ati-driver-installer-8.18.6-i386.run
Seguire le indicazioni a schermo della finestra di dialogo del programma d'installazione.
Terminata l'installazione dei driver, eseguire il comando # fglrxconfig che, attraverso una serie di domande, provvederà a modificare il file /etc/X11/xorg.conf con i parametri giusti per far funzionare l'accelerazione grafica. Riavviare la macchina.
Dopo aver riavviato il sistema, l'accelerazione grafica non funziona ancora: infatti, con i comandi $ fglrxinfo e $ fgl_glxgears si possono avere esplicite informazioni relative al funzionamento dell'accelerazione grafica. Bisognerà quindi controllare file Xorg.0.log dove solitamente vengono riportati alcuni errori tra cui, in questo caso, uno dei i più comuni é il seguente:
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe0984000 at 0x40232000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): **********************************************

Per evitare questo genere di errore bisogna caricare il modulo agp relativo al chipset della scheda madre: ad esempio, se si tratta del chipset VIA, bisogneà caricare con il comando modprobe il modulo via_agp.
Controllare, inoltre, che nel file /etc/modprobe.preload siano inseriti i seguenti moduli: agpgart, via_agp, fglrx da caricare al boot.
Infine, per un corretto funzionamento del driver, abilitare la POSIX shared memory inserendo nel file /etc/fstab la seguente riga: tmpfs /dev/shm tmpfs defaults 0 0
e dare il comando # mount /dev/shm

2. Verifica dell'accelerazione grafica

Si effettua con il comando $ fglrxinfo e con il comando $ fgl_glxgears.
Nel primo caso, l'output sarà simile a questo:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY/RADEON 9000 DDR Generic
OpenGL version string: 1.3.1014 (X4.3.0-8.18.6)

Mentre, nel secondo caso, sarà:

$ fgl_glxgears
Using GLX_SGIX_pbuffer
1488 frames in 5.0 seconds = 297.600 FPS
1616 frames in 5.0 seconds = 323.200 FPS
1277 frames in 5.0 seconds = 255.400 FPS
1352 frames in 5.0 seconds = 270.400 FPS
1203 frames in 5.0 seconds = 240.600 FPS
1328 frames in 5.0 seconds = 265.600 FPS
2746 frames in 5.0 seconds = 549.200 FPS
2604 frames in 5.0 seconds = 520.800 FPS

Ora l'accelerazione grafica funziona e la visione dei dvd o l'esecuzione di giochi come foobillard sono fluide

Link originario : http://happytux.altervista.org/tutorial/pages/ati.html