Freezing e composizione lenta..

9 risposte [Ultimo messaggio]
Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Ciao,
quello che chiedo è essenzialmente un metodo, una procedura, pr riuscire a scoprire quali sono i problemi che ha la mia Mandriva.

Intanto la versione 2010.2 32b con alcuni aggiornamenti del MIB (adesso la repository è disattivata quindi un po' alla volta se ne andranno) senza dual boot o altro.
Il Pc direi che non è scarso:
AMD Athlon 64x2 dual core 5200+
NVIDIA GeForce6150SE (o nForce 430? Boh guardo meglio, comunque mai avuto problemi prima),(con i driver NVIDIA installati)
HD 1T + 250G + esterno da 1T
3Gb di RAM

Eppure continuo ad avere blocchi vari (all'apertura di Firefox, di Amarok, con Open Office o Gimp quando salvo ecc...), oltretutto all'inizio il PC è estremamente lento, tanto che mi compare regolarmente un messaggio del tipo: "
la composizione è troppo lenta ed è stata disabilitata, se si tratta di un problema temporaneo fa ctr+alt+F12 per riattivarla".

Non riesco a capire cosa abbia impostato, installato o dimenticato di installare. Mi sapete dare qualche dritta su come cercare il problema?

Grazie

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Da quello che ho capito usi KDE. Hai i driver proprietari nvidia? Se no installali. Un'altra cosa che potresti controllare è nel centro di controllo kde. Prova a vedere se nella sezione effetti del desktop, scheda avanzate non c'è la spunta su "abilita render diretto". Se è flaggata quell'opzione toglila.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Sì uso KDE (scusa se non lo avevo specificato). I driver sono proprietari.
Sono andato a controllare e mi ricordavo bene, il flag non è spuntato.

Ho provato a guardare quali programmi mi consumano memoria e RAM ma sono i "soliti noti" X, Amarok e Firefox, niente di particolare...
Boh non so che dire

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Hai fatto un test con un altro utente? Magari usando l'utente xguest.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Nicola, fatto il test e con l'utente Xguest funziona decisamente meglio.
E' anche vero che quell'utente è ebbastanza spartano (nel senso che non ha vari desktop e plasmoidi vari)
Che faccio?
Provo a togliere o rinominare la cartella .KDE4?

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Direi che a questo punto una prova conviene farla. Al limite rinomina soltanto .kde4 e riavvia kde. Prova a fare qualche personalizzazione con gli effetti attivi e vedi come va.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Di fatto non cambia molto, anche senza toccare niente la composizione risulta troppo lenta.
C'è sicuramente qualche impostazione legata al mio utente che consuma risorse alla grande.
Sia con il comando top che con "ps aux" non sono riuscito a vedere niente di particolare.
Adesso sto eliminando un po' di pacchetti orfani, ho tolto Cairo (che andava bene con la 2010.1), penso toglierò un po' di "orpelli" tipo emerald & Co che in verità non sto usando.
Se vi viene in mente qualcosa di diverso...
In ogni caso grazie

Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Un aggiornamento dopo varie prove.
Adesso la composizione non viene più disabilitata (pur non essendo un fulmine).
Nell'ordine ho disinstallato un paio di gestori di Compiz esterni al centro controllo di KDE e soprattutto...
utilizzo XRender al posto di Open GL.
Ogni volta che tento di tornare a Open GL ho problemi (ad esempio desktop neri, barra dei programmi che sparisce ecc...).
Ora mi conviene capire bene come funzionano e cosa sono effettivamente gli Open Gl.

Come sempre i suggerimenti sono ben accetti.

Grazie
Paolo

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Non ho ancora capito cosa stai usando per la gestione degli effetti in kde. Compiz o kwin? Kde gestisce gli effetti grafici nativamente (con kwin) senza bisogno di far girare anche compiz. Non è che li stai facendo girare entrambi sul tuo sistema? Io ho una nvidia gt 220 su un portatila asus (leggi firma) si 1 anno fa e gira tutto come una scheggia con kde 4.5.5 e effetti kwin.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di costaest
costaest
(Geek)
Offline
Geek
Iscritto: 29/04/2007
Messaggi: 53

Ciao Nicola,
mi scuso per il ritardo ma fra famiglia, suonare e pure lavorare in questi giorni non ho avuto molto tempo.

Dopo il tuo intervento ti confesso che non so più cosa sta andando sul mio pc (in effetti il senso del mio primo post era di capire come fare per capire cosa stava succedendo).

Ho i pacchetti di compiz installati ma nel MCC ho selezionato "niente effetti del desktop".

Controllando i pacchetti installati mi sono accorto che non era selezionato il seguente pacchetto: "libkwinnvidiahack4". ora lo ho installato, finito il msg provo a ricollegarmi per vedere se cambia qualcosa(sì, sto andando a caso... o quasi).

Boh gli effetti dopo le modifiche dell'altra volta ci sono (ma non è che mi interessano più di tanto), i freezing sono minori in quantità e in durata. l'unica cosa che posso dire (e questa non so se ha una qualche correlazione), che per quanto imposti tutti e 4 i miei desktop a "desktop" uno torna sempre (dopo uno o due riavvii a "vista delle cartelle").

Chiamo un buon esorcista? Basta un po' d'acqua di Lourdes?

grazie