problema con router e switch

14 risposte [Ultimo messaggio]
Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

Ciao a tutti Smile
Uso linux da 3 settimane circa, ho iniziato con una Ubuntu (che non mi ha soddisfatto) e da qualche giorno l'ho sostituita con una Mandriva.
In precedenza, con windows, "gestivo" una piccola lan fra 3 computer, io facevo da gateway e tramite questo switch la linea arrivava agli altri 2. Il problema nasce adesso, considerato che voglio passare definitivamente a linux e non posso tagliare fuori dalla rete gli altri 2 pc.
Per fare ciò ho comprato questo router. Adesso nello switch ci sono 5 cavi di rete, uno del pc con linux, uno di quello con windows, uno del router, e quelli degli altri 2 pc. Il problema è che (a parte che nel libretto delle istruzioni c'è spiegato soltanto come configurarlo su windows) questo router non mi fa connettere a internet, e quando cerco di entrare "dentro" di lui tramite il browser connettendomi ad http://192.168.1.254 mi dice che la connessione è stata rifiutata.
Comunque sono sicuro che l'apparecchio funzioni perchè prima di comprarlo ho chiesto di provarlo proprio su linux, e funzionava perfettamente.

Qualche consiglio?

grazie Smile

Ritratto di daraf
daraf
(Monster)
Offline
Monster
Iscritto: 30/07/2005
Messaggi: 241

parto dal presupposto che l'indirizzo IP sia quello giusto (eventualmente resetta tutte le eventuali configurazioni usando l'apposito tastino e controlla l'IP segnato sul manuale d'uso), quindi l'unica cosa che mi viene in mente è di provare con https://192.168.1.254.

Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

l'avevo già controllato l'ip e coincide, x sicurezza adesso l'ho resettato ma continua a non entrare neanche con https... Sad

Ritratto di daraf
daraf
(Monster)
Offline
Monster
Iscritto: 30/07/2005
Messaggi: 241

Tanto per fare un controllo: prova a collegarti direttamente al router con un solo pc, senza passare dallo switch.
Ammetto di non trovare la cosa logica, ma proviamo a chiarirci un po' le idee (bisogna per forza poter accedere, in un modo o nell'altro).

P.s. dando in konsole (da root, ovviamente) il comando 'ifconfig', che output vedi?

Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

Ho provato a collegare direttamente il router al pc (acceso e collegato alla linea telefonica Big Grin) ho aspettato un pò, ma niente, non riesco neanche ad entrarci. Allora per postare il risultato dell'ifconfig avevo pensato di connettermi a internet tramite il semplice modem ethernet che usavo prima con ubuntu, ma non parte neanche quello, avrò sicuramente qualcosa di sconfigurato. Ho provato a dare il comando pppoeconfig ma non esiste, e a questo punto non so cosa fare se non ricopiare l'output dell'ifconfig. Penso che la parte più interessante sia quella relativa all'eth0

eth0:
Link encap:Ethernet HWaddr 00:13:8F:28:76:0F
inet addr:192.168.1.133 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::213:8fff:fe28:760f:64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

cos'è che non va?

Ritratto di daraf
daraf
(Monster)
Offline
Monster
Iscritto: 30/07/2005
Messaggi: 241

non c'è niente che non va: l'indirizzo della tua scheda di rete è quello giusto (l'hai dato tu o hai usato DHCP?)
Nel caso non l'abbia dato tu, hai provato ad avviare Firefox e a navigare?
Un mio collega è impazzito perchè non sapeva come connettersi (ancora adesso mi domando cosa combinasse), mentre in realtà aveva configurato tutto per connettersi all'avvio (modem, non router nel suo caso).

Leggendo il tuo post ho visto che hai le istruzioni per configurare il router da Windows: perchè non provi? Una volta configurato il router ti basta scrivere 'dhclient eth0' per essere connesso, oppure impostare drakconnect (LAN > eth0) per farlo al boot.

Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

Quote:

daraf ha scritto:
non c'è niente che non va: l'indirizzo della tua scheda di rete è quello giusto (l'hai dato tu o hai usato DHCP?)
Nel caso non l'abbia dato tu, hai provato ad avviare Firefox e a navigare?

uso DHCP e non l'ho dato io, ma adesso ho provato a fare una cosa: ho pingato l'ip del mio router e i pacchetti vanno e vengono, quindi ho riprovato ad entrare nel router via browser e adesso entro tranquillamente, guardo lo stato della connessione finchè non risulta "SHOWTIME" (quindi dovrebbe essere connesso) ma non riesco a navigare.. stessa cosa se metto il modem, o meglio, con il router mi dice direttamente che è impossibile connettersi, mentre con il modem ci sta un pò prima di rinunciarci Smile

Quote:

daraf ha scritto:
Leggendo il tuo post ho visto che hai le istruzioni per configurare il router da Windows: perchè non provi? Una volta configurato il router ti basta scrivere 'dhclient eth0' per essere connesso, oppure impostare drakconnect (LAN > eth0) per farlo al boot.

credo di essermi spiegato male Smile non ho le istruzioni x configurare il router "da" windows, ma per configurarlo "su" windows, in ogni caso proverò, non si sa mai Laughing

grazie Kiss

Ritratto di daraf
daraf
(Monster)
Offline
Monster
Iscritto: 30/07/2005
Messaggi: 241

Una volta che il router è configurato per un pc, funziona per tutti: per lui è indifferente quale OS si connette, perchè tutti usano gli stessi protocolli standard (incredibile: anche Windows)

Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

Fermi tutti, ci sono novità.

Ho "aggiustato" la rete, adesso è DHCP in tutti i computer, infatti riesco a entrare nel router sia da linux che da windows. La spia dell'adsl si comporta come dovrebbe, anche quella della lan e quella dell'alimentazione, sfugge solo un piccolo particolare: il router non si connette a internet (SI, la spina del telefono è collegata Laughing )

Tralasciando questa storia, c'è un'altra cosa che vorrei sapere... come mai collegando un semplice modem ethernet a linux (diretto, il cavo va soltanto dal pc al modem senza passare per lo switch) non riesco a connettermi ad internet? Eppure se sono collegato in rete al mio pc con windows connesso a internet, automaticamente linux è connesso...

Ritratto di inventore1
inventore1
(Collaboratore)
Offline
Collaboratore
Iscritto: 23/09/2004
Messaggi: 2093

perchè i modem usb non si connettono da soli, non sono dei router. devi connetterli come se fosse un normale modem usb.
si fa tutto dal centro di controllo.

Notebook: Intel Core 2 Duo T7200, 2Gb ram, 160GB hd, Intel GMA 950 Big Grin
Server: Amd athlon Xp 2000+, 512Mb ram, 80*2 hd Wink
CERCATE PRIMA DI POSTARE

Ritratto di Heartbreaker
Heartbreaker
(Geek)
Offline
Geek
Iscritto: 10/08/2006
Messaggi: 82

Quote:

inventore1 ha scritto:
perchè i modem usb non si connettono da soli, non sono dei router. devi connetterli come se fosse un normale modem usb.
si fa tutto dal centro di controllo.

non intendevo dire questo Smile io ci provo a connetterlo... ho installato tutto il pacchetto ppp, con adsl-setup ho configurato tutto, adsl-connect mi da

Using interface ppp0
Connect: ppp0 <--> /dev/pts/2
PAP authentication succeeded
not replacing existing default route to eth0 [192.168.0.1]
local IP address 82.59.124.28
remote IP address 192.168.100.1
primary DNS address 85.37.17.39
secondary DNS address 151.99.125.1

ma non risulto connesso a internet, stesso discorso se faccio adsl-start (anche se mi dice che la connessione è attiva), mentre se faccio adsl-stop mi dice che non c'è niente da stoppare perchè la connessione non è attiva ._. non ci sto capendo niente...

pensi che sia meglio aprire un altro topic? Tongue