Non mi funziona più nessuna chiave USB

40 risposte [Ultimo messaggio]
Ritratto di thenthenio
thenthenio
(Geek)
Offline
Geek
Iscritto: 23/09/2006
Messaggi: 116

Inserendo una chiave USB (flash) appare la finestra che dovrebbe contenere i suoi file ma appare subito anche un errore:
Quote:

mount: wrong fs type, bad option, bad superblock on /dev/sdf1, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so

Guardando in dmesg si trova questo:
Quote:

usb 1-5: new full speed USB device using ohci_hcd and address 10
usb 1-5: configuration #1 chosen from 1 choice
scsi10 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 10
usb-storage: waiting for device to settle before scanning
Vendor: Generic Model: USB Flash Disk Rev: 2.23
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdf: 130368 512-byte hdwr sectors (67 MB)
sdf: Write Protect is off
sdf: Mode Sense: 0b 00 00 08
sdf: assuming drive cache: write through
SCSI device sdf: 130368 512-byte hdwr sectors (67 MB)
sdf: Write Protect is off
sdf: Mode Sense: 0b 00 00 08
sdf: assuming drive cache: write through
sdf: sdf1
sd 10:0:0:0: Attached scsi removable disk sdf
sd 10:0:0:0: Attached scsi generic sg5 type 0
usb-storage: device scan complete
FAT: Unrecognized mount option "flush" or missing value

Ho cercato nei man informazioni su udev e hal ed anche in Internet gli howto (ancora su udev e hal) ma non ho trovatu nulla che possa aiutrmi.
In particolare sembra che il comando mount (lanciato da udev o hal) non riconosce l'opzione "flush".
Sono quindi alla ricerca di un file di configurazione di udev o hal che contenga "flush" per toglierlo.
Non sono riuscito prò a a trovare informazioni al riguardo.
C'è qualche file di configurazione che contiene un'opzione sbagliata, od il problema è da ricercare da qualche altra parte?

Ciao, grazie.
Mauro

Ritratto di killer1987
killer1987
(Guru)
Offline
Guru
Iscritto: 02/04/2006
Messaggi: 2924

ma usi il riconoscimento automatico o monti manualmente? per montare manualmente usa

mount -t vfat /dev/sda (o sdX) /mnt/penna (o simili)

se usi hal mi sembra strano questo messaggio. hai hal e dbus in esecuzione? nei servizi si chiamano halddaemon e dbusmessage. prova anche a formattare la penna

ciao,
Marcello

Alé Mageia, C'mon Mageia!!! - Wiki Italiano Mandriva - Acer Aspire 5633, intel GMA 950, stamp HP Laserjet 1018, scanner Epson

Ritratto di freed
freed
(Guru)
Offline
Guru
Iscritto: 23/10/2006
Messaggi: 1624

adesso ho anche io lo stesso problema di mauro
appare sì la finestra d'avvio, ma poi ho lo stesso msg di errore
io ho hal all'avvio

ciao
max

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Immagino quindi che prima funzionasse, cosa hai fatto recentemente ?? aggiornamenti, altro.

Per quanto possa valere sulla mia macchina Cooker funziona tutto benissimo.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di freed
freed
(Guru)
Offline
Guru
Iscritto: 23/10/2006
Messaggi: 1624

ciao moreno
anche io sn in cooker
per quanto riguarda gli aggiornamenti recenti adesso guardo, tuttavia è da un bel pò che non montavo penne, quindi non so a quando potrebbe risalire il problema

ciao
max

Ritratto di thenthenio
thenthenio
(Geek)
Offline
Geek
Iscritto: 23/09/2006
Messaggi: 116

Ciao Moreno, grazie per il tuo interessamento.
Questa è una delle cose (come vlc in un altro topic) che magari non usi per on po' di tempo e quando la usi non va più.
Cosa è successo in mezzo? E chi lo sa, può essere successo di tutto.
Ieri ad esempio avevo aperto solo Thunderbird, Firefox e aMule, ad un certo punto faccio per far comparire la barra delle applicazioni e non c'è più (Beryl funzionava bene), abortisco X con CTRL-ALT-BACKSAPCE, mi riloggo e la barra non c'è, allora riavvio il PC e la barra non c'è, boh!!! Oggi ho cancellato l'intera direttrice .kde ed il file .kderc, mi sarò perso le impostazioni personalizzate, ma la barra delle applicazioni è tornata! Chissà cosa era successo.
Torno al problema della chiave USB.
Il problema non è di una sola chiave USB ma probabilmente di tutte, io ne ho provate 3 che prima andavano ed ora non vanno più.
Il mount manuale però funziona.

Ciao.
Mauro

Ritratto di neo571
neo571
(Monster)
Offline
Monster
Iscritto: 13/12/2005
Messaggi: 340

a me anche non funziona + il mounting delle partizioi in atomatico,

mi postate un vostro file fstab che è sotto /etc cosi lo confronto con il mio?

Come funziona il meccanismo di mounting automatico su mandriva 2007?

Case Cooler Master Cavalier - Enermax Liberty 500W - Intel Core 2 Duo e6420 - 2X1GB Corsair XMS2 675MHz - Asus P5B-E - Asus Geforce 8500GT - WD Caviar 320GB - Mandriva 2007.1 Spring X86_64

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

E' da un bel pezzo che fstab non viene più utilizzato per il montaggio delle partizioni automatiche.

Come funziona ?? bella domanda, i primi livelli sono facili kernel - udev - hal poi mi perdo.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di neo571
neo571
(Monster)
Offline
Monster
Iscritto: 13/12/2005
Messaggi: 340

Siccome mi sono praticamente rassegnato a montarmi le chiavi usb a mano in /mnt/penna,

il mio problema ora è che la cartela penna sotto mnt dove monto a chiave è scrivibile solo da root, con gli altri utenti non riesco a scriverci, come posso fare per
cambiare i peressi su quella directory e permette a tutti gli utenti la scrittura?

Case Cooler Master Cavalier - Enermax Liberty 500W - Intel Core 2 Duo e6420 - 2X1GB Corsair XMS2 675MHz - Asus P5B-E - Asus Geforce 8500GT - WD Caviar 320GB - Mandriva 2007.1 Spring X86_64

Ritratto di Pinguino
Pinguino
(Guru)
Offline
Guru
Iscritto: 14/09/2004
Messaggi: 2918

per i permessi dei dischi esterni devi vedere in /etc/fstab non devi modificare i permessi delle directory.

Prova a controllare cosa hai in fstab e facci sapere.

Proud linux user # 372467 @ http://counter.li.org
Mandriva Cooker 2008 - Kernel 2.6.17-14mdv - KDE 3.5.7 - Gnome 2.16

Ritratto di neo571
neo571
(Monster)
Offline
Monster
Iscritto: 13/12/2005
Messaggi: 340

Ora sono in ufficio, stasera lo posto, intanto puoi postarmi il tuo che vedo le differenze con il mio?

Case Cooler Master Cavalier - Enermax Liberty 500W - Intel Core 2 Duo e6420 - 2X1GB Corsair XMS2 675MHz - Asus P5B-E - Asus Geforce 8500GT - WD Caviar 320GB - Mandriva 2007.1 Spring X86_64