Mandriva 2010 e Nvidia GT320M - problemi di drivers [RISOLTO]

13 risposte [Ultimo messaggio]
Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

Ho preso da poco un nuovo portatile che monta la scheda Nvidia GT320M.
Ho installato subito la One Kde 2010.0 e il driver precaricato per la scheda era Vesa.
La risoluzione era limitata a 800x600, veramente ai limiti dell'utiizzo.
Ho completato le operazioni di aggiornamento del sistema decidendo di provare a vedere le impostazioni con i kernel più recenti. Il risultato è che il pacchetto Nvidia non si riesce a caricare!
In compenso il driver vesa si è attestato a un 1024x768 che però non è certo la risoluzione ottimale.

Quando tento la procedura di installazione automatica dei driver proprietari (basta selezionare scheda non funzionante con nv e compare l'avviso dell'esistenza di driver proprietari) vado incontro a uno strano comportamento.
Se nel sistema ho la versione 185.x (nvidia-current-kernel-desktop-latest - nvidia-current driver for latest kernel-desktop​ 185.18.36) del driver, viene installata la versione 190.x (dkms-nvidia-current 190.53) e nel log (fatto comparire con control alt f12, non so quale sia il file output) compare un errore di mismatch che mi avverte che sto tentando di installare la versione 185.x quando nel kernel è presente la 190.x.

Se tento di nuovo a mettere come driver "scheda non funzionante con nv" il sistema mi riscarica nuovamente il driver 190.x quando è gia compreso nel sistema!

Per di più, eliminando manualmente dal gestore dei pacchetti il driver 185 e precedenti e riprovando a inserire il driver per "scheda non funzionante con nv" mi riscarica la 185 quando la versione 190 è gia presente.

Se seleziono driver non funzionante con nv, faccio partire lo scaricamento del pacchetto e lo interrompo sfruttando la procedura di chiusura facilitata in caso di errori, riesco però a uscire da questo loop conservando la sola versione 190 che è quella che viene ricercata nel kernel.

Infatti al successivo riavvio, l'errore di mismatch non compare, parte l'installazione del driver, compaiono i puntini di caricamento 
fin quando non salta fuori un
bad exit status 10

Tentando con la procedura di installazione manuale del driver  vado incontro a dipendenze mancanti pur avendo installato gcc e libc, non vorrei che il mancato completamento dell'installazione del 190 da pacchetto sia dovuto a un errore di dipendenze (strano che però non sia stato risolto proprio dal manager di pacchetti)

Qualcuno ha qualche idea? se vi servono dei log, ditemi per favore dove trovarli che io non sono riuscito a trovare uno straccio di output.
Ecco le uniche info che posso dare al momento

  • kernel 2.6.31.12-desktop586-2mnb
  • repo sostituiti da file smarturpmi a causa di frequenti errori nel trovare i pacchetti
  • unica versione del driver installata per Nvidia, 190.53
  • installati gcc, gcc-c++, gcc-cpp, glibc

Tutte le soluzioni che trovo su google sono per ubuntu (pare esista un bug di compatibilità tra le nuove e le vecchie versioni del driver nvidia) e francamente questo lo trovo oltremodo snervante.

MDV 2010.1 Spring - One - KDE

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Prova a selezionare nella configurazione del server grafico dal centro di controllo mandriva, nvidiGa geforce 9600 e poi da lì dovrebbe chiederti di usare il driver proprietario installato, il 190.53 che è quello che è supportato dalla tua scheda video (io ho una GT220 che mi ha fatto tribolare non poco all'inizio, ma ora va che è una scheggia...)
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

ciao, grazie!
purtroppo quel driver non mi compare
ecco quello che vedo

MDV 2010.1 Spring - One - KDE

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Usa allora il driver per 6100 and later, funziona bene anche quello. In realtà questo passaggio serve solo per passare poi al driiver proprietario della scheda nvidia, comunque opta per il driver che ti ho indicato in questo post.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

sì  così mi installa i driver 185.18.36

peccato che abbia già installato i 190.qualcosa. e il fatto è che adesso completerò l'installazione di questi driver e al prossimo riavvio fallirà l'installazione e mi ritroverò ancora i driver vesa... Sad

MDV 2010.1 Spring - One - KDE

Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

leggo dalla tua firma che tu hai una scheda simile alla mia e che comunque usa lo stesso pacchetto driver. non hai mai avuto problemi? e i driver della scheda video li avevi installati appena installato linux?

stai usando la versione 190?

MDV 2010.1 Spring - One - KDE

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

prova a vedere se hai più di un driver installato e quindi non si carica.
Inoltre facci vedere come è configurato il tuo xorg.
ciao

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

ho reinstallato linux (per motivi di dual boot) e ne ho approfittato per installare il driver prima di fare gli aggiornamenti.
il driver proposto stavolta è stato solo il 190 (immagino che quindi i problemi siano stati dati da qualche aggiornamento magari di kernel.
Ad ora non ho ancora aggiornato i pacchetti, cosa che farò presto non appena avrò una connessione a banda decente, quindi può darsi che con gli aggiornamenti il problema potrebbe ripresentarsi.

Quindi allo stato attuale ho un sistema non aggiornato con i driver Nvidia all'ultima versione. Ma non so se  il driver proprietario è effettivamente in uso.  Il kernel alla versione 2.6.31.5-desktop586-1mnb.
Intanto non posso abilitare nessun effetto 3d, non mi carica la rassicurante schermata verde Nvidia in fase di avvio e la risoluzione è fissa a 1024x768.

I casi sono tre. O il driver in uso è rimasto un altro, o il driver proprietario non è stato installato correttamente oppure la mia scheda non è ancora supportata.
Non so come verificare nessuna di queste ipotesi nè dove mettere le mani per guardare Sad

Posto l'output di xorg.conf (se è quello che intendete)

# File generated by XFdrake (rev )
 
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************
 
Section "ServerFlags"
    Option "DontZap" "False" # disable  (server abort)
    #DontZoom # disable / (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection
 
Section "Module"
    Disable "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "glx" # 3D layer
EndSection
 
Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "Flat Panel 1024x768"
    HorizSync 31.5-48.0
    VertRefresh 56.0-65.0
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection
 
Section "Device"
    Identifier "device1"
    BoardName "NVIDIA GeForce 6100 and later"
    Driver "nvidia"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
EndSection
 
Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 16
    
    Subsection "Display"
        Depth 8
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection
 
Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection

MDV 2010.1 Spring - One - KDE

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Dal sito nvidia sembra che la tua scheda non si ancora supportata per linux. È una GT320m vero? Puoi provare con i nuovi driver arrivati in cooker, ma sinceramente non saprei dirti se funzionano. Da quello che vedo nel tuo xorg.conf sembra davvero che il tuo driver non supporti la scheda, hai provato ad usare i drivre free nv?
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

vi sono i driver  in devel
http://developer.nvidia.com/object/opengl_driver.html
dove vi sarebbe il supporto ufficiale alla tua scheda:
http://www.nvnews.net/vbulletin/showthread.php?p=2212330
Sono ancora i via di sviluppo ma sencondo me se provi anche i recenti stabili, potresti trovare buona sorte, specialmente se li installi a mano..
ciao

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di Deeder
Deeder
(Geek)
Offline
Geek
Iscritto: 04/06/2008
Messaggi: 96

Ok capito!
Farò un tentativo con i driver in sviluppo, altrimenti aspetterò la versione a pacchetti (che sarebbe l'ideale).

grazie mille a tutti!

MDV 2010.1 Spring - One - KDE