Linux disabilita scheda ethernet anche su windows

6 risposte [Ultimo messaggio]
Ritratto di randerot
randerot
(Geek)
Offline
Geek
Iscritto: 05/05/2007
Messaggi: 111

Buonasera, ho urgente bisogno di aiuto. Un mio amico mi ha dato il suo nuovo netbook acer one d250 per mettergli linux. Ovviamente ho scelto mandriva 2009.1, ma per la prima volta ho avuto problemi con la scheda ethernet. E' una

Attansic Technology Corp.
ID della marca: ‎0x1969
ID del dispositivo: ‎0x1062
Identificativo secondario della marca: ‎0x1025

In pratica ho messo su chiavetta usb la iso di mandriva-one-kde e ho installato da lì. tutto è filato liscio, finchè riavviando mi sono accorto che mancava la scheda di rete, mentre il wireless funziona perfettamente.

Vado su windows e anche lì è sparita la scheda di rete. Andando ad intuito sono andato sul bios per vedere le impostazioni, ma non si riesce a settare altro che l'ordine di boot e la password. Allora vado in modalità provvisoria di windows e finalmente becco la ethernet. Riavvio e vado su mandriva. finalmente trova la scheda di rete, ma quando provo a configurarla da mmc mi si apre una notifica di kde dicendo che è stato disabilitato irq 18. Il wizard della scheda di rete mi dice che non è stato possibile attivare la connessione, e riavviando su windows è sparita di nuovo la scheda. Riandando sul bios riappare, come se linux disabilitasse la scheda e solo dal bios si riesca a riattivarla.

ecco la parte interessante dell'output di dmesg:

<br />Netfilter messages via NETLINK v0.30.                                                               <br />nf_conntrack version 0.5.0 (16240 buckets, 64960 max)                                               <br />CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use                                <br />nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or                          <br />sysctl net.netfilter.nf_conntrack_acct=1 to enable it.                                              <br />ctnetlink v0.93: registering with nfnetlink.                                                        <br />ClusterIP Version 0.8 loaded successfully                                                           <br />xt_time: kernel timezone is +0200                                                                   <br />netfilter PSD loaded - (c) astaro AG                                                                <br />IFWLOG: register target                                                                             <br />NET: Registered protocol family 10                                                                  <br />lo: Disabled Privacy Extensions                                                                     <br />Bluetooth: Core ver 2.15                                                                            <br />NET: Registered protocol family 31                                                                  <br />Bluetooth: HCI device and connection manager initialized                                            <br />Bluetooth: HCI socket layer initialized                                                             <br />Bluetooth: L2CAP ver 2.13                                                                           <br />Bluetooth: L2CAP socket layer initialized                                                           <br />Bluetooth: SCO (Voice Link) ver 0.6                                                                 <br />Bluetooth: SCO socket layer initialized                                                             <br />Bluetooth: RFCOMM socket layer initialized                                                          <br />Bluetooth: RFCOMM TTY layer initialized                                                             <br />Bluetooth: RFCOMM ver 1.11                                                                          <br />Bluetooth: BNEP (Ethernet Emulation) ver 1.3                                                        <br />Bluetooth: BNEP filters: protocol multicast                                                         <br />Bridge firewalling registered                                                                       <br />atl1c 0000:03:00.0: irq 28 for MSI/MSI-X                                                            <br />ADDRCONF(NETDEV_UP): eth1: link is not ready                                                        <br />[drm] Initialized drm 1.1.0 20060810                                                                <br />pci 0000:00:02.0: PCI INT A -&gt; GSI 16 (level, low) -&gt; IRQ 16                                        <br />pci 0000:00:02.0: setting latency timer to 64                                                       <br />[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0                                   <br />atl1c 0000:03:00.0: atl1c: eth1 NIC Link is Up&lt;100 Mbps Full Duplex&gt;                                <br />ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready                                                   <br />NET: Registered protocol family 17                                                                  <br />eth1: no IPv6 routers present                                                                       <br />CPU0 attaching NULL sched-domain.                                                                   <br />CPU1 attaching NULL sched-domain.                                                                   <br />CPU0 attaching sched-domain:                                                                        <br /> domain 0: span 0-1 level SIBLING                                                                   <br />  groups: 0 1                                                                                       <br />CPU1 attaching sched-domain:                                                                        <br /> domain 0: span 0-1 level SIBLING                                                                   <br />  groups: 1 0                                                                                       <br />zcip uses obsolete (PF_INET,SOCK_PACKET)                                                            <br />device eth1 entered promiscuous mode                                                                <br />device eth1 left promiscuous mode                                                                   <br />ath0: no IPv6 routers present                                                                       <br />irq 18: nobody cared (try booting with the &quot;irqpoll&quot; option)                                        <br />Pid: 5773, comm: rm Tainted: P           2.6.30-desktop-2mnb #1                                     <br />Call Trace:                                                                                         <br /> [&lt;c0423627&gt;] ? printk+0x23/0x3c                                                                    <br /> [&lt;c0188243&gt;] __report_bad_irq+0x33/0xb0                                                            <br /> [&lt;c018844e&gt;] note_interrupt+0x18e/0x1d0                                                            <br /> [&lt;c0188b3b&gt;] handle_fasteoi_irq+0xab/0xe0                                                          <br /> [&lt;c0106378&gt;] handle_irq+0x28/0x50<br /> [&lt;c0105a63&gt;] do_IRQ+0x53/0xc0<br /> [&lt;c042934a&gt;] ? do_page_fault+0x18a/0x300<br /> [&lt;c0104650&gt;] common_interrupt+0x30/0x38<br />handlers:<br />[&lt;f8450100&gt;] (usb_hcd_irq+0x0/0xa0 [usbcore])<br />Disabling IRQ #18<br />atl1c 0000:03:00.0: irq 28 for MSI/MSI-X<br />ADDRCONF(NETDEV_UP): eth1: link is not ready<br />atl1c 0000:03:00.0: irq 28 for MSI/MSI-X<br />ADDRCONF(NETDEV_UP): eth1: link is not ready<br />ath0: no IPv6 routers present<br />

Qualcuno ha qualche idea? perchè disabilita irq 18? cosa lo disabilita?

Ho provato a installare sia l'ultimo kernel mib che l'ultimo kernel di cooker perchè pensavo che con il 2.6.30 avessero risolto qualcosa, ma invece non cambia niente.

______________________________________________________________________________________________________________________________________________

Notebook Asus M60J CPU: i7-720QM Memory: 4Gb Scheda Video: Nvidia GT 240M Display: 16.0" HD/led

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Devi avviare il kernel con l'opzione irqpoll come detto nel log. Apri la konsole e da root digita kwrite /boot/grub/menu.lst
Nella voce dove "title linux" (nella riga sottostante) incolla la parola irqpoll

Salva e riavvia il PC. Così dovrebbe andare. Puo darsi che il kernel non riesca a rilevare correttamente quell'interrupt (il 18 per la precisione) e che quindi lo disabiliti.

Se non funziona puoi provare ad aggiungere allo stesso file anche la parola acpi=off. Ma a questo punto non funzionerà lo scaling della CPU e qualche altra cosuccia.

_/\/\/\Bemipefe/\/\/\_

Ritratto di randerot
randerot
(Geek)
Offline
Geek
Iscritto: 05/05/2007
Messaggi: 111

grazie mille per l'aiuto!!!

alla fine per pura fortuna sono riuscito a trovare una guida su google

http://forum.mandriva.com/viewtopic.php?t=111778

Però funziona solo col kernel 2.6.29.3-desktop-1mnb, con quelli mib non si riesce a compilare il modulo.

Peccato, vorrà dire che gli lascio questo kernel.

______________________________________________________________________________________________________________________________________________

Notebook Asus M60J CPU: i7-720QM Memory: 4Gb Scheda Video: Nvidia GT 240M Display: 16.0" HD/led

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Ma scusa se non gli funziona la scheda di rete che cosa gli puo dare il kenrel-2.6.30 in piu. Piu nuovo non è quasi MAI sinonimo di migliore.

Ci sono molti moduli e driver che si basano sul 2.6.27 e non compilano ancora con i superiori. Io stesso uso ancora il 2.6.27 che mi va benissimo lo stesso. Avere un kernel piu nuovo a senso solo se magari quelli vecchio non hanno un determinato modulo o driver integrato oppure non riescono a partire sulla macchina.

Quindi il mio consiglio spassionato è mettigli il 2.6.27 ....almeno ha la macchina completamente funzionante....e non fai fare brutta figura al pinguino Laughing

_/\/\/\Bemipefe/\/\/\_

Ritratto di alex23
alex23
(Guru)
Offline
Guru
Iscritto: 24/09/2008
Messaggi: 514

Il kernel 2.6.30 del MIB ha creato problemi anche a me tante vero che alla fine l'ho levato.

A me comunque è successo l'esatto opposto, la scheda di rete integrata non funzionava in windows e mandriva 2005 tant'è che l'avevo disattivata da BIOS e inserito una scheda di rete PCI. Mandriva 2008, e 2009 invece hanno rilevato entrambe le schede e hanno modificato anche il BIOS e ora funzionano entrambe anche in Linux, adesso una la uso come LAN per il router per la connessione a INTERNET e l'altra come LAN per connettere il PC e il portatile!

Parlando d'altro
@bemifepe
puoi dare un'occhiata a questo post

http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=18393&start=0#forumpost147107

per vedere se è anche questo un problema di IRQ e di schede?

Ritratto di panda84
panda84
(Monster)
Offline
Monster
Iscritto: 18/11/2007
Messaggi: 319

La Attansic L2 la conosco anch'io perché è una brutta bestia. Addirittura alle volte la soluzione al problema era scollegare temporaneamente l'alimentazione (l'ho letto su un forum relativo all'eeepc) e batteria...
Ho letto sul log del kernel di Fedora che dovrebbe esistere un fix per gli ultimi kernel...

Ritratto di alex23
alex23
(Guru)
Offline
Guru
Iscritto: 24/09/2008
Messaggi: 514

purtroppo Mandriva con i kernel è sempre un passo avanti agli altri, non so se i fix di Fedora possano funzionare.