Cookeriani Attenti a GRUB

5 risposte [Ultimo messaggio]
Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

A quanto pare la versione Grafica di Grub presenta nuovi problemi (probabilmente legati alle impostazioni dato che la versione è del 12/01) ben più fastidiosi delle scritte in giapponese che ho segnalato questa mattina nella mia rubrichetta http://www.mandrakeitalia.org/modules/news02/article.php?storyid=2234 .

Il nuovo problema che ho riscontrato ( o meglio ha riscontrato mia moglie che a momenti mi lincia) è che finestre non parte più.
La voce di munu.lst non viene minimamente alterata però quando la si seleziona al boot parte lo stesso Linux (presumo parta la versione linux-nofb).

Fortunatamente esiste una soluzione al problema.

Quando si presenta la maschera di boot seguire la seguente procedura

1) Premere Esc

2) Appare una finestrella in giapponese ma fortunatamente con il bottone OK, cliccare quindio su OK

3) A questo punto Grub passa in modalità testuale

4) Selezionare finestre e premere Invio

A questo punto finestre parte regolarmente

Ho provveduto a segnalare entrambi i problemi

qui
http://lists.mandriva.com/cooker/2009-02/msg00329.php
e qui
http://lists.mandriva.com/cooker/2009-02/msg00326.php

Dato che grub non può essere ritenuto colpevole (a meno che non debba essere ricompilato) il problema risiede sicuramente in qualche altro pacchetto arrivato in questi giorni.
Purtroppo non sono riuscito ad isolarlo per cui non so assolutamente divi chi sia il colpevole.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Sono riuscito ad individuare la causa del problema sull'ultima macchina che mi rimaneva da aggiornare.

Il pacchetto incriminato e che non va ASSOLUTAMENTE aggiornato è banalmente, mandriva-gfxboot-theme.

Aprirò immediatamente un Bug Report per segnalare il problema, se qualcuno avesse già aggiornato me lo dica che metterò a disposizione la vecchia versione del pacchetto sia per i586 che per X86_64.

[postedit]
OK Bug Report aperto
https://qa.mandriva.com/show_bug.cgi?id=47702
[/postedit]

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di randerot
randerot
(Geek)
Offline
Geek
Iscritto: 05/05/2007
Messaggi: 111

io ho aggiornato! che nabbo, se prima di aggiornare guardavo un attimo questo post non aggiornavo!

______________________________________________________________________________________________________________________________________________

Notebook Asus M60J CPU: i7-720QM Memory: 4Gb Scheda Video: Nvidia GT 240M Display: 16.0" HD/led

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Ecco qui i link da cui scaricare i vecchi pacchetti funzionanti

versione i586
http://www.megaupload.com/it/?d=JLRJNW6I

versione X86_64
http://www.megaupload.com/it/?d=NE37C8IP

1) Scarica il file in una cartella vuota
2) rpm -Uvh --oldpackage *.rpm

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di randerot
randerot
(Geek)
Offline
Geek
Iscritto: 05/05/2007
Messaggi: 111

grazie mille!!!

______________________________________________________________________________________________________________________________________________

Notebook Asus M60J CPU: i7-720QM Memory: 4Gb Scheda Video: Nvidia GT 240M Display: 16.0" HD/led

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

OK il pacchetto mandriva-gfxboot-theme-4.1.19-3mdv2009.1.i586.rpm risolve tutti i problemi,

Evitate come la peste mandriva-gfxboot-theme-4.1.19-2mdv2009.1.i586.rpm che invece vi ammazza la macchina.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.