wireless_adattatore_usb_sitecom

22 risposte [Ultimo messaggio]
Ritratto di linquei
linquei
(Geek)
Offline
Geek
Iscritto: 06/07/2007
Messaggi: 70

Quote:

mailga ha scritto:
Non si aggancia al tuo essid, posta il risultato di:
# iwlist wlan0 scanning
e
# cat /etc/sysconfig/network-scripts/ifcfg-wlan0
e
$ lspci

Sempre se vuoi, naturalmente.

Ciao e grazie per il prosieguo! Alla fine prevale sempre il buon senso ciò che non deve mancare mai per noi utenti di Linux. Wink
L'output richiesto è il seguente:

[root@localhost ~]# iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:1C:A2:06:0F:CB
ESSID:"Alice-04823822"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:56/100 Signal level:-60 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:0C:F6:4D:17:4E
ESSID:"Sitecom"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:60/100 Signal level:-57 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-wlan0
DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=yes
METRIC=35
MII_NOT_SUPPORTED=no
USERCTL=no
RESOLV_MODS=no
WIRELESS_MODE=Managed
WIRELESS_ESSID=Sitecom
WIRELESS_ENC_KEY=-----------
WIRELESS_ENC_MODE=restricted
WIRELESS_WPA_DRIVER=wext
WIRELESS_WPA_REASSOCIATE=no
IPV6INIT=no
IPV6TO4INIT=no
DHCP_CLIENT=dhclient
NEEDHOSTNAME=no
PEERDNS=yes
PEERYP=yes
PEERNTPD=no
[root@localhost ~]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 10)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:0c.0 Communication controller: Conexant Systems, Inc. HSF 56k HSFi Modem (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 4000] (rev a4)

Ritratto di mailga
mailga
(Geek)
Offline
Geek
Iscritto: 29/05/2009
Messaggi: 63

Da quel che vedo non dovresti avere grossi problemi:

1) usi ndiswrapper, vero? Hai quindi installato i driver win. L'unico problema (a me è capitato) è che potrebbe lavorare solo in DHCP e su rete aperta. Se su Suse sei riuscito a configurarlo questo problema non s pone;

2) che tipo di rete hai? Lavora in DHCP o usi degli ip fissi? nel primo caso va bene così, nel secondo devi impostarli con iwconfig (ma lo vediamo dopo, semmai).

3) che tipo di criptazione usi? Wpa o wep, o libera?

4) le prove le fai con la eth0 attiva? Prova a buttarla giù ed attivare la wlan;

5) Non ho mandriva sottomano, ma da drakeconf dovresti provare a configurare la tua wifi tramite GUI, altrimenti lo faremo da linea di comando.

Facce sapè.

Ritratto di linquei
linquei
(Geek)
Offline
Geek
Iscritto: 06/07/2007
Messaggi: 70

Quote:

mailga ha scritto:
Da quel che vedo non dovresti avere grossi problemi:

1) usi ndiswrapper, vero? Hai quindi installato i driver win. L'unico problema (a me è capitato) è che potrebbe lavorare solo in DHCP e su rete aperta. Se su Suse sei riuscito a configurarlo questo problema non s pone;

2) che tipo di rete hai? Lavora in DHCP o usi degli ip fissi? nel primo caso va bene così, nel secondo devi impostarli con iwconfig (ma lo vediamo dopo, semmai).

3) che tipo di criptazione usi? Wpa o wep, o libera?

4) le prove le fai con la eth0 attiva? Prova a buttarla giù ed attivare la wlan;

5) Non ho mandriva sottomano, ma da drakeconf dovresti provare a configurare la tua wifi tramite GUI, altrimenti lo faremo da linea di comando.

Facce sapè.

Ciao! Ora sto postando dal mio notebook con connessione wireless, ma utilizzando la scheda interna wireless.
Il pennino non l'ho mai utilizzato su questo. Stavo cercando di attivarlo su un pc fisso che non ha scheda wireless. Ho certo installato i driver ndiswrapper ed in più, come da guida trovata su OpenSuse, ho installato anche quelli relativi al pennino da shell. Lavoro in DHCP e uso criptazione wep. Gli aggiornamenti sul pc in questione li ho fatti tramite una connessione modem MT512HS Onda usb che non ho avuto problemi ad installarlo.è
Ora se sul mio notebbook uso la stessa rete in DHCP e tutto va bene, perchè con il pc fisso nonostante il pennino rileva la rete wireless non avviene la connessione?
Se è possibile ti sarei grato se mi indicassi passo passo i settaggi o modifiche da apportare. Grazie! Big Grin

Ritratto di mailga
mailga
(Geek)
Offline
Geek
Iscritto: 29/05/2009
Messaggi: 63

Quote:

linquei ha scritto:
Stavo cercando di attivarlo su un pc fisso che non ha scheda wireless. Ho certo installato i driver ndiswrapper ed in più, come da guida trovata su OpenSuse, ho installato anche quelli relativi al pennino da shell. Lavoro in DHCP e uso criptazione wep.

Proviamo, premesso che non ti ho chiesto di verificare il caricamento del modulo ndiswrapper e di tutto quel che riguarda la wifi (questi ultimi dovrebbero essere a posto, visto che sei in wifi in questo momento):

1) digita da shell:
$ chkconfig --list | grep -i network
Dovresti trovarti due servizi (ti mostro i miei in fedora):
Quote:

$ chkconfig --list | grep -i network
NetworkManager 0:off 1:off 2:on 3:on 4:on 5:on 6:off
network 0:off 1:off 2:off 3:off 4:off 5:off 6:off

Se li trovi così, non serve che tu fermi anche network, se invece sono attivi tutti e due stoppali:
# service network stop<br /># service NetworkManager stop
In ogni caso anche adesso dovresti trovare le tue reti facendo:
# iwlist wlan0 scanning
Dopodichè, per sicurezza, buttiamo giù la wlan:
# ifconfig wlan0 down
Adesso vediamo di tirarla su come si deve:
# iwconfig wlan0 essid &quot;Sitecom&quot;
# iwconfig wlan0 mode managed
# iwconfig wlan0 ap 00:0C:F6:4D:17:4E
Hai il DHCP attivato sul router per cui mi fermerei qui.
Incrocia le dita:
# ifconfig wlan0 up
e posta il risultato di:
$ iwconfig
e:
$ ping -c 5 www.google.it

Ritratto di mailga
mailga
(Geek)
Offline
Geek
Iscritto: 29/05/2009
Messaggi: 63

Edit: mi sono dimenticato di un "piccolo" particolare... la chiave WEP.
Digita una di queste righe (open o restricted in dipendenza delle tue impostazioni) subito dopo # iwconfig wlan0 essid "Sitecom" :
# iwconfig eth1 key ############# open<br />oppure<br /># iwconfig eth1 key ############# restricted

Ritratto di mailga
mailga
(Geek)
Offline
Geek
Iscritto: 29/05/2009
Messaggi: 63

Quote:

mailga ha scritto:
Edit: mi sono dimenticato di un "piccolo" particolare... la chiave WEP.
Digita una di queste righe (open o restricted in dipendenza delle tue impostazioni) subito dopo # iwconfig wlan0 essid "Sitecom" :
# iwconfig eth1 key ############# open<br />oppure<br /># iwconfig eth1 key ############# restricted

Ri-edit: (evidentemente la senilità imporrebe di andare a dormine dopo una certa ora), ho sbagliato. Anzichè eth1 devi usare wlan0, ovviamente.

Ritratto di linquei
linquei
(Geek)
Offline
Geek
Iscritto: 06/07/2007
Messaggi: 70

Ciao! Grazie per il tuo aiuto. Mi sa tanto che debbo rinunciarci!
L'output è il seguente:

[root@localhost elvy]# chkconfig --list | grep -i network
network 0:off 1:off 2:on 3:on 4:on 5:on 6:off 7:off
network-auth 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7:off
network-up 0:off 1:off 2:on 3:on 4:on 5:on 6:off 7:off
[root@localhost elvy]# service network stop
Shutting down interface eth0: [ OK ]
Shutting down interface wlan0: [ OK ]
Shutting down loopback interface: [ OK ]
[root@localhost elvy]# service NetworkManager stop
Cannot find NetworkManager service
Usage: service -[Rfshv] SERVICE ARGUMENTS
-f|--full-restart: Do a fullrestart of the service.
-R|--full-restart-all: Do a fullrestart of all running services.
-s|--status-all: Print a status of all services.
-d|--debug: Launch with debug.
-h|--help: This help.
[root@localhost elvy]# iwlist wlan0 scanning
wlan0 Scan completed :
Cell 01 - Address: 00:1C:A2:06:0F:CB
ESSID:"Alice-04823822"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.412 GHz (Channel 1)
Quality:54/100 Signal level:-61 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 02 - Address: 00:0C:F6:4D:17:4E
ESSID:"Sitecom"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:60/100 Signal level:-57 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

[root@localhost elvy]# ifconfig wlan0 down
[root@localhost elvy]# iwconfig wlan0 essid "Sitecom"
[root@localhost elvy]# iwconfig wlan0 mode managed
[root@localhost elvy]# iwconfig wlan0 ap 00:0C:F6:4D:17:4E
[root@localhost elvy]# ifconfig wlan0 up
[root@localhost elvy]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:off/any Nickname:"localhost"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[root@localhost elvy]# ping -c 5 www.google.it
ping: unknown host www.google.it
[root@localhost elvy]# iwconfig wlan0 key ########## restricted
[root@localhost elvy]#

Ancora non si connette!

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

La rete wireless (l'unica) ce vede la tua scheda è
<br />ESSID:&quot;Alice-04823822&quot; <br />

Quindi presumo tu abbia un router alice W-Gate. Sul forum sono state postate delle discussioni in merito a tale apparecchio e alcuni avevo problemi a connetersi.

http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=17861&forum=4&post_id=141068#forumpost141068

Poi non ho capito perchè imposti l'ESSID come "Sitecom" se l'Access Point è "Alice-04823822".

Prova a dare semplicemente:

<br />ifdown eth0<br />ifdown wlan0<br />iwconfig wlan0 ESSID &quot;Alice-04823822&quot;<br />ifup wlan0<br />

_/\/\/\Bemipefe/\/\/\_

Ritratto di linquei
linquei
(Geek)
Offline
Geek
Iscritto: 06/07/2007
Messaggi: 70

Quote:

Bemipefe ha scritto:
La rete wireless (l'unica) ce vede la tua scheda è
<br />ESSID:&quot;Alice-04823822&quot; <br />

Quindi presumo tu abbia un router alice W-Gate. Sul forum sono state postate delle discussioni in merito a tale apparecchio e alcuni avevo problemi a connetersi.

http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=17861&forum=4&post_id=141068#forumpost141068

Poi non ho capito perchè imposti l'ESSID come "Sitecom" se l'Access Point è "Alice-04823822".

Prova a dare semplicemente:

<br />ifdown eth0<br />ifdown wlan0<br />iwconfig wlan0 ESSID &quot;Alice-04823822&quot;<br />ifup wlan0<br />

Ciao! Quell'ESSID "Alice-04823822 è relativo ad un modem W-Alice che io non uso, sicuramente sarà nei dintorni dove dimoro. Infatti utilizzo un modem W-Sitecom con una alice flat.

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

In ogni caso il tuo router Sitecom non compare nella lista degli access point che appare con :

iwlist wlan0 scan

Sei sicuro di essere nel raggio di trasmissione ? Non puoi cercare di avviciarti ? Finchè non ti compare nella lista non ti potrai connettere. Escludo un malfunzionamento della pennetta perchè l'altro router lo vede.

PS: Se usi ndiswrapper il raggio di azione (non so per quale motivo) puo ridursi. Io prima lo usavo per la mia Broadcom bcm4319 ora uso il driver del kernel e ho notato che prendo un po di piu di prima.

_/\/\/\Bemipefe/\/\/\_