Scheda audo integrata non va

12 risposte [Ultimo messaggio]
Ritratto di DonGennaro
DonGennaro
(Monster)
Offline
Monster
Iscritto: 29/03/2007
Messaggi: 349

La scheda audio integrata del mio portatile HP 6735s non funziona. O meglio ha funzionato la prima volta che ho avviato mandriva ha funzionato..ora invece è muta :'(
Infatti se apro amrok 2 mi dice "problema nella tua scheda audio" poi va bhe non dice più niente.
Ho provato ad impostare alsa e a disibalitare pulse audio ma il risultato non è cambiato.
Purtroppo il produttore del mio portatile non da specifiche della scheda audio infatti da solo "High Definition Audio, altoparlanti stereo, uscita cuffia/linea stereo, ingresso microfono stereo, microfono integrato"

Mandriva me la rileva come se fosse una scheda intel..

Quanti problemi!!
Aiutatemi!Please

Ps: Mandriva 2009.0, KDE 4.1

Ricorda per sempre il cinque novembre.
E la congiura contro lo stato.
Ricorda e sta attento che quel tradimento...
MAI E POI MAI SIA DIMENTICATO.

Ritratto di freed
freed
(Guru)
Offline
Guru
Iscritto: 23/10/2006
Messaggi: 1624

bisognerebbe capire se non va più solo con mandriva o anche con altri sistemi operativi

se hai windows vedi se lì funziona, senò prova a vedere con altre live linux

ciao
max

Ritratto di DonGennaro
DonGennaro
(Monster)
Offline
Monster
Iscritto: 29/03/2007
Messaggi: 349

Con Windows va

Ricorda per sempre il cinque novembre.
E la congiura contro lo stato.
Ricorda e sta attento che quel tradimento...
MAI E POI MAI SIA DIMENTICATO.

Ritratto di maurelio79
maurelio79
(Guru)
Offline
Guru
Iscritto: 19/05/2006
Messaggi: 2074

Posta l'output dei comandi

lspci e lshw

Eventualmente per ridurre l'output del comando lshw potresti combinarlo con grep, quindi

lshw | grep Audio

Debian Squeeze+Mandriva2009 on Asus X59SLseries
http://www.mylinuxexperience.org/

Ritratto di pillotz
pillotz
(Geek)
Offline
Geek
Iscritto: 03/06/2007
Messaggi: 84

Quote:

DonGennaro ha scritto:
Con Windows va

WINZOZZ? :-o :-o Laughing Laughing

MANDRIVA PER SEMPRE
-------------------------------------------------------------------------------------

mai mettersi a discutere con uno stupido, prima ti porta al suo livello e poi ti batte per l'esperienza.

Ritratto di DonGennaro
DonGennaro
(Monster)
Offline
Monster
Iscritto: 29/03/2007
Messaggi: 349

lspci

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4357 (rev 10)
06:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 0

[root@localhost vito]# lshw | grep Audio
description: Audio devic

Ricorda per sempre il cinque novembre.
E la congiura contro lo stato.
Ricorda e sta attento che quel tradimento...
MAI E POI MAI SIA DIMENTICATO.

Ritratto di maurelio79
maurelio79
(Guru)
Offline
Guru
Iscritto: 19/05/2006
Messaggi: 2074

Perfetto!!
Hai un Azalia audio controller!!

Quote:

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

Io su Debian ho lo stesso controller audio, ma non penso cambi molto:

come utente root apri questo file

/etc/modprobe.d/sound

e aggiungi questo model=lenovo

il mio dopo la modifica è così:

Quote:

asus-debian:/home/maurelio# cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0 model=lenovo
asus-debian:/home/maurelio#

Dopo che hai fatto la modifica riavvia (o riavvia il server audio)
Prova e fammi sapere.

Ciao.

Debian Squeeze+Mandriva2009 on Asus X59SLseries
http://www.mylinuxexperience.org/

Ritratto di DonGennaro
DonGennaro
(Monster)
Offline
Monster
Iscritto: 29/03/2007
Messaggi: 349

Mi dispiace ho provato a fare come dici ma non ho avuto nessun risultato.. non è che devo impostare altro?
Comunque volevo dirti una cosa, appena installato mandriva l'audio si sentiva, (stavo con un kernel 2.6.27.14 rc 8 qualcosa del genere).
Dopo l'aggironamento del kernel l'audio è scomparso!
ora sto con il kernel 2.6.27.14, ma anche se avvio mandriva con il vecchio kernel l'audio non si sente più..
volevo darti anche altre info..

se io vado in Configura il computer --> hardware --> elenca e configura l'hardware --> scheda audio ecco cosa ho :

Identificazione
Marca: ‎ATI Technologies Inc

Descrizione: ‎SBx00 Azalia (Intel HDA)

Classe dei supporti: ‎Audio device

Connessione
Bus: ‎PCI

Dominio PCI: ‎0

Bus PCI n°: ‎0

Dispositivo PCI n°: ‎20

Funzione PCI n°: ‎2

ID della marca: ‎0x1002

ID del dispositivo: ‎0x4383

Identificativo secondario della marca: ‎0x103c

Identificativo secondario del dispositivo: ‎0x3613

Driver
Modulo: ‎snd_hda_intel

Driver alternativi: ‎sconosciuto

Intanto è giusto il driver primario?

Se vado ad "Impostare" il driver in uso tutti i campi appaiono vuoti.

Se invece lancio il tool di configurazione :

Qui è possibile scegliere un driver alternativo (OSS o ALSA) per la scheda audio (ATI Technologies Inc|SBx00 Azalia (Intel HDA)).

La scheda ora utilizza il driver ALSA "snd_hda_intel" (il driver predefinito era "snd_hda_intel")

Con tutti i parametri spuntati e non mi fa fare nient'altro

Che faccio? :'((((((((((((((((((((((((((((((((((

Ricorda per sempre il cinque novembre.
E la congiura contro lo stato.
Ricorda e sta attento che quel tradimento...
MAI E POI MAI SIA DIMENTICATO.

Ritratto di maurelio79
maurelio79
(Guru)
Offline
Guru
Iscritto: 19/05/2006
Messaggi: 2074

Ciao, ora sono a lavoro, quindi non posso fare delle verifiche, ma quando torno a casa (00.30 Smile ) do un occhio alla mia configurazione, visto che ho su Mandriva 2009, aggiornata, con controller audio Azalia.

Pulseaudio come è messo? Io l'ho disattivato, perchè sentivo bassissimo e male.

Debian Squeeze+Mandriva2009 on Asus X59SLseries
http://www.mylinuxexperience.org/

Ritratto di DonGennaro
DonGennaro
(Monster)
Offline
Monster
Iscritto: 29/03/2007
Messaggi: 349

Ok fammi sapere! Pulse audio è attivato, ma anche se lo disattivo non succede niente! fammi sapere per favore..

Ricorda per sempre il cinque novembre.
E la congiura contro lo stato.
Ricorda e sta attento che quel tradimento...
MAI E POI MAI SIA DIMENTICATO.

Ritratto di maurelio79
maurelio79
(Guru)
Offline
Guru
Iscritto: 19/05/2006
Messaggi: 2074

QUesto è l'output dei comandi lspci e lshw dati sulla macchina:

Quote:

[root@localhost maurelio]# lspci | grep Audio
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
[root@localhost maurelio]# lshw | grep Audio
description: Audio device
product: Azalia Audio Controller
[root@localhost maurelio]#

Questo è ciò che leggo da Configura Hardware:

Quote:

Identificazione
Marca: ‎Silicon Integrated Systems [SiS]

Descrizione: ‎Azalia Audio Controller

Classe dei supporti: ‎Audio device

Connessione
Bus: ‎PCI

Dominio PCI: ‎0

Bus PCI n°: ‎0

Dispositivo PCI n°: ‎15

Funzione PCI n°: ‎0

ID della marca: ‎0x1039

ID del dispositivo: ‎0x7502

Identificativo secondario della marca: ‎0x1043

Identificativo secondario del dispositivo: ‎0x1783

Driver
Modulo: ‎snd_hda_intel

Driver alternativi: ‎sconosciuto

E il file che ti avevo detto di modificare, ho appena scoperto che in Mandriva non esiste.

Ho disattivato Pulse e sento benissimo.

Tuttavia le nostre schede sono diverse o almeno vengono viste diversmente.....

Debian Squeeze+Mandriva2009 on Asus X59SLseries
http://www.mylinuxexperience.org/