Problemi scheda video Intell 855GM [RISOLTO]

15 risposte [Ultimo messaggio]
Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

Ciao volevo chiedervi il vostro aiuto per riuscir a configurare il mio pc dopo l'installazione di Mandriva alla nuova versione 2010.(prima con la ver 2009.1 funzionava tutto).
Premetto già che fin da subito ho avuto, problemi infatti il pc partiva sempre con una schermata nera, L'unico modo per arrivare in modo grafico, alla scelta utente, era quello di farlo partire in modalità "sicura" impostata al boot con tasto f3.Visto il problema ho provato a smanettare dietro la scheda grafica fino ad arrivare al danneggiamento del file xorg.conf ,ora nn ho più la possibiltà di configurare la scheda video perchè mi compare sempre la scritta " il file xorg è danneggiato".
Ho provato allora a copiare e sostituire con la copia di backup del file xorg per ripsristinare il tutto,ma purtroppo resta sempre dannneggiato.
C''è qulcuno che ha qualche idea e mi sa aiutare per risolvere il problema??
Il pc in questione si tratta di un acer travelmate 290 con intel centrino e scheda video Intel 855gm
Graize anticipamente

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Prova ad inviare il tuo file xorg.conf in modo da vedere quali sono i danni che hai combinato (fare sempre i backup prima di pasticciare!!!)

Dai un occhiata anche a questo thread http://www.mandrakeitalia.org/forum/driver/intel-gma500

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

si può anche a provare a rigenerarlo dando da console il comando drakx11 e ti parte la configuarzione guidata.
ciao

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

Grazie mille per le tempestive risposte però ho un ulteriore problema.Infatti non riesco ad aprire il xorg si deve utilizzare kwrite da consolle loggato come root giusto??Perchè se fosse così nn riesco proprio ad aprirlo mi va in crash ogni volta e non me lo apre.Per il secondo consiglio datomi per utilizzare il comando drakx11 non mi è possibile farlo perchè mi dice sempre che il file xorg danneggiato.Che posso fare allora?
Scusate ma non sono molto pratico con linux
Grazie ancora

Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

Allora rieccomi,avevo postato anche 2 gg fa ma è sparito il mio vecchio post cmq nn importa Smile...Eccomi dopo svariati tentativi ho deciso di formattare e reinstallare mandriva visto il casino creato...Ora sono al punto di prima con schermo nero all'avvio però con una copia già fatta del file xorg stavolta ;)Che fare ora??Vi posto quello che mi risulta dopo averlo editato
GRaziee
# File generated by XFdrake (rev )

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    Option "DontZap" "False" # disable (server abort)
    #DontZoom # disable / (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "Flat Panel 1024x768"
    HorizSync 28.8-90
    VertRefresh 60
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "Intel Corporation"
    BoardName "Intel 810 and later"
    Driver "intel"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection

Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

Scusate se continuo a postare,però penso possa diventare utile per chi come me potrebbe avere il mio stesso problema.Vi aggiorno su quanto fatto,infatti ho visto che facendo partire il sistema in safemode  utilizzando "xorg vesa" il sistema si avvia e funziona alla perfezione però al riavvio si ripristina tutto al punto di prima e si ripianta di nuovo.Qualcuno ha un consiglio da darmi o mi può aiutare?
Graziee

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

??
Ma la Mandriva l'hai installata o stai usando una live?? in quest'ultimo caso è normale che dimentichi tutto ogni volta.

Se l'unico modo per far andare la tua scheda è in modalità vesa devi lanciare mcc e da li selezionare il driver vesa in modo da rendere permanente la scelta o in alternativa puoi modificare manualmente il file /etc/X11/xorg.conf

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

Ciao,cmq non ho la versione live ho quella da dvd scaricata da internet.Non vorrei fosse incompatibile con la mia scheda video perchè ora ho una nuova novità. ieri sera mi ha chiesto di aggiornare il sistema e ora funziona solamente se avvio in modalità sicura e profilo personalizzato in versione grafica tutta "stilizzata" Wink.Infatti quando cerco di farlo partire in modalità predefinita(sempre dopo aver avviato in modalità sicura)cerca di caricare gli effetti grafici ma poi ritorna alla scelta utente.Scusate la mia ignoranza ma non sono molto pratico con linux ma sono affascinato e ho molta voglia di imparare e conoscere questo sistema operativo.CHe fare?Potrebbe dipendere dall'incompatibilità con il kernel??Cosa sarebbe la "modalità sicura"?
Grazie mille

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

se ti dovesse ricapitare che non ti si avvia X, ovvero l'interfaccia grafica e ti rimane la schermata di login nera, diventa root e usa il tools
drakx11

è molto simile al tools che usi "con il mouse" qui ti sposti con tab e le freccette, se non fossi ancora a tuo agio con l'editare un file manualmente.
Ricordati che puoi usare il driver vesa in situazioni di emergenza e nella lista è molto in "basso"..

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di zucco
zucco
(Junior)
Offline
Junior
Iscritto: 28/10/2008
Messaggi: 21

niente da fare nemmeno editandolo in quella maniera riesco ad ottenere qualcosa,l'unico modo per avviarlo resta quella di passare attraverso la modalità "impostazione sicure" e allora tutto va alla perfezione..altrimenti sempre e solo schermo nero!!DA cosa può dipendere?Che posso fare??ormai le ho provate tutte se non risolvo penso mi toccherà ritornare alla versione 2009.1 Sad.

Ritratto di killer1987
killer1987
(Guru)
Offline
Guru
Iscritto: 02/04/2006
Messaggi: 2924

ciao, forse potrebbe essere un problema di framebuffer... prova questo suggerimento usato per un'altro problema:
http://wiki.mandriva.com/it/2009.0_Errata#Casi_riguardanti_Framebuffer
c'è anche un bug aperto per la 2009.1, non so se c'entri qualcosa, adesso non ho tempo per guardarlo: https://qa.mandriva.com/show_bug.cgi?id=50414

ciao
Marcello

Alé Mageia, C'mon Mageia!!! - Wiki Italiano Mandriva - Acer Aspire 5633, intel GMA 950, stamp HP Laserjet 1018, scanner Epson