Problemi con Nvidia GeForce 2 MX/MX400

31 risposte [Ultimo messaggio]
Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ciao a tutti,
per qualche motivo sconosciuto, non partiva più il login grafico, in pratica alla fine del boot, era solo possibile il login testuale.
Leggendo nei forum, con drakconf, ho modificato i driver per la scheda video in vesa, riuscendo così a ripartire.
Ora però non riesco a caricare correttamente i driver per questa scheda video (Nvidia GeForce 2 MX/MX400 64 Mb).
(Prima funzionava tutto alla perfezione, 3d, compiz etc.)
Dal centro di controllo se carico i driver 96xx per GeForce 3 to 4, eseguendo il test, da l'errore NVidia (0): failed to initialize the Nvidia kernel module.
Segue poi " that there is a supported Nvidia GPU in this system and ..." Prova a cambiare dei parametri.
Il peggio è che se salvo questa configurazione non parte più il server grafico!
Provando con TNT GeForce 2 va meglio, ma niente 3d.
Ho provato così scaricando i driver (96.43.05) da Nvidia e lanciando il comando (previo init 3) sh NVIDIA-Linux-X86-96-43-05-pkg1.run ma ottengo l'errore " No precompiled kernel interfaces was found to mach your kernel; would you like the installer to attemp to download a kernel interface for your kernel from the Nvidia ftp site? ".
Ovviamente rispondo Yes, ma ottengo poi l'errore " No matching precompiled kernel interfaces was found on the Nvidia ftp site ".
Tralascio il resto per non dilungarmi oltre, ma alla fine non riesco nell'installazione.
A proposito, con uname -r ottengo 2.6.22.19-desktop-2mdv.
Potete cortesemente aiutarmi?
Ciao e Grazie

Ritratto di kurtz77
kurtz77
(Guru)
Offline
Guru
Iscritto: 30/10/2004
Messaggi: 2486

Disinstalla e reinstalla i driver nvidia dal centro di controllo tramite il gestore dei pacchetti, la tua scheda probabilmente usa i driver legacy, che supportano le schede video meno recenti e quindi il pacchetto che hai scaricato non apporta nessuna miglioria anzi è probabilmente la stessa versione disponibile in mandriva.
Nella sezione Hardware>Configura il server grafico, la procedura dovrebbe essere automatica appena viene rilevata la possibilità di installare un driver proprietario.

Ciao

kurtz77 8-)
blog: la linea d'ombra

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ho provato, ma niente da fare, stesso errore.

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ciao, ho provato con i nuovi driver nvidia, ma ottengo ancora lo stesso errore!
Qualche idea?

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ho mandriva 2008, quindi ho provato ad installare quanto suggerito: sembrava tutto ok, ma al riavvio schermata nera!
Drakconf per fare ripartire il tutto.
Ho provato poi da centro di controllo, configura il server grafico, a caricare i driver, ed alla domanda: esiste un driver proprietario disponibile per questa scheda video che ha ulteriori caratteristiche. Vuoi utilizzarlo? Rispondendo Si, ottengo come risposta: Il driver proprietario non ha potuto essere installato correttamente, in mancanza verrà utilizzato il driver libero.
E quindi niente 3D....

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

...quando dici:

....ho provato ad installare quanto suggerito: sembrava tutto ok,....

cosa intendi? ...la compilazione non ha dato errori? e poi succede il misfatto?

Mi sa che c'e' un po di casino nei moduli e nei pacchetti nvidia installati. Bisogna fare pulizia.....cmq posta il risultato del comando
$rpm -qa | grep nvidia

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ciao, questo è quello che ottengo con:
rpm -qa | grep nvidia
nvidia71xx-kernel-desktop-latest-1.0-1.20080506.7185.5mdv2008.0
nvidia-current-kernel-2.6.22.19-desktop-2mdv-100.14.19-1mdv2008.0
dkms-nvidia-current-173.14.09-1mdv2008.0
nvidia71xx-kernel-2.6.22.9-desktop-1mdv-1.0-7185.5mdv2008.0
nvidia96xx-kernel-2.6.22.19-desktop-2mdv-1.0-9639.4mdv2008.0
nvidia96xx-kernel-2.6.22.9-desktop-1mdv-1.0-9639.4mdv2008.0
x11-driver-video-nvidia71xx-71.86.01-1.1.mib2008.0
nvidia71xx-kernel-2.6.22.19-desktop-2mdv-1.0-7185.5mdv2008.0
nvidia-current-kernel-desktop-latest-100.14.19-1.20080506.1mdv2008.0
nvidia71xx-kernel-2.6.22.18-desktop-1mdv-1.0-7185.5mdv2008.0
nvidia-current-kernel-2.6.22.9-desktop-1mdv-100.14.19-1mdv2008.0
nvidia-current-doc-html-173.14.09-1mdv2008.0
x11-driver-video-nvidia96xx-96.43.01-1.1.mib2008.0
dkms-nvidia96xx-96.43.01-1.1.mib2008.0
nvidia96xx-kernel-2.6.22.18-desktop-1mdv-1.0-9639.4mdv2008.0
nvidia96xx-kernel-desktop-latest-1.0-1.20080506.9639.4mdv2008.0
dkms-nvidia71xx-71.86.01-1.1.mib2008.0
nvidia-current-kernel-2.6.22.18-desktop-1mdv-100.14.19-1mdv2008.0
x11-driver-video-nvidia-current-173.14.09-1mdv2008.0

Sbaglio, o sembra un pò una specie di cronostoria di quanto installato?

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

Come supponevo bisogna fare pulizia.

Il comando rpm -qa | grep nvidia è molto di più di una cronostoria, mostra i pacchetti riferiti ai driver nvidia installati e quindi anche tu puoi capire che c'è una enorme confusione di release e di dkms ecc. ecc.
.
Fai cosi, disinstalla ad uno ad uno tutti i pacchetti dell'elenco tramite il centro di controllo mandriva > Installa&rimuovi software.

Ridai il comando rpm -qa | grep nvidia e verifichi che i pacchetti siano disinstallati tutti. Rifai a seguire la procedura nvidia di installazione.

Coraggio ....ancora un piccolo sforzo! Wink

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Come si suol dire, una buona ed una meno buona: dopo il lavoro di pulizia ho reinstallato con la procedura nvidia, reboot (e qui ho finalmente rivisto il logo nvidia) e accelerazione video ok.
Sembrava in effetti tutto a posto, poi ho visto che manca (credo) il decoratore di finestre: infatti non si può ingrandire o minimizzare le finestre, o chiudere le finestre con "x".
Ho provato caricando emerald, ma niente: mi sfugge qualcosa?
Un'altra cosa: come mai tutti quei pacchetti nvidia installati? La cosa che mi preoccupa è che non vorrei installare qualcosa di non corretto in seguito ad un aggiornamento.
Ciao

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

Quote:

geronimo62 ha scritto:
...................
Sembrava in effetti tutto a posto, poi ho visto che manca (credo) il decoratore di finestre: infatti non si può ingrandire o minimizzare le finestre, o chiudere le finestre con "x".
Ho provato caricando emerald, ma niente: mi sfugge qualcosa?

...ti manca 'fusion-icon', installalo e fai in modo che parta al boot.

Quote:

geronimo62 ha scritto:
Un'altra cosa: come mai tutti quei pacchetti nvidia installati? La cosa che mi preoccupa è che non vorrei installare qualcosa di non corretto in seguito ad un aggiornamento.
Ciao

E' colpa degli aggiornamenti automatici. Io consiglio sempre di disabilitarli.

Ritratto di geronimo62
geronimo62
(Junior)
Offline
Junior
Iscritto: 05/02/2008
Messaggi: 34

Ok, ho installato fusion-icon, ma ancora niente.
Scusa, ma come si fa per farlo partire al boot?