Problema Driver Nvidia 8400GS

6 risposte [Ultimo messaggio]
Ritratto di dave_adm
dave_adm
(Newbie)
Offline
Newbie
Iscritto: 08/02/2009
Messaggi: 4

Ciao a Tutti,
sono un nuovo Utente sia del Vostro ottimo sito che di Linux. Ho da poco installato Linux Mandriva 2009.0 Free su un Pentium 4 3000 Mhz HT con 1024 di RAM e con VGA NVIDIA Geforce 8400. La rete, audio, lettori ecc... funzionano perfettamente, ho dei problemi con la scheda video, la visualiazzazione è estremamente rallentata e gli effetti 3d non funzionano (dicendomi che il 3d non è supportato). In XFdrake la scheda riusulta Geforce 6100 and Later anche dopo aver installato i Driver del sito della NVIDIA (180.22 per Linux a 32bit), solo in una occassione XFdrake mi vedeva la scheda come "Personalizzata" però all'avvio del Server X, si presentava il LOGO NVIDIA che sfarfallava, senza avviarsi.
Ho provato diversi metodi basandomi su guide trovate in internet. Ma il problema persiste, forse ho sbagliato io oppure non ho installato qualche rpmi neccessario BOH. Vi prego aiutatemi voglio uscire dalla dipendeza di winzoz.

Grazie a tutti

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao e Benvenuto tra noi

Probabilmente seguendo queste guide avrai finito di incasinare tutto il sistema, comunque è bizzarro che uscisse fuori il logo e poi si bloccasse la macchina, in genere dovrebbe essere il contrario.

Vediamo un po' di cose:

1) rom -qa | grep kernel

2) uname -r

3) rpm -qa | grep nvidia

4) cat /etc/X11/xorg.conf

5) Analizza il file /var/log/Xorg.0.log alla ricerca di tutte le righe che cominciano con (EE) e postale

6) Spiega quali guide hai seguito e specialmente se hai usato i file bin per incasinare definitivamente il tutto.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

scusa se ti correggo Moreno ma magari dave_adm non conosce ancora i tutti i comandi

1) rom -qa | grep kernel

in verità è

1) rpm -qa | grep kernel

Ritratto di dave_adm
dave_adm
(Newbie)
Offline
Newbie
Iscritto: 08/02/2009
Messaggi: 4

Ciao è Grazie di avermi risposto così velocemente. Si ho finito per incasinare il tutto all'inizio,(infatti ho reinstallato l'OS un paio di volte) ma a forza di provare e riprovare ho preso un po' di familiarità con la Console di Linux e sono riuscito almeno a far avviare il Server X tramite XFdrake mantenedo il driver che mandriva aveva scelto per me.
I driver che ho installato sono gli ultimi che ho trovato sul sito Nvidia per la mia scheda 180.22 per Linux 32bit

Di seguito le Info che mi hai chiesto:
1)kernel-desktop-devel-2.6.27-0.rc8.2mnb2
kernel-source-2.6.27-0.rc8.2mnb-1-1mnb2
kernel-desktop-lastest-2.6.27-0.rc8.2mnb2
kernel-desktop-2.6.27-0.rc8.2mnb-1-1mnb2
nvidia-current-kernel-2.6.27-desktop-1mnb-177.70-2.3mdv2009.0
nvidia-current-kernel-2.6.27-desktop-0.rc8.2mnb-177.70-1mdv2009.0
kernel-desktop-2.6.27.10-1mnb-1-1mnb2
kernel-headers-2.6.27.5-1mnb2
kernel-firmware-2.6.27-2mnb2
kernel-desktop-devel-latest-2.6.27.10-1mnb2
nvidia-current-kernel-desktop-latest-177.70-1.20090103.2.3mdv2009.0
2) 2.6.27.10-desktop-1mnb
3) x11-driver-video-nvidia-current-177.70-2.3mdv2009.0
nvidia-current-kernel-2.6.27.10-desktop-1mnb-177.70-1mdv2009.0
dkms-nvidia-current-177.70-2.3mdv2009.0
nvidia-current-doc-html-177.70-2.3mdv2009.0
nvidia-current-kernel-desktop-lastest-177.70-1.20090130.2.3mdv2009.0
4) Beh nel file Xorg.conf penso che sei interessato solo alla Sezione "Device", questo file l'ho modificato di recente come indicato sul sito della Nvidia infatti ho finito per rovinare il driver della tastiera Big Grin LOL
cmq
Section "DEVICE"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 6100 later"
Driver "nv" Questo l'ho rimodificato a originale anche con parametro "nvidia" dava i soliti problemi
Option "DPMS"
EndSection
5)Allora le uniche righe che ho trovato sono:
(EE) Failed to initialize GLX extension (compatible NVIDIA X driver not found)
(EE) No Input driver matching 'nv'
6) Le guide che ho usato sono:
1)http://linuxpedia.netsons.org/index.php?title=Configurazione_scheda_video_NVIDIA_in_Mandriva
2)http://eldino.wordpress.com/2007/11/12/it-tutorial-come-installare-i-driver-nvidia-su-mandriva-2008-e-godersi-compiz-senza-connesione-internet/
3)http://guide.debianizzati.org/index.php/Installazione_driver_proprietari_Nvidia
Poi ho letto alcuni Forum in Internet tra cui alcuni vostri, poi vedendo che era il migliore mi sono iscritto :-P

Un bel casotto eh? Cmq se ce bisogno magari rifaccio tutto da capo. Forse ho dimenticato qualche reponsity o pacchetto di qualche genere BOH
In attesa di una vostra risposta vi ringrazio immensamente

Ritratto di dave_adm
dave_adm
(Newbie)
Offline
Newbie
Iscritto: 08/02/2009
Messaggi: 4

Penso che ora risultino i 177.70 perchè ho ripristina quelli precedenti no?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Cominciamo col le guide seguite, una peggio dell'altra.
Se avessi seguito le nostre guide avresti potuto avere più canches.
Quella più valida rimane quella scritta da Tony_Evo http://www.mandrakeitalia.org/modules/wfsection/article.php?page=1&articleid=285 dea seguire sino al punto 9.

I messaggi d'errore parlano chiaro non vengono neanche trovati i driver nvidia, chissa dove sono finiti.

direi a questo punto di:

1)
urpme nvidia-current-kernel dkms-nvidia-current

2)
urpmi nvidia-current-kernel

riavvi, incroci le dita ed in caso d'errore cerca i messaggi d'errore in /var/log/Xorg.0.log

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di dave_adm
dave_adm
(Newbie)
Offline
Newbie
Iscritto: 08/02/2009
Messaggi: 4

Ok Grazie Mille per l'assistenza mi metto subito a provare..
A più Tardi...