Problema con driver Ati

4 risposte [Ultimo messaggio]
Ritratto di minosat
minosat
(Geek)
Offline
Geek
Iscritto: 01/06/2006
Messaggi: 106

Devo dire che è colpa mia Sad se stavo fermo magari non succedeva, ma è successo.... ho una Ati 9200SE e funzionava tutto bene (compreso compiz-fusion) con i driver free 8.34.8 poi mi è venuta la brillante di aggiornare i driver con la versione 8.40 da allora sono cominciati i guai, ho provato di tutto (o quasi) ma non riesco più a far funzionare compiz-fusion sono anche ritornato a installare i driver 8.34.8 e se scrivo "glxinfo" questo è il risultato:

[xxxxx@localhost ~]$ glxinfo
name of display: :0.0
Segmentation fault

allego anche il mio xorg.conf anche se forse credo il problema sia altrove... se qualcuno può aiutarmi.... Grazie

[xxxxxx@localhost ~]$ cat /etc/X11/xorg.conf
# File generated by XFdrake (rev 142098)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does no
t work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "FA17A"
HorizSync 30-82
VertRefresh 50-75

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon 9250 and earlier"
Driver "ati"
Option "DPMS"
Option "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Dai il comando

update-alternatives --config gl_conf

dovrebbe essere settato sul secondo campo (non ricordo il nome al momento).

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di minosat
minosat
(Geek)
Offline
Geek
Iscritto: 01/06/2006
Messaggi: 106

Moreno ho fatto come dici tu ma non mi succede nulla, ho provato anche a disinstallare tutto, driver beryl, compiz, fusion e cancellare anche le dir relative... reinstallare i driver ATI 8.34.8 free e compiz-fusion daccapo, risultato?

[xxxxx@localhost ~]$ glxinfo
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Segmentation fault

Che altro posso fare?

Ti invio anche il mio xorg.conf

# File generated by XFdrake (rev 142098)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does no
t work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "FA17A"
HorizSync 30-82
VertRefresh 50-75

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon 9250 and earlier"
Driver "ati"
Option "DPMS"
Option "XaaNoOffscreenPixmaps" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Grazie

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Ora che ci guardo meglio non hai configurato il file xorg.conf per usare i driver ATI.

Ti posto il mio come esempio:

<br /># File generated by XFdrake (rev 228555)<br /># **********************************************************************<br /># Refer to the xorg.conf man page for details about the format of<br /># this file.<br /># **********************************************************************<br /><br />Section &quot;ServerLayout&quot;<br />   Identifier     &quot;layout1&quot;<br />        #New<br />      Option &quot;AIGLX&quot; &quot;false&quot;<br />        Screen      0  &quot;aticonfig-Screen[0]&quot; 0 0<br />        InputDevice    &quot;Keyboard1&quot; &quot;CoreKeyboard&quot;<br />     InputDevice    &quot;Mouse1&quot; &quot;CorePointer&quot;<br /> InputDevice    &quot;SynapticsMouse1&quot; &quot;AlwaysCore&quot;<br />EndSection<br /><br />Section &quot;Files&quot;<br />EndSection<br /><br />Section &quot;Module&quot;<br />      Load  &quot;dbe&quot; # Double-Buffering Extension<br />        Load  &quot;v4l&quot; # Video for Linux<br />   Load  &quot;extmod&quot;<br />  Load  &quot;type1&quot;<br />   Load  &quot;freetype&quot;<br />        Load  &quot;glx&quot; # 3D layer<br />  Load  &quot;dri&quot; # direct rendering<br />EndSection<br /><br />Section &quot;ServerFlags&quot;<br />    #New<br />    Option &quot;AIGLX&quot; &quot;off&quot;<br />    #DontZap # disable &lt;Ctrl&gt;&lt;Alt&gt;&lt;BS&gt; (server abort)<br />    #DontZoom # disable &lt;Ctrl&gt;&lt;Alt&gt;&lt;KP_+&gt;/&lt;KP_-&gt; (resolution switching)<br /> # allows the server to start up even if the mouse does not work<br />       Option      &quot;allowmouseopenfail&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br />     Identifier  &quot;Keyboard1&quot;<br /> Driver      &quot;kbd&quot;<br />       Option      &quot;XkbModel&quot; &quot;pc105&quot;<br />        Option      &quot;XkbLayout&quot; &quot;it&quot;<br />  Option      &quot;XkbOptions&quot; &quot;compose:rwin&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br />    Identifier  &quot;Mouse1&quot;<br />    Driver      &quot;mouse&quot;<br />     Option      &quot;Protocol&quot; &quot;ExplorerPS/2&quot;<br /> Option      &quot;Device&quot; &quot;/dev/mouse&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br />  Identifier  &quot;SynapticsMouse1&quot;<br />   Driver      &quot;synaptics&quot;<br /> Option      &quot;EdgeMotionMinSpeed&quot; &quot;200&quot;<br />        Option      &quot;MaxSpeed&quot; &quot;1.00&quot;<br /> Option      &quot;MinSpeed&quot; &quot;0.8&quot;<br />  Option      &quot;BottomEdge&quot; &quot;650&quot;<br />        Option      &quot;EdgeMotionMaxSpeed&quot; &quot;200&quot;<br />        Option      &quot;CircScrollTrigger&quot; &quot;2&quot;<br />   Option      &quot;UpDownScrolling&quot; &quot;0&quot;<br />     Option      &quot;SHMConfig&quot; &quot;on&quot;<br />  Option      &quot;LeftEdge&quot; &quot;120&quot;<br />  Option      &quot;FingerLow&quot; &quot;14&quot;<br />  Option      &quot;HorizScrollDelta&quot; &quot;20&quot;<br />   Option      &quot;MaxTapMove&quot; &quot;110&quot;<br />        Option      &quot;FingerHigh&quot; &quot;15&quot;<br /> Option      &quot;VertScrollDelta&quot; &quot;20&quot;<br />    Option      &quot;CircularScrolling&quot; &quot;1&quot;<br />   Option      &quot;RightEdge&quot; &quot;830&quot;<br /> Option      &quot;AccelFactor&quot; &quot;0.015&quot;<br />     Option      &quot;TopEdge&quot; &quot;120&quot;<br />EndSection<br /><br />Section &quot;Monitor&quot;<br /><br />    # TV fullscreen mode or DVD fullscreen output.<br />    # 768x576 @ 79 Hz, 50 kHz hsync<br />     Identifier   &quot;monitor1&quot;<br /> VendorName   &quot;Generic&quot;<br />  ModelName    &quot;Flat Panel 1680x1050&quot;<br />     HorizSync    31.5 - 90.0<br />  VertRefresh  60.0 - 60.0<br />  ModeLine     &quot;768x576&quot; 50.0 768 832 846 1000 576 590 595 630<br />    ModeLine     &quot;768x576&quot; 63.1 768 800 960 1024 576 578 590 616<br />    ModeLine     &quot;1680x1050_120&quot; 313.2 1680 1816 2000 2320 1050 1051 1054 1125 -hsync +vsync<br />        ModeLine     &quot;1680x1050_100&quot; 256.2 1680 1808 1992 2304 1050 1051 1054 1112 -hsync +vsync<br />        ModeLine     &quot;1680x1050_85&quot; 214.5 1680 1800 1984 2288 1050 1051 1054 1103 -hsync +vsync<br /> ModeLine     &quot;1680x1050_75&quot; 188.1 1680 1800 1984 2288 1050 1051 1054 1096 -hsync +vsync<br /> ModeLine     &quot;1680x1050_60&quot; 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync<br /> ModeLine     &quot;1680x1050_50&quot; 120.2 1680 1776 1952 2224 1050 1051 1054 1081 -hsync +vsync<br /> ModeLine     &quot;1600x1000_120&quot; 284.0 1600 1728 1904 2208 1000 1001 1004 1072 -hsync +vsync<br />        ModeLine     &quot;1600x1000_100&quot; 232.1 1600 1720 1896 2192 1000 1001 1004 1059 -hsync +vsync<br />        ModeLine     &quot;1600x1000_85&quot; 194.2 1600 1712 1888 2176 1000 1001 1004 1050 -hsync +vsync<br /> ModeLine     &quot;1600x1000_75&quot; 169.1 1600 1704 1880 2160 1000 1001 1004 1044 -hsync +vsync<br /> ModeLine     &quot;1600x1000_60&quot; 133.1 1600 1704 1872 2144 1000 1001 1004 1035 -hsync +vsync<br /> ModeLine     &quot;1600x1000_50&quot; 108.7 1600 1688 1856 2112 1000 1001 1004 1029 -hsync +vsync<br /> ModeLine     &quot;1440x900_120&quot; 229.8 1440 1552 1712 1984 900 901 904 965 -hsync +vsync<br />     ModeLine     &quot;1440x900_100&quot; 187.6 1440 1544 1704 1968 900 901 904 953 -hsync +vsync<br />     ModeLine     &quot;1440x900_85&quot; 156.8 1440 1536 1696 1952 900 901 904 945 -hsync +vsync<br />      ModeLine     &quot;1440x900_75&quot; 136.5 1440 1536 1688 1936 900 901 904 940 -hsync +vsync<br />      ModeLine     &quot;1440x900_60&quot; 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync<br />      ModeLine     &quot;1440x900_50&quot; 87.4 1440 1512 1664 1888 900 901 904 926 -hsync +vsync<br />       ModeLine     &quot;1280x800_120&quot; 181.2 1280 1376 1520 1760 800 801 804 858 -hsync +vsync<br />     ModeLine     &quot;1280x800_100&quot; 147.9 1280 1376 1512 1744 800 801 804 848 -hsync +vsync<br />     ModeLine     &quot;1280x800_85&quot; 123.4 1280 1368 1504 1728 800 801 804 840 -hsync +vsync<br />      ModeLine     &quot;1280x800_75&quot; 107.2 1280 1360 1496 1712 800 801 804 835 -hsync +vsync<br />      ModeLine     &quot;1280x800_60&quot; 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync<br />       ModeLine     &quot;1280x800_50&quot; 68.6 1280 1336 1472 1664 800 801 804 824 -hsync +vsync<br />EndSection<br /><br />Section &quot;Monitor&quot;<br />        Identifier   &quot;aticonfig-Monitor[0]&quot;<br />     Option      &quot;VendorName&quot; &quot;ATI Proprietary Driver&quot;<br />     Option      &quot;ModelName&quot; &quot;Generic Autodetecting Monitor&quot;<br />       Option      &quot;DPMS&quot; &quot;true&quot;<br />EndSection<br /><br />Section &quot;Device&quot;<br />       Identifier  &quot;device1&quot;<br />   Driver      &quot;ati&quot;<br />       VendorName  &quot;ATI Technologies Inc&quot;<br />      BoardName   &quot;ATI Radeon 9500 - X850&quot;<br />    Option      &quot;DPMS&quot;<br />      Option      &quot;XaaNoOffscreenPixmaps&quot; &quot;1&quot;<br />EndSection<br /><br />Section &quot;Device&quot;<br /> Identifier  &quot;aticonfig-Device[0]&quot;<br />       Driver      &quot;fglrx&quot;<br />EndSection<br /><br />Section &quot;Screen&quot;<br />       Identifier &quot;screen1&quot;<br />    Device     &quot;device1&quot;<br />    Monitor    &quot;monitor1&quot;<br />   DefaultDepth     24<br />       SubSection &quot;Display&quot;<br />            Depth     8<br />               Modes    &quot;1680x1050&quot; &quot;1600x1000&quot; &quot;1440x900&quot; &quot;1280x800&quot;<br />    EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth     15<br />              Modes    &quot;1680x1050&quot; &quot;1600x1000&quot; &quot;1440x900&quot; &quot;1280x800&quot;<br />    EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth     16<br />              Modes    &quot;1680x1050&quot; &quot;1600x1000&quot; &quot;1440x900&quot; &quot;1280x800&quot;<br />    EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth     24<br />              Modes    &quot;1680x1050&quot; &quot;1600x1000&quot; &quot;1440x900&quot; &quot;1280x800&quot;<br />    EndSubSection<br />EndSection<br /><br />Section &quot;Screen&quot;<br />       Identifier &quot;aticonfig-Screen[0]&quot;<br />        Device     &quot;aticonfig-Device[0]&quot;<br />        Monitor    &quot;aticonfig-Monitor[0]&quot;<br />       DefaultDepth     24<br />       SubSection &quot;Display&quot;<br />            Viewport   0 0<br />            Depth     24<br />      EndSubSection<br />EndSection<br /><br />Section &quot;Extensions&quot;<br />#  Option      &quot;Composite&quot;<br />EndSection<br />

Per info dai un occhiata ache a questa guida:
http://www.mandrakeitalia.org/modules/wfsection/article.php?page=1&articleid=192

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di minosat
minosat
(Geek)
Offline
Geek
Iscritto: 01/06/2006
Messaggi: 106

L'ho seguita quella guida ma ti posso garantire che non ho ottenuto migliorie, volendo posso provare a usare il tuo xorg.conf?
(Anche se mi dici di no ci provo lo stesso, gli amici mi chiamano S. Tommaso! )
volevo porti anche un'altro quesito:
non credo sia collegato dallo stesso problema ma da quando ho fatto l'aggiornamento automatico di sistema qualche giono fa che mi ha aggiornato anche il Kdebase... non mi parte neache più l'OpenOffice... questo è il backtrace dell' errore di crash quando invoco l' apertura del programma

(no debugging symbols found)
Using host libthread_db library "/lib/i686/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1237955792 (LWP 4466)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb4ea26be in XF86DrmAdaptor::XF86DrmAdaptor () from /usr/lib/libGL.so.1
#7 0xb4e9f7fe in drmwayOpen () from /usr/lib/libGL.so.1
#8 0xb4e9e6b3 in lnxioOpen () from /usr/lib/libGL.so.1
#9 0xb4d899bc in ioOpen () from /usr/lib/libGL.so.1
#10 0xb4d52afc in gslOpen () from /usr/lib/libGL.so.1
#11 0xb45bb464 in gldvOpen () from /usr/lib/libGL.so.1
#12 0xb49f07b2 in wsiDisplay::wsiDisplay () from /usr/lib/libGL.so.1
#13 0xb4a1ce89 in wsiGlobalDatabase::getDisplay () from /usr/lib/libGL.so.1
#14 0xb49fee9b in wsiGetDisplay () from /usr/lib/libGL.so.1
#15 0xb4ea75d5 in GlxDisplayInfo::GlxDisplayInfo () from /usr/lib/libGL.so.1
#16 0xb4ea6f6a in GlxState::addDisplayConnection () from /usr/lib/libGL.so.1
#17 0xb4ea70dd in GlxState::getDisplayInfo () from /usr/lib/libGL.so.1
#18 0xb4ea83ba in glXGetConfig () from /usr/lib/libGL.so.1
#19 0xb565f0c2 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#20 0xb567fb86 in SalDisplay::BestVisual ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#21 0xb5683c12 in SalDisplay::initScreen ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#22 0xb5694faf in vcl_sal::WMAdaptor::WMAdaptor$base ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#23 0xb56962d9 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#24 0xb5696aa7 in vcl_sal::WMAdaptor::createWMAdaptor ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#25 0xb5688e36 in SalDisplay::Init ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#26 0xb568b30c in SalX11Display::SalX11Display$base ()
from /usr/lib/ooo-2.1/program/libvclplug_gen680li.so
#27 0xb6f16181 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvclplug_kde680li.so
#28 0xb6f165b9 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvclplug_kde680li.so
#29 0xb6f15e45 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvclplug_kde680li.so
#30 0xb6f169c7 in create_SalInstance ()
from /usr/lib/ooo-2.1/program/libvclplug_kde680li.so
#31 0xb7e9966e in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvcl680li.so
#32 0xb7e9994c in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvcl680li.so
#33 0xb7c3bb4d in InitVCL () from /usr/lib/ooo-2.1/program/libvcl680li.so
#34 0xb7c3bf61 in Window::Resize ()
from /usr/lib/ooo-2.1/program/libvcl680li.so
#35 0xb7c3c175 in SVMain () from /usr/lib/ooo-2.1/program/libvcl680li.so
#36 0x0805f283 in sal_main ()
#37 0x0805f306 in main ()

:-o :-o :-o sono grave?