nvidia 295.17-2 non vanno

3 risposte [Ultimo messaggio]
Ritratto di Max66
Max66
(Geek)
Offline
Geek
Iscritto: 05/07/2009
Messaggi: 89

Ieri aggiornando la 2011 x86_64 mi ha installato anche i nuovi driver nvidia in oggetto; presumo che siano già la seconda versione (teoricamente funzionanti)
Avviando il PC senza grafica mi si pianta con questo messaggio:

nvidia-current (295.17-2): Installing module.
.......(bad exit status: 10)
Build failed. Installation skipped.

Il PC non va più avanti: non ho la grafica e nemmeno la console.

La scheda grafica è una nvidia GeForce 9500 GT
Come posso ripristinare? Devo rifare l'installazione??

Grazie 1000

O.T. anche se non è il forum adatto, oso chiedere: sulla stessa macchina c'è un XP con un virus nel MBR; posso formattare e reinstallare XP senza perdere la mia installazione Mandriva (ammesso che il problema in oggetto si risolva)?

Mdv 2010.2 i586 - KDE4.5.5 - Kernel 2.6.33.6-desktop-nrjpae -> INTEL Core2 Duo E7300 2,66GHz - 4GB - nVidia GeForce9500GT
Mdv 2011 x86_64 - KDE4.6.5 - Kernel 2.6.38.7-desktop-1mnb2 -> AMD Thurion X2 Ultra Dual-Core Mobile ZM-80 - 4GB - nVidia GT130M

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Prova ad arrivare in console con CTRL+ALT+F1 e da lì da root dai xfdrake o mcc. Ti si aprirà un centro di controllo in modalità testo, da qui configura la scheda video in modo da usare i driver open nvidia o quelli vesa che ti faranno partire il pc in modalità video.
Ripristina questa situazione e poi vediamo se si riesce a far andare i nuovi driver video.
Ciao
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Max66
Max66
(Geek)
Offline
Geek
Iscritto: 05/07/2009
Messaggi: 89

Sono riuscito a far ripartire la grafica con i driver vesa, anche se con frequenti freeze.

La situazione attuale è questa:

[root@localhost ~]# uname -r
2.6.39.4-5.1-desktop
 
[root@localhost ~]# rpm -qa |grep kernel
kernel-desktop-devel-latest-2.6.39.4-4-mdv2011.0.x86_64
kernel-firmware-20110803-69.3-mib2011.0.noarch
kernel-desktop-devel-2.6.39.4-5.1-mdv2011.0.x86_64
kernel-desktop-latest-2.6.39.4-4-mdv2011.0.x86_64
kernel-headers-2.6.39.4-4.2-mdv2011.0.x86_64
kernel-desktop-2.6.39.4-5.1-mdv2011.0.x86_64
kernel-firmware-extra-20110803-69.2-mib2011.0.noarch
nvidia-current-kernel-2.6.39.4-5.1-desktop-280.13-4-mdv2011.0.x86_64
nvidia-current-kernel-desktop-latest-280.13-1.20120104.4-mdv2011.0.x86_64
 
[root@localhost ~]# rpm -qa |grep nvidia
nvidia-current-kernel-2.6.39.4-5.1-desktop-280.13-4-mdv2011.0.x86_64
nvidia-current-kernel-desktop-latest-280.13-1.20120104.4-mdv2011.0.x86_64
dkms-nvidia-current-295.17-2-mdv2011.0.x86_64
nvidia-current-doc-html-295.17-2-mdv2011.0.x86_64
x11-driver-video-nvidia-current-295.17-2-mdv2011.0.x86_64

Grazie

Mdv 2010.2 i586 - KDE4.5.5 - Kernel 2.6.33.6-desktop-nrjpae -> INTEL Core2 Duo E7300 2,66GHz - 4GB - nVidia GeForce9500GT
Mdv 2011 x86_64 - KDE4.6.5 - Kernel 2.6.38.7-desktop-1mnb2 -> AMD Thurion X2 Ultra Dual-Core Mobile ZM-80 - 4GB - nVidia GT130M

Ritratto di Max66
Max66
(Geek)
Offline
Geek
Iscritto: 05/07/2009
Messaggi: 89

Niente da fare: i nuovo driver non riesco proprio a farli funzionare.

Se vado a scegliere la scheda grafica da MCC, dopo aver risposto SI al caricamento del driver proprietario, mi riporta questo errore:

Si è verificato un errore:
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.

Qualcuno può darmi qualche dritta?

EDIT:
Dopo una decina di tentativi, ho risolto con:

[root@localhost ~]# urpme dkms-nvidia-current
[root@localhost ~]# urpmi dkms-nvidia-current

Dopo il rebuild tutto torna a funzionare, effetti desktop compresi.

Con XFdrake, però, mi segnala la presenza di driver proprietari e, se confermo il loro utilizzo, mi carica questi due:

nvidia-current-kernel-2.6.39.4-5.1-desktop-280.13-4-mdv2011.0.x86_64
nvidia-current-kernel-desktop-latest-280.13-1.20120104.4-mdv2011.0.x86_64

è corretto? Posso eliminarli?

Grazie 1000.

Mdv 2010.2 i586 - KDE4.5.5 - Kernel 2.6.33.6-desktop-nrjpae -> INTEL Core2 Duo E7300 2,66GHz - 4GB - nVidia GeForce9500GT
Mdv 2011 x86_64 - KDE4.6.5 - Kernel 2.6.38.7-desktop-1mnb2 -> AMD Thurion X2 Ultra Dual-Core Mobile ZM-80 - 4GB - nVidia GT130M