No audio su ASUS M51SN e Mandriva 2008.1 --> AIUTO!!!

5 risposte [Ultimo messaggio]
Ritratto di mlx82
mlx82
(Newbie)
Offline
Newbie
Iscritto: 10/06/2008
Messaggi: 3

Ciao,

scusate se apro un nuovo topic ma ho visto che al precedente non mi ha risposto nessuno.

Ho un portatile ASUS M51SN con installata la Mandriva 2008 Spring Edition 64bit. Il portatile è dotato di scheda audio "intel 82801H (ICH8 Family) HD audio Controller". Purtroppo non si sente alcun suono (in windows funziona).

Sono andato nel pannello di configurazione della scheda audio e ho spuntato le prime due caselle. Ho installato pulse 0.9.10 e le alsa 1.0.16. Ho anche lanciato alsaconf che mi dice che tutto funziona correttamente.. ma non si sente nulla!

Sono andato sul centro di controllo e ho visto i comandi per verificare che tutto funzioni nella sezione guasti. Vi riporto i risultati:

lspcidrake -v | fgrep -i AUDIO

snd_hda_intel : Intel Corporation|82801H (ICH8 Family) HD Audio Controller (vendor:8086 device:284b subv:1043 subd:1783)

grep sound-slot /etc/modprobe.conf

alias sound-slot-0 snd_hda_intel

/sbin/lsmod

Module Size Used by
ipt_IFWLOG 7816 2
ipt_psd 52368 1
ip_set_iptree 11408 2
iptable_raw 6400 0
xt_comment 6144 0
xt_policy 8192 0
ipt_ULOG 14344 0
ipt_TTL 6400 0
ipt_ttl 6144 0
ipt_TOS 6400 0
ipt_tos 5888 0
ipt_set 6528 2
ipt_SAME 6656 0
ipt_REJECT 8320 4
ipt_REDIRECT 6528 0
ipt_recent 13216 0
ipt_owner 6272 0
ipt_NETMAP 6528 0
ipt_MASQUERADE 7936 0
ipt_LOG 10496 9
ipt_iprange 6016 0
ipt_ECN 7040 0
ipt_ecn 6400 0
ipt_CLUSTERIP 11912 0
ipt_ah 6144 0
ipt_addrtype 6144 4
nf_nat_tftp 6016 0
nf_nat_snmp_basic 14596 0
nf_nat_sip 8704 0
nf_nat_pptp 7424 0
nf_nat_proto_gre 6916 1 nf_nat_pptp
nf_nat_irc 6784 0
nf_nat_h323 11520 0
nf_nat_ftp 7680 0
nf_nat_amanda 6400 0
ts_kmp 6400 5
nf_conntrack_amanda 8704 1 nf_nat_amanda
nf_conntrack_tftp 9364 1 nf_nat_tftp
nf_conntrack_sip 13460 1 nf_nat_sip
nf_conntrack_proto_sctp 13324 0
nf_conntrack_pptp 10496 1 nf_nat_pptp
nf_conntrack_proto_gre 9344 1 nf_conntrack_pptp
nf_conntrack_netlink 31360 0
nf_conntrack_netbios_ns 7040 0
nf_conntrack_irc 10400 1 nf_nat_irc
nf_conntrack_h323 58976 1 nf_nat_h323
nf_conntrack_ftp 12712 1 nf_nat_ftp
ip_set_portmap 8832 0
ip_set_macipmap 8712 0
ip_set_ipmap 8576 0
ip_set_iphash 11912 0
ip_set 23340 11 ip_set_iptree,ipt_set,ip_set_portmap,ip_set_macipmap,ip_set_ipmap,ip_set_iphash
xt_tcpmss 6528 0
xt_pkttype 6272 0
xt_physdev 6928 0
xt_NFQUEUE 6272 0
xt_NFLOG 6400 0
xt_multiport 7680 4
xt_MARK 6912 0
xt_mark 6528 0
xt_mac 6272 0
xt_limit 7168 0
xt_length 6272 0
xt_helper 6784 0
xt_hashlimit 13720 0
ip6_tables 18248 1 xt_hashlimit
xt_DSCP 6656 0
xt_dscp 6400 0
xt_dccp 7432 0
xt_conntrack 7680 0
xt_CONNMARK 7424 0
xt_connmark 6912 0
xt_CLASSIFY 6144 0
xt_tcpudp 7680 11
xt_state 6656 12
iptable_nat 11780 0
nf_nat 23212 14 ipt_SAME,ipt_REDIRECT,ipt_NETMAP,ipt_MASQUERADE,nf_nat_tftp,nf_nat_sip,nf_nat_pptp,nf_nat_proto_gre,nf_nat_irc,nf_nat_h323,nf_nat_ftp,nf_nat_amanda,nf_conntrack_netlink,iptable_nat
nf_conntrack_ipv4 20752 14 iptable_nat
nf_conntrack 69616 29 ipt_MASQUERADE,ipt_CLUSTERIP,nf_nat_tftp,nf_nat_snmp_basic,nf_nat_sip,nf_nat_pptp,nf_nat_irc,nf_nat_h323,nf_nat_ftp,nf_nat_amanda,nf_conntrack_amanda,nf_conntrack_tftp,nf_conntrack_sip,nf_conntrack_proto_sctp,nf_conntrack_pptp,nf_conntrack_proto_gre,nf_conntrack_netlink,nf_conntrack_netbios_ns,nf_conntrack_irc,nf_conntrack_h323,nf_conntrack_ftp,xt_helper,xt_conntrack,xt_CONNMARK,xt_connmark,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
iptable_mangle 6912 1
nfnetlink 8392 1 nf_conntrack_netlink
iptable_filter 7040 1
ip_tables 23784 4 iptable_raw,iptable_nat,iptable_mangle,iptable_filter
x_tables 20744 49 ipt_IFWLOG,ipt_psd,xt_comment,xt_policy,ipt_ULOG,ipt_TTL,ipt_ttl,ipt_TOS,ipt_tos,ipt_set,ipt_SAME,ipt_REJECT,ipt_REDIRECT,ipt_recent,ipt_owner,ipt_NETMAP,ipt_MASQUERADE,ipt_LOG,ipt_iprange,ipt_ECN,ipt_ecn,ipt_CLUSTERIP,ipt_ah,ipt_addrtype,xt_tcpmss,xt_pkttype,xt_physdev,xt_NFQUEUE,xt_NFLOG,xt_multiport,xt_MARK,xt_mark,xt_mac,xt_limit,xt_length,xt_helper,xt_hashlimit,ip6_tables,xt_DSCP,xt_dscp,xt_dccp,xt_conntrack,xt_CONNMARK,xt_connmark,xt_CLASSIFY,xt_tcpudp,xt_state,iptable_nat,ip_tables
af_packet 23944 2
snd_seq_dummy 7556 0
snd_seq_oss 36736 0
snd_seq_midi_event 11520 1 snd_seq_oss
snd_seq 59264 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 11412 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 45728 0
ipv6 290600 21 nf_conntrack_h323
snd_mixer_oss 20608 1 snd_pcm_oss
binfmt_misc 14476 1
loop 20100 0
fuse 51504 5
nls_utf8 6272 1
nls_cp437 11136 1
vfat 16256 1
fat 56112 1 vfat
dm_mod 62840 0
cpufreq_ondemand 12176 1
cpufreq_conservative 12040 0
cpufreq_powersave 6016 0
acpi_cpufreq 11792 2
freq_table 8448 2 cpufreq_ondemand,acpi_cpufreq
nvram 12552 0
mmc_block 16000 0
snd_hda_intel 444248 5
sdhci 21380 0
iwl4965 205288 0
video 23316 0
usbmouse 9088 0
output 7680 1 video
uvcvideo 60552 0
asus_laptop 24284 0
battery 16904 0
ohci1394 34996 0
mmc_core 54280 2 mmc_block,sdhci
led_class 8456 1 asus_laptop
mac80211 135308 1 iwl4965
usbhid 50528 1 usbmouse
compat_ioctl32 13184 1 uvcvideo
iTCO_wdt 16336 0
ac 9480 0
snd_pcm 82824 3 snd_pcm_oss,snd_hda_intel
thermal 19616 0
ieee1394 94552 1 ohci1394
snd_timer 26120 2 snd_seq,snd_pcm
snd_page_alloc 12816 2 snd_hda_intel,snd_pcm
iTCO_vendor_support 7940 1 iTCO_wdt
button 11808 0
videodev 31104 1 uvcvideo
snd_hwdep 12552 1 snd_hda_intel
rtc_cmos 11960 0
processor 37832 4 acpi_cpufreq,thermal
joydev 15616 0
evdev 14976 8
ff_memless 9608 1 usbhid
atl1 38540 0
serio_raw 10372 0
pcspkr 7168 0
snd 60744 18 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
v4l1_compat 17668 2 uvcvideo,videodev
cfg80211 17296 1 mac80211
v4l2_common 22400 3 uvcvideo,compat_ioctl32,videodev
soundcore 11296 1 snd
mii 9344 1 atl1
sr_mod 20900 0
sg 39192 0
ide_disk 18816 0
piix 12804 0 [permanent]
ide_core 123928 2 ide_disk,piix
ata_piix 22788 0
ahci 31620 6
libata 155952 2 ata_piix,ahci
sd_mod 31872 7
scsi_mod 157880 4 sr_mod,sg,libata,sd_mod
ext3 137616 2
jbd 51752 1 ext3
uhci_hcd 29088 0
ohci_hcd 27268 0
ehci_hcd 40204 0
usbcore 151728 7 usbmouse,uvcvideo,usbhid,uhci_hcd,ohci_hcd,ehci_hcd

/sbin/chkconfig --list sound" e "/sbin/chkconfig --list alsa

chkconfig versione 1.3.34 - Copyright (C) 1997-2000 Red Hat, Inc.
Questo software è liberamente distribuibile secondo i termini della GNU Public License.
uso: chkconfig --list [nome]
chkconfig --add <nome>
chkconfig --del <nome>
chkconfig --override <nome>
chkconfig [--level <livelli>] <nome> <on|off|reset|resetpriorities>

aumix -q

bash: aumix: command not found

/sbin/fuser -v /dev/dsp

Nessuna risposta.

Seguendo le indicazioni in un altro post ho provato a fare lspci:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0405 (rev a1)
02:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
09:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
09:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
09:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
09:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

e lspci -n:

00:00.0 0600: 8086:2a00 (rev 03)
00:01.0 0604: 8086:2a01 (rev 03)
00:1a.0 0c03: 8086:2834 (rev 03)
00:1a.1 0c03: 8086:2835 (rev 03)
00:1a.7 0c03: 8086:283a (rev 03)
00:1b.0 0403: 8086:284b (rev 03)
00:1c.0 0604: 8086:283f (rev 03)
00:1c.1 0604: 8086:2841 (rev 03)
00:1c.2 0604: 8086:2843 (rev 03)
00:1c.3 0604: 8086:2845 (rev 03)
00:1c.4 0604: 8086:2847 (rev 03)
00:1c.5 0604: 8086:2849 (rev 03)
00:1d.0 0c03: 8086:2830 (rev 03)
00:1d.1 0c03: 8086:2831 (rev 03)
00:1d.2 0c03: 8086:2832 (rev 03)
00:1d.7 0c03: 8086:2836 (rev 03)
00:1e.0 0604: 8086:2448 (rev f3)
00:1f.0 0601: 8086:2815 (rev 03)
00:1f.1 0101: 8086:2850 (rev 03)
00:1f.2 0106: 8086:2829 (rev 03)
01:00.0 0300: 10de:0405 (rev a1)
02:00.0 0200: 1969:1048 (rev b0)
03:00.0 0280: 8086:4229 (rev 61)
09:01.0 0c00: 1180:0832 (rev 05)
09:01.1 0805: 1180:0822 (rev 22)
09:01.2 0880: 1180:0592 (rev 12)
09:01.3 0880: 1180:0852 (rev 12)

e a verificare il contenuto del file modprobe.conf al quale ho aggiunto la riga options snd_hda_intel model=asus:

alias eth0 atl1
options snd_hda_intel model=asus
install scsi_hostadapter /sbin/modprobe ahci; /sbin/modprobe ata_piix; /bin/true
install usb-interface /sbin/modprobe ehci_hcd; /sbin/modprobe uhci_hcd; /bin/true
remove sdhci /sbin/modprobe -r mmc_block; /sbin/modprobe --first-time -r --ignore-remove sdhci
install sdhci /sbin/modprobe --first-time --ignore-install sdhci && { /sbin/modprobe mmc_block; /bin/true; }
alias ieee1394-controller ohci1394
install ide-controller /sbin/modprobe piix; /bin/true
remove snd_hda_intel /sbin/modprobe --first-time -r --ignore-remove snd_hda_intel
install snd_hda_intel /sbin/modprobe --first-time --ignore-install snd_hda_intel

ma purtroppo non è servito a nulla.

Come posso risolvere?

Grazie!

Ritratto di michele-p
michele-p
(Guru)
Offline
Guru
Iscritto: 22/01/2007
Messaggi: 3268

...penso che occorra fornire qualche parametro particolare al modulo del kernel visto che la riga aggiuntiva che ti avevo detto di aggiungere non ha sortito alcun risultato. Prima di fare altri tentativi una curiosità; ma il mixer ha i valori dell'audio alzati oppure sono tutti a zero?....sempre nel mixer, l'interruttore IEC958 è attivo?...se si, prova a disattivarlo....

Bye 8-)

Ritratto di nicco
nicco
(Guru)
Offline
Guru
Iscritto: 02/04/2005
Messaggi: 1395

La voce model=xxxxx
ha un sacco di parametri diversi, che possono essere testati oltre ad "asus"
la cui lista puoi trovare sul sito stesso di alsa project, cercando la chiave model

Io ho avuto lo stesso problema con un Toshiba Satellite U200. e benche abbia provato una grande combinazione di parametri di model ed altri, non ne sono venuto a capo.

Bisogna sperare, o in qualche aggiornamente dell'attuale linea di kernel mandriva, con qualche fix, oppure nella nuova versione di alsa (la x17 e' in fase rc1):
il supporto dell'attuale alsa x16, al modulo intel ich7/ich8, e' alquanto bacato e lacunoso...

Appena sara disponibile il kernel 2.6.26 stabile, oppure una versione finale degli alsa x17, proveremo (MIB) a fare un kernel, che risolva, si spera...

Professional experience >>> Community Manager and System Admin: http://pianetalinux.org
Kernel designer, engineer, maintainer and tester for ROSA Desktop and OpenMandriva Lx O.S.
OpenMandriva 2014.0 x86_64 - OMV + Kernel Farm + MIB - Kernel-nrjQL-desktop-3.15.6

Ritratto di Matleyx
Matleyx
(Geek)
Offline
Geek
Iscritto: 06/04/2005
Messaggi: 110

Quote:

nicco ha scritto:

Bisogna sperare, o in qualche aggiornamente dell'attuale linea di kernel mandriva, con qualche fix, oppure nella nuova versione di alsa (la x17 e' in fase rc1):
il supporto dell'attuale alsa x16, al modulo intel ich7/ich8, e' alquanto bacato e lacunoso...

@nicco

Se può servire, con la 2007.1 l' ICH8 della mia scheda madre funzionava alla grande, compreso l'uscita audio digitale. Con la 2008 e 2008.1 non c'è stato verso, pensi che mettendo una vecchia versione di Alsa possa rifunzionare? Oppure è un fatto contingente di Alsa e kernel?
Se con una versione vecchia di Alsa secondo te potrebbe funzionare, sapresti indicarmi quale era la versione sulla 2007.1?

Grazie

Ciao

Notebook no.1: Sony Vaio Core i7, nvidia 330gm, 8 Gb Ram - S.o.: Windows 7 Professional 64
Notebook no.2: HP DV4 1050 el - Windows Vista ultimate 64 - Mdk 2010.2

Ritratto di densou
densou
(Junior)
Offline
Junior
Iscritto: 14/06/2008
Messaggi: 13

ma con Ubuntu non c'è stato modo di fare funzionare l'audio Sad

Mandriva l'ho trovato COSI' modulare che senza chissà quanta difficoltà (miracolo, non ci speravo più) son riuscito a fare funzionare l'audio.

Ho disinstallato Pulseaudio in parte (lasciando solo i 2 pacchetti "principali") e successivamente ho installato ALSA compreso il modulo per il kernel.

Questo però l'ho fatto con audio disabilitato da bios, ma è andata bene ! Smile

Piuttosto avrei da ridire sul pessimo supporto delle VGA integrate Intel ma è un'altra storia Sad

Ritratto di mlx82
mlx82
(Newbie)
Offline
Newbie
Iscritto: 10/06/2008
Messaggi: 3

Scusate se non ho più controllato questo post. Avevo messo le notifiche via mail, ma non mi sono arrivate.

Grazie a tutti per i suggerimenti.

Ho provato a disabilitare IEC958 (ce ne sono 2, quello con scritto Default PCI era abilitato), ma non è servito a nulla.

Onestamente non so più che pesci pigliare.. è piuttosco scocciante vedere che su pc nuovi (ma che comunque hanno già 3 o 4 mesi) non si riesce mai a far funzionare tutto. Anche la scheda video non è settata perfettamente (è un modello 9500 nvidia), ma quanto meno l'immagine la vedo. PEr l'audio niente da fare.

Speriamo che sti nuovi drivers arrivino.. prima o poi!