Installazione stampante canon

5 risposte [Ultimo messaggio]
Ritratto di Fabio75
Fabio75
(Guru)
Offline
Guru
Iscritto: 30/04/2007
Messaggi: 829

Mandriva 2009.1 64 bit

Sto cercando di installare sulla mia mandriva, una stampante canon ip2500

Se provo a utilizzare il tool presente in Mandriva, la stampante non funziona.
Questo mi accadeva anche con le versioni di Mandriva 2008.1 e 2009.

Utilizzo perciò i pacchetti forniti dal sito canon:
cnijfilter-common-2.70-3.i386.rpm
cnijfilter-ip2500series-2.70-1.i386.rpm

Il problema questa volta è la serie di dipendenze che non riesco a soddisfare neanche con pacchetti simili come accadeva per mandriva 2009:

Dipendenze fallite:
libgdk-1.2.so.0 necessario a cnijfilter-ip2500series-2.70-1.i386
libglib-1.2.so.0 necessario a cnijfilter-ip2500series-2.70-1.i386
libgmodule-1.2.so.0 necessario a cnijfilter-ip2500series-2.70-1.i386
libgtk-1.2.so.0 necessario a cnijfilter-ip2500series-2.70-1.i386
libxml.so.1 necessario a cnijfilter-ip2500series-2.70-1.i386

Se provo a forzare l'installazione senza controllare le dipendenze...non mi funziona.

Dovrei cercare in rete queste librerie e provare a installarle?
Qualcuno a soluzioni da proporre?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Alcune di quelle librerie sono presenti nel pacchetti libgtk+1.2 presente in Contrib ed in libglib1.2 in Main però se ricevi errori temo abbiano una versione incompatibile, non riesci a trovare i sorgenti da ricompilare??

Ciao Ciao, Morenp

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Fabio75
Fabio75
(Guru)
Offline
Guru
Iscritto: 30/04/2007
Messaggi: 829

I due pacchetti a cui ti riferisci sono già installati..per gli altri devo vedere..speriamo bene..

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Uno ad uno è da suicidio. Esegui questo script. scaricalo e dai da shell:

<br />sh UAO2009_32.sh<br />

poi disinstalla gli rpm canon che hai installato e reinstallali. Dopo di che ricordato di disabilitare i repository a 32 bit da drakconf nella sezione Media Source, altrimenti installi programmi a 32 bit senza accorgertene.

_/\/\/\Bemipefe/\/\/\_

Ritratto di Fabio75
Fabio75
(Guru)
Offline
Guru
Iscritto: 30/04/2007
Messaggi: 829

Grazie, finalmente ho risolto questo problema che mi sembrava insormontabile.

Una domanda:

Tra i repository di Mandriva 2009.1 64 bit
ci sono i main 32 bit.
Parecchi pacchetti per Mandriva 64 bit hanno bisogno di librerie presenti nei main 32 bit. ..

Cosa devo fare? Posso abilitare questo repository solo all'accorrenza o rischio di rovinare l'installazione per la presenza di pacchetti i586?

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Abilitali solo se hai necessita di installare pacchetti a 32 bit con dipendenze. Altrimenti tienili disabilitati. Se non tene accorgi va a finire che installi programmi a 32 bit invece che quelli a 64 bit.

Non hai alcun motivo per tenerli abilitati se non ti servono.

_/\/\/\Bemipefe/\/\/\_