Epson Stylus Dx4400

35 risposte [Ultimo messaggio]
Ritratto di mikymerol
mikymerol
(Junior)
Offline
Junior
Iscritto: 16/04/2009
Messaggi: 38

*Klick* Ciao allora io uso Mandriva 2009 Kde4 l'ultimo che c'è disponibile!!!Comunque ho digitato il comando nella konsole terminale ma non mi esce nulla!!!!

*Monster* Si ci sono andato in scanner e nella finestra dopo che ho fatto la ricerca scanner mi esce scritto:"The following scanner-Noname stk virtual device is available on your system."

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Allora il comando lsusb lo devi dare come root. Se si impalla la shell non ritornando il prompt (il cursore col #) e non esce niente allora hai problemi con le USB.

Invece di fare la scansione automatica, aggiungi manualmente lo scanner. Selezionando Epson ->Stylus Dx4200 che dovrebbe farti funzionare anche il tuo.
Oppure prova Epson ->Stylus Dx4800.

Facci sapere

_/\/\/\Bemipefe/\/\/\_

Ritratto di mikymerol
mikymerol
(Junior)
Offline
Junior
Iscritto: 16/04/2009
Messaggi: 38

Allora monster ho dato il comando lsusb dalla console e questo è il risultato del comando:

Bus 001 Device 004: ID 174f:a311
Bus 001 Device 001: ID 1d6b:0002
Bus 005 Device 001: ID 1d6b:0001
Bus 004 Device 002: ID 0b05:1712 ASUSTek Computer, Inc.
Bus 004 Device 001: ID 1d6b:0001
Bus 003 Device 001: ID 1d6b:0001
Bus 002 Device 002: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003
Bus 002 Device 001: ID 1d6b:0001

La console non si è ne bloccata ne nulla è andato tutto ok!!!!

P.s. Quando configuro manualmente lo scanner dopo aver scelto epson dx4200 mi chiede di scrivere il nome del dispositivo a cui è collegata la epson con un menù a tendina sotto!!!Cosa ci devo mettere lì?

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Quote:

Allora monster...

Sono due volte che mi chiami monster ma ...Il nick è quello sopra ossia "Bemipefe". Big Grin

Prova a non inserire nulla ossia fagli fare l'autodetect. Se non funziona prova ad inserire "libusb:001:001".

_/\/\/\Bemipefe/\/\/\_

Ritratto di mikymerol
mikymerol
(Junior)
Offline
Junior
Iscritto: 16/04/2009
Messaggi: 38

Scusami per il tuo nick Smile comunque ho provato in tutti e due i modi ma niente da fare!!!!!!

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Gia provato a riavviare ?
Di libusb ne avrai credo piu di uno ....provali tutti.

Dammi l'output del comando ls /dev/* e dmesg | grep -n10 usb

Comunque dall'output di lsusb sembra che non ci siano altri dispositivi oltre che a questi due:

<br />Bus 004 Device 002: ID 0b05:1712 ASUSTek Computer, Inc.<br />Bus 002 Device 002: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003<br />

Il primo deve essere il dispositivo bluetooth il secondo è il mouse. E lo scanner ?

Vediamo anche lspci

_/\/\/\Bemipefe/\/\/\_

Ritratto di mikymerol
mikymerol
(Junior)
Offline
Junior
Iscritto: 16/04/2009
Messaggi: 38

s /dev/* :

/dev/audio /dev/psaux /dev/systty /dev/tty47 /dev/usbdev3.2_ep00
/dev/cdrom@ /dev/ptmx /dev/tty /dev/tty48 /dev/usbdev3.2_ep01
/dev/cdrw@ /dev/ram@ /dev/tty0 /dev/tty49 /dev/usbdev3.2_ep02
/dev/console /dev/ram0 /dev/tty1 /dev/tty5 /dev/usbdev3.2_ep81
/dev/core@ /dev/ram1 /dev/tty10 /dev/tty50 /dev/usbdev3.2_ep82
/dev/cpu_dma_latency /dev/ram10 /dev/tty11 /dev/tty51 /dev/usbdev4.1
/dev/dsp /dev/ram11 /dev/tty12 /dev/tty52 /dev/usbdev4.1_ep00
/dev/dvd@ /dev/ram12 /dev/tty13 /dev/tty53 /dev/usbdev4.1_ep81
/dev/dvdrw@ /dev/ram13 /dev/tty14 /dev/tty54 /dev/usbdev4.2
/dev/fb@ /dev/ram14 /dev/tty15 /dev/tty55 /dev/usbdev4.2_ep00
/dev/fb0 /dev/ram15 /dev/tty16 /dev/tty56 /dev/usbdev4.2_ep02
/dev/fd@ /dev/ram2 /dev/tty17 /dev/tty57 /dev/usbdev4.2_ep03
/dev/fd0 /dev/ram3 /dev/tty18 /dev/tty58 /dev/usbdev4.2_ep81
/dev/fd1 /dev/ram4 /dev/tty19 /dev/tty59 /dev/usbdev4.2_ep82
/dev/full /dev/ram5 /dev/tty2 /dev/tty6 /dev/usbdev4.2_ep83
/dev/hidraw0 /dev/ram6 /dev/tty20 /dev/tty60 /dev/usbdev5.1
/dev/hpet /dev/ram7 /dev/tty21 /dev/tty61 /dev/usbdev5.1_ep00
/dev/initctl| /dev/ram8 /dev/tty22 /dev/tty62 /dev/usbdev5.1_ep81
/dev/kmem /dev/ram9 /dev/tty23 /dev/tty63 /dev/usblp0@
/dev/kmsg /dev/ramdisk@ /dev/tty24 /dev/tty7 /dev/vcs
/dev/log= /dev/random /dev/tty25 /dev/tty8 /dev/vcs1
/dev/loop0 /dev/raw1394 /dev/tty26 /dev/tty9 /dev/vcs12
/dev/loop1 /dev/rawctl /dev/tty27 /dev/ttyS0 /dev/vcs2
/dev/loop2 /dev/root /dev/tty28 /dev/ttyS1 /dev/vcs3
/dev/loop3 /dev/rtc@ /dev/tty29 /dev/ttyS2 /dev/vcs4
/dev/loop4 /dev/rtc0 /dev/tty3 /dev/ttyS3 /dev/vcs5
/dev/loop5 /dev/scd0@ /dev/tty30 /dev/urandom /dev/vcs6
/dev/loop6 /dev/sda /dev/tty31 /dev/usbdev1.1 /dev/vcs7
/dev/loop7 /dev/sda1 /dev/tty32 /dev/usbdev1.1_ep00 /dev/vcsa
/dev/lp0 /dev/sda2 /dev/tty33 /dev/usbdev1.1_ep81 /dev/vcsa1
/dev/mem /dev/sda5 /dev/tty34 /dev/usbdev1.4 /dev/vcsa12
/dev/mixer /dev/sda6 /dev/tty35 /dev/usbdev1.4_ep00 /dev/vcsa2
/dev/mouse@ /dev/sequencer /dev/tty36 /dev/usbdev1.4_ep81 /dev/vcsa3
/dev/network_latency /dev/sequencer2 /dev/tty37 /dev/usbdev1.4_ep82 /dev/vcsa4
/dev/network_throughput /dev/sg0 /dev/tty38 /dev/usbdev2.1 /dev/vcsa5
/dev/null /dev/sg1 /dev/tty39 /dev/usbdev2.1_ep00 /dev/vcsa6
/dev/nvidia0 /dev/snapshot /dev/tty4 /dev/usbdev2.1_ep81 /dev/vcsa7
/dev/nvidiactl /dev/sr0 /dev/tty40 /dev/usbdev2.2 /dev/video@
/dev/nvram /dev/sr1 /dev/tty41 /dev/usbdev2.2_ep00 /dev/video0
/dev/oldmem /dev/st0 /dev/tty42 /dev/usbdev2.2_ep81 /dev/watchdog
/dev/par0@ /dev/st1 /dev/tty43 /dev/usbdev3.1 /dev/XOR@
/dev/parport0 /dev/stderr@ /dev/tty44 /dev/usbdev3.1_ep00 /dev/zero
/dev/port /dev/stdin@ /dev/tty45 /dev/usbdev3.1_ep81
/dev/ppp /dev/stdout@ /dev/tty46 /dev/usbdev3.2

/dev/bsg:
0:0:0:0 1:0:0:0

/dev/bus:
usb/

/dev/cpu:
0/

/dev/disk:
by-id/ by-path/ by-uuid/

/dev/dri:
card0

/dev/input:
by-id/ event0 event2 event4 event6 event8 mice mouse1
by-path/ event1 event3 event5 event7 event9 mouse0

/dev/mapper:
control

/dev/net:
tun

/dev/pktcdvd:
control

/dev/pts:
0 1

/dev/shm:
pulse-shm-3922114267

/dev/snd:
controlC0 hwC0D0 hwC0D1 pcmC0D0c pcmC0D0p pcmC0D6c pcmC0D6p seq timer

/dev/usb:
lp0

/dev/v4l:
by-path/

dmesg | grep -n10 usb :

395-serio: i8042 AUX3 port at 0x60,0x64 irq 12
396-mice: PS/2 mouse device common for all mice
397-input: AT Translated Set 2 keyboard as /class/input/input0
398-cpuidle: using governor ladder
399-cpuidle: using governor menu
400-TCP cubic registered
401-Using IPI No-Shortcut mode
402-registered taskstats version 1
403-BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
404-Freeing unused kernel memory: 364k freed
405:usbcore: registered new interface driver usbfs
406:usbcore: registered new interface driver hub
407:usbcore: registered new device driver usb
408-ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
409-ehci_hcd 0000:00:1d.7: setting latency timer to 64
410-ehci_hcd 0000:00:1d.7: EHCI Host Controller
411-ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
412-ehci_hcd 0000:00:1d.7: debug port 1
413-ehci_hcd 0000:00:1d.7: cache line size of 32 is not supported
414-ehci_hcd 0000:00:1d.7: irq 23, io mem 0xfebfbc00
415-ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
416:usb usb1: configuration #1 chosen from 1 choice
417-hub 1-0:1.0: USB hub found
418-hub 1-0:1.0: 8 ports detected
419:usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
420:usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
421:usb usb1: Product: EHCI Host Controller
422:usb usb1: Manufacturer: Linux 2.6.27.19-desktop586-1mnb ehci_hcd
423:usb usb1: SerialNumber: 0000:00:1d.7
424-ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
425-USB Universal Host Controller Interface driver v3.0
426-uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
427-uhci_hcd 0000:00:1d.0: setting latency timer to 64
428-uhci_hcd 0000:00:1d.0: UHCI Host Controller
429-uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
430-uhci_hcd 0000:00:1d.0: irq 23, io base 0x0000ec00
431:usb usb2: configuration #1 chosen from 1 choice
432-hub 2-0:1.0: USB hub found
433-hub 2-0:1.0: 2 ports detected
434-Synaptics Touchpad, model: 1, fw: 6.1, id: 0xa3a0b3, caps: 0xa04713/0x10008
435-input: SynPS/2 Synaptics TouchPad as /class/input/input1
436:usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
437:usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
438:usb usb2: Product: UHCI Host Controller
439:usb usb2: Manufacturer: Linux 2.6.27.19-desktop586-1mnb uhci_hcd
440:usb usb2: SerialNumber: 0000:00:1d.0
441-uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 20 (level, low) -> IRQ 20
442-uhci_hcd 0000:00:1d.1: setting latency timer to 64
443-uhci_hcd 0000:00:1d.1: UHCI Host Controller
444-uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
445-uhci_hcd 0000:00:1d.1: irq 20, io base 0x0000e880
446:usb usb3: configuration #1 chosen from 1 choice
447-hub 3-0:1.0: USB hub found
448-hub 3-0:1.0: 2 ports detected
449:usb 1-6: new high speed USB device using ehci_hcd and address 4
450:usb 1-6: configuration #1 chosen from 1 choice
451:usb 1-6: New USB device found, idVendor=174f, idProduct=a311
452:usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
453:usb 1-6: Product: USB2.0
454:usb 1-6: Manufacturer: Syntek
455:usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
456:usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
457:usb usb3: Product: UHCI Host Controller
458:usb usb3: Manufacturer: Linux 2.6.27.19-desktop586-1mnb uhci_hcd
459:usb usb3: SerialNumber: 0000:00:1d.1
460-uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 22 (level, low) -> IRQ 22
461-uhci_hcd 0000:00:1d.2: setting latency timer to 64
462-uhci_hcd 0000:00:1d.2: UHCI Host Controller
463-uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
464-uhci_hcd 0000:00:1d.2: irq 22, io base 0x0000e800
465:usb usb4: configuration #1 chosen from 1 choice
466-hub 4-0:1.0: USB hub found
467-hub 4-0:1.0: 2 ports detected
468:usb 2-1: new low speed USB device using uhci_hcd and address 2
469:usb 2-1: configuration #1 chosen from 1 choice
470:usb 2-1: New USB device found, idVendor=05e3, idProduct=1205
471:usb 2-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
472:usb 2-1: Product: USB Mouse
473:usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
474:usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
475:usb usb4: Product: UHCI Host Controller
476:usb usb4: Manufacturer: Linux 2.6.27.19-desktop586-1mnb uhci_hcd
477:usb usb4: SerialNumber: 0000:00:1d.2
478-uhci_hcd 0000:00:1d.3: PCI INT D -> GSI 18 (level, low) -> IRQ 18
479-uhci_hcd 0000:00:1d.3: setting latency timer to 64
480-uhci_hcd 0000:00:1d.3: UHCI Host Controller
481-uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
482-uhci_hcd 0000:00:1d.3: irq 18, io base 0x0000e480
483:usb usb5: configuration #1 chosen from 1 choice
484-hub 5-0:1.0: USB hub found
485-hub 5-0:1.0: 2 ports detected
486:usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
487:usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
488:usb usb5: Product: UHCI Host Controller
489:usb usb5: Manufacturer: Linux 2.6.27.19-desktop586-1mnb uhci_hcd
490:usb usb5: SerialNumber: 0000:00:1d.3
491:usb 4-1: new full speed USB device using uhci_hcd and address 2
492-SCSI subsystem initialized
493-Driver 'sd' needs updating - please use bus_type methods
494-No dock devices found.
495:usb 4-1: configuration #1 chosen from 1 choice
496:usb 4-1: New USB device found, idVendor=0b05, idProduct=1712
497:usb 4-1: New USB device strings: Mfr=0, Product=0, SerialNumber=3
498:usb 4-1: SerialNumber: 0194E8-5B-0002
499-libata version 3.00 loaded.
500-ata_piix 0000:00:1f.2: version 2.12
501-ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
502-ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
503-ata_piix 0000:00:1f.2: setting latency timer to 64
504-scsi0 : ata_piix
505-scsi1 : ata_piix
506-ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
507-ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
508-ata1.00: ATA-7: ST9100828AS, 3.ALA, max UDMA/133
--
555-ACPI: Processor [CPU2] (supports 8 throttling states)
556-input: Power Button (FF) as /class/input/input3
557-Marking TSC unstable due to TSC halts in idle
558-ACPI: Power Button (FF) [PWRF]
559-input: Lid Switch as /class/input/input4
560-ACPI: Lid Switch [LID]
561-input: Power Button (CM) as /class/input/input5
562-ACPI: Power Button (CM) [PWRB]
563-input: Sleep Button (CM) as /class/input/input6
564-Bluetooth: Generic Bluetooth USB driver ver 0.3
565:usbcore: registered new interface driver btusb
566-sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
567-Uniform CD-ROM driver Revision: 3.20
568-sr 1:0:0:0: Attached scsi CD-ROM sr0
569-ACPI: Sleep Button (CM) [SLPB]
570:usbcore: registered new interface driver hiddev
571-ACPI: Transitioning device [FN00] to D3
572-fan PNP0C0B:00: registered as cooling_device3
573-ACPI: Fan [FN00] (off)
574-input: USB Mouse as /class/input/input7
575:input,hidraw0: USB HID v1.10 Mouse [USB Mouse ] on usb-0000:00:1d.0-1
576:usbcore: registered new interface driver usbhid
577:usbhid: v2.6:USB HID core driver
578-r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
579-r8169 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
580-r8169 0000:02:00.0: setting latency timer to 64
581-r8169 0000:02:00.0: no MSI. Back to INTx.
582-eth0: RTL8168b/8111b at 0xf8b3c000, 00:18:f3:f8:6c:fd, XID 38000000 IRQ 16
583-thermal LNXTHERM:01: registered as thermal_zone0
584-ACPI: Thermal Zone [THRM] (34 C)
585-ACPI: AC Adapter [AC0] (on-line)
586-asus-laptop: Asus Laptop Support version 0.42
587-asus-laptop: A6Je model detected
588-input: Asus Extra Buttons as /class/input/input8
589-Registered led device: asus::mail
590-Linux video capture interface: v2.00
591-Linux agpgart interface v0.103
592-stkwebcam: Syntek USB2.0 Camera is now controlling video device /dev/video0
593:usbcore: registered new interface driver stkwebcam
594-stk11xx: Syntek USB2.0 webcam driver startup
595:usbcore: registered new interface driver stk11xx
596-stk11xx: v1.3.1 : Syntek USB Video Camera
597-input: PC Speaker as /class/input/input9
598-iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
599-iwl3945: Copyright(c) 2003-2008 Intel Corporation
600-iwl3945 0000:03:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
601-iwl3945 0000:03:00.0: setting latency timer to 64
602-iwl3945: Detected Intel Wireless WiFi Link 3945ABG
603-iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
604-phy0: Selected rate control algorithm 'iwl-3945-rs'
605-iTCO_vendor_support: vendor-support=0
--
662-[fglrx] ioport: bar 1, base 0xb000, size: 0x100
663-pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
664-pci 0000:01:00.0: setting latency timer to 64
665-[fglrx] Pat entry 2 is already configured
666-[fglrx] PAT is enabled successfully!
667-[fglrx] module loaded - fglrx 8.52.3 [Aug 1 2008] with 1 minors
668-[fglrx] Reserved FB block: Shared offset:0, size:1000000
669-[fglrx] Reserved FB block: Unshared offset:7fbb000, size:40000
670-[fglrx] Reserved FB block: Unshared offset:7ffb000, size:5000
671-NET: Registered protocol family 17
672:usbcore: registered new interface driver usblp
673-ip_tables: (C) 2000-2006 Netfilter Core Team
674-Netfilter messages via NETLINK v0.30.
675-nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
676-CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Plase use
677-nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
678-sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
679-eth0: no IPv6 routers present
680-ctnetlink v0.93: registering with nfnetlink.
681-ClusterIP Version 0.8 loaded successfully
682-ip6_tables: (C) 2000-2006 Netfilter Core Team
--
1202-ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
1203-ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
1204- cdb 1e 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
1205- res 40/00:02:00:08:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
1206-ata2.00: status: { DRDY }
1207-ata2: link is slow to respond, please be patient (ready=0)
1208-ata2: device not ready (errno=-16), forcing hardreset
1209-ata2: soft resetting link
1210-ata2.00: configured for PIO4
1211-ata2: EH complete
1212:usb 3-2: new full speed USB device using uhci_hcd and address 2
1213:usb 3-2: configuration #1 chosen from 1 choice
1214:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1215:usb 3-2: New USB device found, idVendor=04b8, idProduct=083f
1216:usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
1217:usb 3-2: Product: USB1.1 MFP(Full-Speed)
1218:usb 3-2: Manufacturer: EPSON
1219:usb 3-2: SerialNumber: B00020708050436034
1220:usblp0: removed
1221:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1222-ppdev: user-space parallel port driver
1223-ppdev0: no associated port!
1224:usblp0: removed
1225:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1226-ppdev0: no associated port!
1227:usblp0: removed
1228:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1229-ppdev0: no associated port!
1230:usblp0: removed
1231:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1232-ppdev0: no associated port!
1233:usblp0: removed
1234:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1235-ppdev0: no associated port!
1236:usblp0: removed
1237:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1238-ppdev0: no associated port!
1239-ata2.00: qc timeout (cmd 0xa0)
1240-ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
1241-ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
1242- cdb 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
1243- res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x5 (timeout)
1244-ata2.00: status: { DRDY ERR }
1245:usblp0: removed
1246:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1247-ppdev0: no associated port!
1248-ata2: link is slow to respond, please be patient (ready=0)
1249-ata2: device not ready (errno=-16), forcing hardreset
1250-ata2: soft resetting link
1251-ata2.00: configured for PIO4
1252-ata2: EH complete
1253:usblp0: removed
1254:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1255-ppdev0: no associated port!
1256:usblp0: removed
1257:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1258-ppdev0: no associated port!
1259:usblp0: removed
1260:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1261-ppdev0: no associated port!
1262:usblp0: removed
1263:usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04B8 pid 0x083F
1264-ppdev0: no associated port!
1265-ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
1266-ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
1267- cdb 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
1268- res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
1269-ata2.00: status: { DRDY }
1270-ata2: link is slow to respond, please be patient (ready=0)
1271-ata2: device not ready (errno=-16), forcing hardreset
1272-ata2: soft resetting link
1273-ata2.00: configured for PIO4

lspci :

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon Mobility X1450]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
04:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
04:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
04:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
04:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)

ECCOTI TUTTO.......!!!!!!!!!!

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Dai dati che mi hai fornito deduco semplicemente che la stampante viene rivelata. Infatti è presente il dispositivo /dev/usblp0 e infatti ti dovrebbe anche stampare.

echo "CIAO!" > /dev/usblp0

Dovrebbe stampare ciao sul foglio. Il problema con lo scanner e che non viene rilevato. Proviamo innanzi tutto a vedere perchè. Dai da shell:

<br />sane-find-scanner -v<br />

_/\/\/\Bemipefe/\/\/\_

Ritratto di mikymerol
mikymerol
(Junior)
Offline
Junior
Iscritto: 16/04/2009
Messaggi: 38

Questo è il risultato del comando sane-find-scanner -v :

merola@localhost ~]$ sane-find-scanner -v
This is sane-find-scanner from sane-backends 1.0.19

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

searching for SCSI scanners:
checking /dev/scanner... failed to open (Invalid argument)
checking /dev/sg0... failed to open (Invalid argument)
checking /dev/sg1... failed to open (Invalid argument)
checking /dev/sg2... failed to open (Invalid argument)
checking /dev/sg3... failed to open (Invalid argument)
checking /dev/sg4... failed to open (Invalid argument)
checking /dev/sg5... failed to open (Invalid argument)
checking /dev/sg6... failed to open (Invalid argument)
checking /dev/sg7... failed to open (Invalid argument)
checking /dev/sg8... failed to open (Invalid argument)
checking /dev/sg9... failed to open (Invalid argument)
checking /dev/sga... failed to open (Invalid argument)
checking /dev/sgb... failed to open (Invalid argument)
checking /dev/sgc... failed to open (Invalid argument)
checking /dev/sgd... failed to open (Invalid argument)
checking /dev/sge... failed to open (Invalid argument)
checking /dev/sgf... failed to open (Invalid argument)
checking /dev/sgg... failed to open (Invalid argument)
checking /dev/sgh... failed to open (Invalid argument)
checking /dev/sgi... failed to open (Invalid argument)
checking /dev/sgj... failed to open (Invalid argument)
checking /dev/sgk... failed to open (Invalid argument)
checking /dev/sgl... failed to open (Invalid argument)
checking /dev/sgm... failed to open (Invalid argument)
checking /dev/sgn... failed to open (Invalid argument)
checking /dev/sgo... failed to open (Invalid argument)
checking /dev/sgp... failed to open (Invalid argument)
checking /dev/sgq... failed to open (Invalid argument)
checking /dev/sgr... failed to open (Invalid argument)
checking /dev/sgs... failed to open (Invalid argument)
checking /dev/sgt... failed to open (Invalid argument)
checking /dev/sgu... failed to open (Invalid argument)
checking /dev/sgv... failed to open (Invalid argument)
checking /dev/sgw... failed to open (Invalid argument)
checking /dev/sgx... failed to open (Invalid argument)
checking /dev/sgy... failed to open (Invalid argument)
checking /dev/sgz... failed to open (Invalid argument)
# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

searching for USB scanners:
checking /dev/usb/scanner... failed to open (Invalid argument)
checking /dev/usb/scanner0... failed to open (Invalid argument)
checking /dev/usb/scanner1... failed to open (Invalid argument)
checking /dev/usb/scanner2... failed to open (Invalid argument)
checking /dev/usb/scanner3... failed to open (Invalid argument)
checking /dev/usb/scanner4... failed to open (Invalid argument)
checking /dev/usb/scanner5... failed to open (Invalid argument)
checking /dev/usb/scanner5... failed to open (Invalid argument)
checking /dev/usb/scanner7... failed to open (Invalid argument)
checking /dev/usb/scanner8... failed to open (Invalid argument)
checking /dev/usb/scanner9... failed to open (Invalid argument)
checking /dev/usb/scanner10... failed to open (Invalid argument)
checking /dev/usb/scanner11... failed to open (Invalid argument)
checking /dev/usb/scanner12... failed to open (Invalid argument)
checking /dev/usb/scanner13... failed to open (Invalid argument)
checking /dev/usb/scanner14... failed to open (Invalid argument)
checking /dev/usb/scanner15... failed to open (Invalid argument)
checking /dev/usbscanner... failed to open (Invalid argument)
checking /dev/usbscanner0... failed to open (Invalid argument)
checking /dev/usbscanner1... failed to open (Invalid argument)
checking /dev/usbscanner2... failed to open (Invalid argument)
checking /dev/usbscanner3... failed to open (Invalid argument)
checking /dev/usbscanner4... failed to open (Invalid argument)
checking /dev/usbscanner5... failed to open (Invalid argument)
checking /dev/usbscanner6... failed to open (Invalid argument)
checking /dev/usbscanner7... failed to open (Invalid argument)
checking /dev/usbscanner8... failed to open (Invalid argument)
checking /dev/usbscanner9... failed to open (Invalid argument)
checking /dev/usbscanner10... failed to open (Invalid argument)
checking /dev/usbscanner11... failed to open (Invalid argument)
checking /dev/usbscanner12... failed to open (Invalid argument)
checking /dev/usbscanner13... failed to open (Invalid argument)
checking /dev/usbscanner14... failed to open (Invalid argument)
checking /dev/usbscanner15... failed to open (Invalid argument)
found USB scanner (vendor=0x174f [Syntek ], product=0xa311 [USB2.0 ]) at libusb:001:004
found USB scanner (vendor=0x04b8 [Language Error], product=0x083f [Language Error]) at libusb:003:002
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.
done

Ritratto di Bemipefe
Bemipefe
(Guru)
Offline
Guru
Iscritto: 07/07/2005
Messaggi: 1125

Dai questi comandi da root:

<br />cd /etc/udev/rules.d/<br />find *libsane.rules | xargs sudo kate<br />

Ti dovrebbe aprire l'editor di testo "Kate" del file che contiene le regole di libsane. Proviamo ad aggiungere alla fine della lista il tuo scanner. Prima della riga :

Quote:

# The following rule will disable USB autosuspend for the device

Copia e incolla quanto segue:
<br /># EPSON Stylus DX4400<br />SYSFS{idVendor}==&quot;04b8&quot;, SYSFS{idProduct}==&quot;083f&quot;, MODE=&quot;0664&quot;, RUN+=&quot;libusbscanner&quot;, ENV{libsane_matched}=&quot;yes&quot;<br />

Poi ridai il comando sane-find-scanner -v e proviamo a scannerizzare con scanimage -L e poi xsane

_/\/\/\Bemipefe/\/\/\_