Driver ATI 8.5 e Mandriva 2008.1

5 risposte [Ultimo messaggio]
Ritratto di serginer
serginer
(Junior)
Offline
Junior
Iscritto: 12/06/2008
Messaggi: 14

Ciao a tutti!
Esiste una soluzione definitiva a questi benedetti drive ati per far funzionare il 3D oppure è meglio cambiare scheda video?
Mi spiego meglio...
Se scelgo il driver nativo Ati x1300 mandriva dopo un po và in crash!
Insomma ho un sacco di problemi,dal monitor che và fuori frequenza e non si vede più nulla al blocco completo del computer dove rimane solo il riavvio.
Ho provato a installare i driver ati 8.5 del sito ati ma non cambia nulla,peccato perchè il compiz era assai divertente.
Ora sto usando i driver Xgorvesa e sono gli unici che non mi creano problemi.
Non c'è una soluzione al problema di cui si è discusso?
Oppure,senza troppi smanettamenti non posso utilizzare un driver xorg diverso che mi fà funzionare anche il 3d?
Grazie.

Ritratto di johnthejocker
johnthejocker
(Guru)
Offline
Guru
Iscritto: 05/11/2006
Messaggi: 550

Big Grin:D

Guarda, 'sti driver sono una piaga!!!
Più avanti si va peggio mi sembra che vada!!!
Almeno tu puoi cambiare la scheda. Io ho una x200m installata sul portatile che è una vera ciofeca visto che i nuovi driver sembrano non supportarla per niente.
Ho anche tentato la via dell'installazione manuale di una vecchia versione che pareva funzionare, ma sembra una strada senza uscita. I driver non compilano e non sono riuscito a capire perchè, e nessuno mi ha potuto aiutare in tal senso... adesso vado con i driver open 'ati'

Sono in attesa di tempi migliori, ma da come va la cosa non saprei dire quando questi arriveranno!!!!

Ciao

Desktop: HP m9180.it - Mandriva 2010.1 - Windows Vista HP - e altro... XD
Portatile: Packard Bell W3420 - Mandriva 2010.1 Cooker - Windows XP HE
PC Server Casalingo: Mandriva 2008

Ritratto di serginer
serginer
(Junior)
Offline
Junior
Iscritto: 12/06/2008
Messaggi: 14

Stiamo a posto allora!
Almeno io se mi rompo posso cambiare totalmente scheda e passare a nvidia,anche se francamente non mi piace l'idea di spendere nuovi soldi.
Comunque ragà se qualche guru quì dentro può indicare un driver alternativo per far funzionare una ati x1300...
Domanda:come mai compiz non funziona se si seleziona il driver xorgati oppure xorgvesa??
Grazie.

Ritratto di kurtz77
kurtz77
(Guru)
Offline
Guru
Iscritto: 30/10/2004
Messaggi: 2486

Quote:

Domanda:come mai compiz non funziona se si seleziona il driver xorgati oppure xorgvesa??

Perchè non supportano l'accelerazione 3D. Il vantaggio dei driver proprietari sarebbe tutto lì, se funzionassero, ma Ati non s'è mai degnata di fornire un supporto decente al suo hardware.
Adesso AMD (proprietaria di ATI) ha aperto le specifiche dei suoi prodotti e la comunità sta cercando di rilasciare driver open source completi, vediamo un po' cosa ne viene fuori.

Ciao

kurtz77 8-)
blog: la linea d'ombra

Ritratto di SebastianQ
SebastianQ
(Junior)
Offline
Junior
Iscritto: 15/06/2008
Messaggi: 14

Quote:

johnthejocker ha scritto:
Big Grin:D

Guarda, 'sti driver sono una piaga!!!
Più avanti si va peggio mi sembra che vada!!!
Almeno tu puoi cambiare la scheda. Io ho una x200m installata sul portatile che è una vera ciofeca visto che i nuovi driver sembrano non supportarla per niente.
Ho anche tentato la via dell'installazione manuale di una vecchia versione che pareva funzionare, ma sembra una strada senza uscita. I driver non compilano e non sono riuscito a capire perchè, e nessuno mi ha potuto aiutare in tal senso... adesso vado con i driver open 'ati'

Sono in attesa di tempi migliori, ma da come va la cosa non saprei dire quando questi arriveranno!!!!

Ciao

Quoto intutto e per tutto! Oltretutto mi sembra che sulla vecchia Mandriva 2007 Spring Compiz mi andasse benone, con gli aggiornamenti dei driver video l'ho dovuto disattivare.. Mah, speriamo che Ati si decida prima o poi!

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

i driver rilasciati da ati stanno andando nella giusta direzione. i driver open stanno andando ancora meglio ora che arrivano le specifiche per scriverli.

i driver video sono molto delicati, a me è successo di non riuscire a installarli con l'ultimo aggiornamento del kernel allora sono tornato al kernel precedente.

quindi consiglio di verificare l'ambiente per la preparazione dei moduli e di completare l'installazione con aticonfig --initial -f ed eventualmente sistemare xorg.conf manualmente