ati radeon e nuovo utente

31 risposte [Ultimo messaggio]
Ritratto di sbabbaro
sbabbaro
(Junior)
Offline
Junior
Iscritto: 22/04/2008
Messaggi: 12

ho controllato nei repo...non ho settato i testing quindi non dovrebbero essere aggiunti alle fonti dalle quale scaricare pacchetti o aggiornare il sistema

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Hops mi era saltato il post.

Dunque non ti voile installare i driver perché sono già installati, ora la domanda è quando li hai installati ??

Non ho idea se la tua scheda sia correttamente gestita da questi driver quanti anni ha ??

[postedit]
Temo che siano Dolori!!
Andando sul sito della ATI http://ati.amd.com/support/driver.html e selezionando i driver della 9250 mi dice di scaricare la versione 8.28.8 del lontanissimo 2006
http://ati.amd.com/support/drivers/linux/linux-radeon-prer200.html
quindi temo che i driver recenti diano grossi problemi con questa scheda.
[/postedit]

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di sbabbaro
sbabbaro
(Junior)
Offline
Junior
Iscritto: 22/04/2008
Messaggi: 12

la scheda video è abbastanza vecchiotta ma ha sempre lavorato bene....voglio dire...lavorava bene con winzozz..immagino col pinguino possa fare lo stesso...per capirci,mi scatta anche quando scorro le pagine web con firefox.... Thinking
io non ho installato nessun driver è questo il problema,mandriva dopo l installazione mi ha riconosciuto automaticamente i driver e non ho dovuto installare nulla...pero mi sono accorto che andava a scatti....quindi immagino che i driver non vadano bene...il guaio è che non so come fare e gestire cosi il mio pc è snervante....mi rode che scorrendo o aggiornando le pagine web o le varie finestre , scatti tutto...
cosa mi consigliate di fare?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Purtroppo queste cose non dipendono da Linux ma da ATI/AMD, i driver da loro rilasciati sono Closed Source e quindi solo loro possono metterci dentro le mani.
Se i nuovi driver da loro rilasciati non sono compatibili con la tua scheda non c'è nulla da fare, l'unica soluzione sarebbe installare una vecchia versione di Mandriva probabilmente una 2007.0 ed allora avresti la scheda funzionante con i limiti ovviamente che aveva la 2007.0.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

con quella scheda video ti conviene usare i driver opensource, verifica di avere il pacchetto x11-driver-video-ati e di avere un pezzo del file xorg.conf

Section &quot;Device&quot;<br />    Identifier &quot;device1&quot;<br />    VendorName &quot;ATI Technologies Inc&quot;<br />    BoardName &quot;ATI Radeon 9500 to Radeon X1050&quot;<br />    Driver &quot;ati&quot;<br />    Option &quot;DPMS&quot;<br />    Option &quot;XaaNoOffscreenPixmaps&quot; &quot;1&quot;<br />EndSection

ovviamente il boardname sarà diverso

e poi se mancasse aggiungi

Section &quot;DRI&quot;<br />        Mode 0666<br />EndSection<br />        <br />Section &quot;Extensions&quot;<br />        Option &quot;Composite&quot; &quot;Enable&quot;<br />EndSection

se è agp 8x puoi aggiungere per migliorare le performance

Option          &quot;AGPMode&quot;       &quot;8&quot;

in section device (vedi sopra)

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

con quella scheda video ti conviene usare i driver opensource, verifica di avere il pacchetto x11-driver-video-ati e di avere un pezzo del file xorg.conf

Section &quot;Device&quot;<br />    Identifier &quot;device1&quot;<br />    VendorName &quot;ATI Technologies Inc&quot;<br />    BoardName &quot;ATI Radeon 9500 to Radeon X1050&quot;<br />    Driver &quot;ati&quot;<br />    Option &quot;DPMS&quot;<br />    Option &quot;XaaNoOffscreenPixmaps&quot; &quot;1&quot;<br />EndSection

ovviamente il boardname sarà diverso

e poi se mancasse aggiungi

Section &quot;DRI&quot;<br />        Mode 0666<br />EndSection<br />        <br />Section &quot;Extensions&quot;<br />        Option &quot;Composite&quot; &quot;Enable&quot;<br />EndSection

se è agp 8x puoi aggiungere per migliorare le performance

Option          &quot;AGPMode&quot;       &quot;8&quot;

in section device (vedi sopra)

Ritratto di sbabbaro
sbabbaro
(Junior)
Offline
Junior
Iscritto: 22/04/2008
Messaggi: 12

ok ho aggiunto le stringhe che mi avevate consigliato....ma non è cambiato un tubo
prima di abbandonarmi alla rassegnazione/disperazione vorrei chiedervi come faccio a vedere se ho installato il pacchetto
x11-driver-video-ati
come faccio?

Ritratto di maurelio79
maurelio79
(Guru)
Offline
Guru
Iscritto: 19/05/2006
Messaggi: 2074

Ti ricordo quando ti ho detto di scrivere

rpm -qa | grep ati

con quel comando vedi tutti i pacchetti installati in cui è presente la parolo ati.

Il tuo output è stato:

Quote:

migration-assistant-0.6.0-2mdv2008.1 libkdecorations4-4.0.3-1mdv2008.1
mandriva-kde-translation-2008.1-0.2mdv2008.1
fonts-ttf-decoratives-1.3-19mdv2008.1
fonts-ttf-liberation-1.0-1mdv2008.1
dash-static-0.5.4-7mdv2008.1
foomatic-filters-3.0.2-1.20071218.1mdv2008.1
notification-daemon-0.3.7-3mdv2008.1
foomatic-db-hpijs-20070820-3mdv2008.1
update-alternatives-1.9.0-2mdv2008.1
foomatic-db-3.0.2-1.20071218.1mdv2008.1
foomatic-db-engine-3.0.2-1.20071218.2mdv2008.1
x11-driver-video-ati-6.8.0-1mdv2008.1
libstartup-notification-1_0-0.9-6mdv2008.1
gutenprint-foomatic-5.0.2-4mdv2008.1

come vedi li hai installati.

Per sicurezza scrivi in una shell

cat /etc/X11/xorg.conf

e incolla qui il risultato.

Debian Squeeze+Mandriva2009 on Asus X59SLseries
http://www.mylinuxexperience.org/

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

$su
password

#rpm -qa | grep x11-driver-video-ati

dovresti avere una risposta dal terminale con la parte che cerchi in rosso

dopo le modifiche hai fatto un logout/login o uno switch init3/init5?

Ritratto di sbabbaro
sbabbaro
(Junior)
Offline
Junior
Iscritto: 22/04/2008
Messaggi: 12

allora,questo è il risultato della shell dopo il comando

migration-assistant-0.6.0-2mdv2008.1
libkdecorations4-4.0.3-1mdv2008.1
mandriva-kde-translation-2008.1-0.2mdv2008.1
fonts-ttf-decoratives-1.3-19mdv2008.1
fonts-ttf-liberation-1.0-1mdv2008.1
dash-static-0.5.4-7mdv2008.1
foomatic-filters-3.0.2-1.20071218.1mdv2008.1
notification-daemon-0.3.7-3mdv2008.1
foomatic-db-hpijs-20070820-3mdv2008.1
update-alternatives-1.9.0-2mdv2008.1
foomatic-db-3.0.2-1.20071218.1mdv2008.1
foomatic-db-engine-3.0.2-1.20071218.2mdv2008.1
x11-driver-video-ati-6.8.0-1mdv2008.1
libstartup-notification-1_0-0.9-6mdv2008.1
gutenprint-foomatic-5.0.2-4mdv2008.1
[root@localhost fabio]#
[root@localhost fabio]#
[root@localhost fabio]# con quel comando vedi tutti i pacchetti installati in cui è presente la parolo ati.
bash: con: command not found
[root@localhost fabio]#
[root@localhost fabio]# Il tuo output è stato:
bash: Il: command not found
[root@localhost fabio]#
[root@localhost fabio]# Citazione:
bash: Citazione:: command not found
[root@localhost fabio]# migration-assistant-0.6.0-2mdv2008.1 libkdecorations4-4.0.3-1mdv2008.1
bash: migration-assistant-0.6.0-2mdv2008.1: command not found
[root@localhost fabio]# mandriva-kde-translation-2008.1-0.2mdv2008.1
bash: mandriva-kde-translation-2008.1-0.2mdv2008.1: command not found
[root@localhost fabio]# fonts-ttf-decoratives-1.3-19mdv2008.1
bash: fonts-ttf-decoratives-1.3-19mdv2008.1: command not found
[root@localhost fabio]# fonts-ttf-liberation-1.0-1mdv2008.1
bash: fonts-ttf-liberation-1.0-1mdv2008.1: command not found
[root@localhost fabio]# dash-static-0.5.4-7mdv2008.1
bash: dash-static-0.5.4-7mdv2008.1: command not found
[root@localhost fabio]# foomatic-filters-3.0.2-1.20071218.1mdv2008.1
bash: foomatic-filters-3.0.2-1.20071218.1mdv2008.1: command not found
[root@localhost fabio]# notification-daemon-0.3.7-3mdv2008.1
bash: notification-daemon-0.3.7-3mdv2008.1: command not found
[root@localhost fabio]# foomatic-db-hpijs-20070820-3mdv2008.1
bash: foomatic-db-hpijs-20070820-3mdv2008.1: command not found
[root@localhost fabio]# update-alternatives-1.9.0-2mdv2008.1
bash: update-alternatives-1.9.0-2mdv2008.1: command not found
[root@localhost fabio]# foomatic-db-3.0.2-1.20071218.1mdv2008.1
bash: foomatic-db-3.0.2-1.20071218.1mdv2008.1: command not found
[root@localhost fabio]# foomatic-db-engine-3.0.2-1.20071218.2mdv2008.1
bash: foomatic-db-engine-3.0.2-1.20071218.2mdv2008.1: command not found
[root@localhost fabio]# x11-driver-video-ati-6.8.0-1mdv2008.1
bash: x11-driver-video-ati-6.8.0-1mdv2008.1: command not found
[root@localhost fabio]# libstartup-notification-1_0-0.9-6mdv2008.1
bash: libstartup-notification-1_0-0.9-6mdv2008.1: command not found
[root@localhost fabio]# gutenprint-foomatic-5.0.2-4mdv2008.1
bash: gutenprint-foomatic-5.0.2-4mdv2008.1: command not found
[root@localhost fabio]#
[root@localhost fabio]#
[root@localhost fabio]# come vedi li hai installati.
bash: come: command not found
[root@localhost fabio]#
[root@localhost fabio]# Per sicurezza scrivi in una shell
bash: Per: command not found
[root@localhost fabio]#
[root@localhost fabio]# cat /etc/X11/xorg.conf
# File generated by XFdrake (rev 234840)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "hp m703"
HorizSync 30-70
VertRefresh 50-140

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon 9250 and earlier"
Driver "ati"
Option "DPMS"
Option "AccelMethod" "EXA"
Option "XaaNoOffscreenPixmaps" "1"
Option "AGPMode" "8"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

dopo aver fatto le modifiche che mi avere suggerito voi ho terminato la sessione e mi sono riconnesso.....cosa sarebbe uno switch init3/init5
Sad scusate ma sono una frana
vorrei ringraziarvi sinceramente per la vostra pazienza e il vostro aiuto,siete davvero gentili....