ATI Radeon® Xpress 200M e Mandriva 2006 sul laptop toshiba

4 risposte [Ultimo messaggio]
Ritratto di Mercuzio
Mercuzio
(Junior)
Offline
Junior
Iscritto: 23/05/2006
Messaggi: 7

Salve a tutti, dopo le difficoltà di installazione di Mandriva 2006 sul mio toshiba (le cui specifiche tecniche vedete in calce al messaggio) ora finalmente per mezzo dell'installazione "noauto" sono riuscito a far partire il tutto. Il maggior problema che ora mi si è parato davanti è la grafica. La mia scheda grafica è ATI Radeon® Xpress 200M ma non sono riuscito a farla riconoscere dal mio Xorg-x11-6.9-1.
Ho provato a seguire le istruzioni del mitico Moreno (http://www.mandrakeitalia.org/modules/wfsection/article.php?articleid=149).
Però quando riavvio il sistema non cambia nulla. Ho provato quindi a vedere nuovamente i file Xorg presenti e non risultano aggiornati alla versione (7.0) che pensavo di aver installato.

Il server grafico mi funziona nel senso che riesco ad usare la Mandriva tramite grafica ma non è al massimo della sua funzionalità visto che questo è principalmente il mio problema ogni volta che lancio un video o con Xine o con Kaffeine e lo espando a tutto schermo mandriva va in crash e automaticamente, senza che io faccia niente, riavvia la sessione.
Chi mi può dare una mano?
Grazie.

---------------------------------------------------------------------------
Toshiba Satellite Pro M40-274: Intel® Celeron® M processor 360, 1.40 GHz, HD 40 GB, 256 MB RAM, WXGA TFT display, ATI Radeon® Xpress 200M

Ritratto di cirax
cirax
(Geek)
Offline
Geek
Iscritto: 25/10/2004
Messaggi: 187

Ciao,

scusa l'appunto ma la guida di Moreno è della fine del 2005 quando in Updates non esistevano ancora aggiornamenti di Xorg che risolvessero i problemi che la 2006 si portava dietro con la versione CVS dell'installatore, ora con un semplice aggiornamento ti ritrovi xorg alla 6.9 funzionante.

Credo convenga tentare questa strada piuttosto che utilizzare pacchetti della cooker... se poi sto prendendo fischi per fiaschi scusate...

Ciao ciao


"piscio sui pomponi e sui cilindri dispari!"
da Ed il polso del Joe Bar Team

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Non ho capito se tu hai installato i driver DKMS di ATI, in questo caso loro dovrebbero superare tutti i Bug di XOrg.

Io ho una ATI X300 e va benissimo (O meglio andava sino all'uscita si XOrg 7.1).

Posta il tuo file di configurazione xorg.conf che trovi in /etc/X11

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di Mercuzio
Mercuzio
(Junior)
Offline
Junior
Iscritto: 23/05/2006
Messaggi: 7

Ciao Moreno,
innanzitutto, i driver DKMS di ATI dove li posso trovare....e quale tipo mi serve?
Ecco il mio xorg.conf:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "synaptics"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "Protocol" "auto-dev"
Option "Device" "/dev/input/mice"
Option "MinSpeed" "0.09"
Option "MaxSpeed" "0.18"
Option "BottomEdge" "4200"
Option "SHMConfig" "on"
Option "FingerLow" "25"
Option "LeftEdge" "1700"
Option "MaxTapMove" "220"
Option "MaxTapTime" "180"
Option "FingerHigh" "30"
Option "VertScrollDelta" "100"
Option "TopEdge" "1700"
Option "AccelFactor" "0.0015"
Option "RightEdge" "5300"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1280x800"
HorizSync 31.5-90
VertRefresh 60

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "vesa"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "screen1"
EndSection

Questo è il mio faile xorg.conf. Se mi sapete dire come posso utilizzare al meglio la mia scheda grafica evitando che la sessione mi si riavvii automaticamente ogni volta che lancio un video te ne sono grato in eterno.
Ciao

---------------------------------------------------------------------------
Toshiba Satellite Pro M40-274: Intel® Celeron® M processor 360, 1.40 GHz, HD 40 GB, 256 MB RAM, WXGA TFT display, ATI Radeon® Xpress 200M

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Come mai hai selezionato la scheda video vesa ??
Il driver ati base non va ??

I driver per la 2006 li trovi qui: ftp://ftp.cica.es/mirrors/Linux/plf/mandrake/non-free/2006.0/i586

Aggiungi la sorgente PLF e poi installali con urpmi (Ci sono varie guide sull'argomento).

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.