AMD HD5570 Driver 13.251 non si installa

4 risposte [Ultimo messaggio]
Ritratto di pi-tech
pi-tech
(Junior)
Offline
Junior
Iscritto: 09/02/2007
Messaggi: 26

Salve a tutti,
come da titolo sto provando invano di installare i driver video in oggetto (ultimi disponibili e scaricati dal sito AMD).
Seguendo la Wiki di AMD ho fatto anche un'installazione del tipo "urpmi fglrx" che mi ha installato quasi mezzo giga di Kernel della serie 2.6.33.5 e 2.6.33-7; a parte ho installato anche la parte "devel" degli stessi. Purtroppo non c'è niente da fare: quando avvio la procedura di installazione questa termina con un messaggio di errore, invitando a visionare il log.
Allego quindi il file /usr/share/ati/fglrx-install.log dove si può vedere che il problema è nella parte finale quando dovrebbe essere creato un qualche modulo (mi sembra di capire....).
Sinceramente mi sembra di aver seguito la procedura, ma evidentemente non è così, ma allora non ho capito dove sbaglio.
Sono a disposizione per fornire qualunque informazione aggiuntiva utile ad aiutarvi a capire e darmi se possibile una mano per risolvere questo problema.
Vi ringrazio in anticipo per l'aiuto che potrete darmi.

p.s.: ho preso questa scheda in sostituzione di una nvidia 8600 GT che mi ha abbandonato ma che prima di rompersi funzionava egregiamente coi suoi driver.

Leggendo sul Forum ho capito che forse ho pasticciato di brutto....
Mi sembra ad esempio che la scheda 5570 non è supportata da kernel 2.6.33 del mio sistema...boh.
Trovo utile precisare che la distro è la 2010.2. Avrei deciso, per fare una bella pulizia, di piallare tutto e aggiornare all'ultima disponibile (mi pare sia la 2011).
Fatemi sapere, se vi va, le vostre impressioni.

Grazie.

AllegatoDimensione
fglrx-install.log_.txt2.53 KB
Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 12/07/2009
Messaggi: 181

Premettendo che al momento non so darti una vera risposta, vorrei darti qualche suggerimento. Prima di tutto hai cercato se il driver in questione non sia già presente nei repo (sezione nonfree)? Inoltre potrebbe essere utile linkare la pagina con le istruzioni che hai seguito ed allegare anche il file /usr/share/ati/amd-uninstall.sh. Inoltre magari dovresti privare prima a disinstallare e poi a reinstallare il driver.

Come hai notato l'istallazione è fatta con l'opzione 'force', perciò probabilmente viene saltato il controllo delle dipendenze. Quindi dovresti capire cone disabilitare tale opzione e sperare che ti scriva qualche cosa di più specifico. Sicuramente ti servirà un compilatore C qualche libreria ed i sorgenti del kernel (che però devono essere la stessa versione di quello che hai in uso). A proposito, hai i kernel 'server' istallati?

pi-tech ha scritto:

Trovo utile precisare che la distro è la 2010.2. Avrei deciso, per fare una bella pulizia, di piallare tutto e aggiornare all'ultima disponibile (mi pare sia la 2011).

Questa è una buona idea, non tanto per fare pulizia quanto perché stai utilizzando una versione datata non più dotata di alcun supporto (aggiornamenti di versione o sicurezza) da più di un anno. L'ultima disponibile col nome 'Mandriva' è effettivamente la 2011, ma anch0essa è obsoleta. La nuova distro si chiama OpenMandriva e la puoi trovare qui. Per tutti i dettagli basta che leggi le ultime 5 o 6 news che trovi in questo forum. Il consiglio e di installarle e riprovare poi, se ne hai davvero bisogno, il driver della scheda video.

ciao,
mandian

Ritratto di pi-tech
pi-tech
(Junior)
Offline
Junior
Iscritto: 09/02/2007
Messaggi: 26

Ciao mandian, ti ringrazio del tuo puntuale intervento.
Cerco di rispondere con ordine:non ho controllato la disponibilità del driver nei repo NonFree, perché "ai miei tempi" (devi sapere difatti che il primo kernel che ho compilato era il 2.0.1) si faceva così,si scaricavano i driver proprietari dal sito del produttore della scheda e si sudava per farli funzionare.
Ma evidentemente mi sono un po' arrugginito.....
Insomma ho scaricato il driver dal sito AMD e ho seguito le relative istruzioni di cui alla Wiki qui installando poi con urpmi tutto quanto riferibile a "fglrx".
Avendo poi riscontrato l'errore "DKMS" ho installato anche i kernel "devel".
Ma il procedimento AMD non va a buon fine per via dell'errore riportato nel file allegato.

Ho dato un'occhiata alla OpenMandriva che mi consigli ma mi sembra ancora troppo acerba rispetto al tempo che dovrei dedicarci. Non è meglio MAGEIA ? Scusa ma sono lontano da un pezzo dalle novità...

Penso che al momento sia meglio per me cercare di dare una ripulita al mio PC e poi semmai cercare di capire meglio come installare correttamente i driver di questa scheda video (come dicevo l'ho presa per sostituire una Nvidia 8600gt che si è rotta, ma è una storia troppo lunga e rischierei l'OT).

Grazie, vi leggo con piacere.

Edit:
In procinto di effettuare la pulizia di cui parlavo, mi servirebbe sapere gentilmente a quali repo "Non Free" occorre riferirsi.
Nel mio sistema i repo attualmente definiti sono i seguenti:
Main (Official e Updates);
Contrib (Official e Updates);
Non-free (Official e Updates);
PLF (Free e Non Free).

Attualmente riesco a vedere il server grafico attivo, ma con driver VESA e risoluzione "bruttina" che mi stira tutto in orizzontale, non c'è modo di cambiarla dal MCC.

Grazie di nuovo

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 12/07/2009
Messaggi: 181

Mi è difficile risponderti a tutto perché non ho più nessun pc con Mandriva 2010.

pi-tech ha scritto:


Cerco di rispondere con ordine:non ho controllato la disponibilità del driver nei repo NonFree, perché "ai miei tempi" (devi sapere difatti che il primo kernel che ho compilato era il 2.0.1) si faceva così,si scaricavano i driver proprietari dal sito del produttore della scheda e si sudava per farli funzionare.
Ma evidentemente mi sono un po' arrugginito.....

Alla pagina che hai linkato si legge:

Citazione:

ATI commercial driver is available from public non-free section on official mirrors for Mandriva Linux 2007 Spring and later. ATI commercial driver is available from third-party PLF repository for all currently supported Mandriva Linux releases.

Comunque, se ho ben capito, hai seguito l'ultimo metodo, ma dal file che hai allegato non è chiaro che tipo di errore ti dà. Sembra che manchi qualche dipendenza ...

pi-tech ha scritto:


Ho dato un'occhiata alla OpenMandriva che mi consigli ma mi sembra ancora troppo acerba rispetto al tempo che dovrei dedicarci. Non è meglio MAGEIA ? Scusa ma sono lontano da un pezzo dalle novità...

Quello che è meglio dipende soprattutto dalle tue esigenze. Mageia si è separata da Mandriva ai tempi della 2010 ed è rimasta abbastanza simile a quella. OpenMandiva si propone come evoluzione della 2011 e, di fatto, è più un fork di ROSA (che a sua volta è un fork dalla 2011) che di Mandriva.
Al di là delle vicende 'storiche' ti conviene guardare quali software hanno già pacchettizzato rispetto a quelli che ti servono. Puoi provarle entrabe come live e poi decidere.

pi-tech ha scritto:


Nel mio sistema i repo attualmente definiti sono i seguenti:
Main (Official e Updates);
Contrib (Official e Updates);
Non-free (Official e Updates);
PLF (Free e Non Free).

Nei repo nonfree c'è una versione di fglrx già pronta per l'uso, ma rimane da vedere se la versione è sufficientemente aggiornata per supportare la tua scheda. Per quanto riguarda i repo devi controllare a quale mirror sono riferiti (basta guaradre il file /etc/urpmi/urpmi.conf, che eventualemnte puno allegare) infatti non è detto che siano ancora tutti attivi (ricoradi che stai usando una versione obsoleta di una distro che non esiste più). Ad esempio i repo PLF penso che non esistono più (nella 2011 erano stati sostituiti dai repo restricted)

ciao,
mandian

Ritratto di pi-tech
pi-tech
(Junior)
Offline
Junior
Iscritto: 09/02/2007
Messaggi: 26

Aggiornamento.
Per mancanza di tempo e l'insorgenza di altri problemi sul PC ho preso la radicale decisione di "pensionarlo" e farmene assemblare uno nuovo.
Nell' attesa ho dato un'occhiata alle varie distro e ho deciso che passerò a MAGEIA non appena uscirà La versione 4 definitiva.
Grazie per l'attenzione.

Saluti a tutti.