Lilo e scheda audio

4 risposte [Ultimo messaggio]
Ritratto di nebumix
nebumix
(Newbie)
Offline
Newbie
Iscritto: 29/11/2005
Messaggi: 3

Salve a tutti, sono nuovo del forum e anche di Linux. Ho installato 2 giorni fa per la prima volta (dopo essere stato al Linux Day) Mandriva 2005 LE.
Per ora gli unici 2 problemi sono il file Lilo.conf e la scheda audio.

Lilo.conf

Ho letto che per modificare il boot di avvio bisogna editare il file lilo.conf.
Io vorrei mettere come sistema operativo di default windows. (ancora non so usare linux, quindi almeno per un altro po' dovrò continuare a usare windows e quindi vorrei che partisse in automatico)
Ho gia provato a modificare il file, (ho fatto tutto a intuito e sicuramente ho sbagliato, considerando che continua a partire linux per default e non win)
Vi copio il contenuto del file, magari sapete dirmi cosa modificare.

------------------------------------------------------------------------------------------------------------

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="windows"
boot=/dev/sda
map=/boot/map
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/sda6
initrd=/boot/initrd.img
append="acpi=ht splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/sda6
initrd=/boot/initrd.img
append="acpi=ht"
read-only
image=/boot/vmlinuz-smp
label="linux-smp"
root=/dev/sda6
initrd=/boot/initrd-smp.img
append="acpi=ht splash=silent"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/sda6
initrd=/boot/initrd.img
append="failsafe acpi=ht devfs=nomount"
read-only
other=/dev/sda1
label="windows"
table=/dev/sda

------------------------------------------------------------------------------------------------------------

Secondo problema:
Scheda audio.

Sembra che tutto il mio hardware sia stato riconosciuto e configurato durante l'installazione, l'unica cosa che non funziona è la scheda audio.
Ho una Realtek high definition audio.
Ho letto in giro che bisogna scaricare i driver e installarli.
Ho scharicato 2 tipi di driver diversi, che dovrebbero essere entrambi per linux, ma non riesco a installare nessuno dei due.
Non so se ho scaricato dei driver sbagliati o se non riesco proprio a installarli.
Nelle istruzioni che ho trovato con i driver scaricati c'è scritto che vanno compilati, ho provato a seguire le istruzioni ma mi da sempre errore e non compila niente (almeno credo, sta il fatto che la scheda audio non funge).

Se qualcuno fosse in grado di darmi una mano gliene sarei grato.
Grazie a tutti
Ciao

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao e Benvenuto tra noi

Purtroppo posso aiutarti solo per quel che riguarda LILO.
Una volta modificato il file lilo.conf devi lanciare il comando lilo che si occupa di salvare le informazioni al posto giusto.

Visto che sei nuovo del mondo linux ti consiglio di prendere dimestichezza con il centro di controllo di Mandriva che ti permette di fare queste cose in maniera semplice ed indolore.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di nebumix
nebumix
(Newbie)
Offline
Newbie
Iscritto: 29/11/2005
Messaggi: 3

Ciao, ti ringrazio per l'interessamento, potresti dirmi quale è questo "comando lilo che si occupa di salvare le informazioni al posto giusto"?
Grazie
ciao

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Il comando è proprio lilo senza molta fantasia per fortuna.

Ciao Ciao Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di nebumix
nebumix
(Newbie)
Offline
Newbie
Iscritto: 29/11/2005
Messaggi: 3

Grazie, sono riuscito a risolvere il problema di Lilo.
Se ci fosse qualcuno in grado di darmi una mano con la cheda audio gliene sarei grato.
Grazie ancora per lilo.
Ciao