Problema installazione driver nvidia vecchi: "conflicts with xorg-x11-server"

4 risposte [Ultimo messaggio]
Ritratto di cornelius
cornelius
(Junior)
Offline
Junior
Iscritto: 20/11/2005
Messaggi: 17

Salve,
ho seguito la guida di cosmico (www.mandrakeitalia.org/modules/wfsection/article.php?articleid=134) per istallare i driver nvidia della mia vecchia scheda video nvidia TNT2 ultra.

Avendo letto anche sul sito di nvidia che i driver appropriati per questa scheda sono i "7174" e non i successivi che non la supportano, ho scaricato questi pacchetti invece degli 7676-4 indicati dalla guida di cosmico, cioè:

1) dkms-nvidia-7174-12.mdk2006.0.mde.i586.rpm
2) libnvidia-opengl1-7174-12.mdk2006.0.mde.i586.rpm
3) nvidia-xorg-7174-12.mdk2006.0.mde.i586.rpm

Mi sono installato il kernel-source e il dkms.

Mentre sono riuscito a installare il primo pacchetto (dkms-nvidia-7174-12), i successivi due non si installano e tornano questo errore:

"Si è verificato un problema durante l'installazione: nvidia <= 7676-2mdk conflicts with xorg-x11-server-6.9-1.cvs20050915.2mdk.i586".

Avreste qualche indicazione per risolvere questo problema o per indicarmi dove sto sbagliando?

Grazie molte.

Ritratto di joao_64
joao_64
(Newbie)
Offline
Newbie
Iscritto: 24/10/2004
Messaggi: 4

Io l'ho risolto installando solamente il driver quello del sito NVIDIA-Linux-x86-1.0-7174-pkg1.run per il resto non ho installato altri pacchetti nvidia.
Ciao

Ritratto di cornelius
cornelius
(Junior)
Offline
Junior
Iscritto: 20/11/2005
Messaggi: 17

Grazie. Se non ho capito male però, nella modalità di installazione a cui mi sto riferendo io, si installano i driver basati su DKMS, che permette di risparmiarsi di dover ricompilare i driver a ogni variazione del kernel.
Ciao

Ritratto di joao_64
joao_64
(Newbie)
Offline
Newbie
Iscritto: 24/10/2004
Messaggi: 4

con i driver nvidia io non ho ricompilato il kernel.
Ho installato il kernel source ed dkms ma quando ho installato i driver nvidia ed ho riavviato tutto e andato alla perfezione senza dover far altro. Non so' se sono stato solo fortunato ma prima appena partiva login grafico si bloccava tutto adesso parte prima il logo nvidia e poi il login grafico e tutto fila a meraviglia.
Ciao

Ritratto di cornelius
cornelius
(Junior)
Offline
Junior
Iscritto: 20/11/2005
Messaggi: 17

Quote:

joao_64 ha scritto:
con i driver nvidia io non ho ricompilato il kernel.Ciao

...ok, dicevo un'altra cosa, e cioè che quando ti troverai a dover aggiornare il kernel dovrai occuparti nuovamente di quei driver invece di averli sistemati una volta per tutte.
Non so se ho capito bene - probabilmente no! Wink - comunque se non trovo altro modo farò presto così come hai fatto tu.
Ciao.