scheda ATI , schermo nero

7 risposte [Ultimo messaggio]
Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Salve !

Riprendo una vexata questio relativo alle schede ATI. Tempo fa chiesi aiuto per far funzionare (con Mandriva 2010.0) la mia ATI Radeon, poiché risultava visibile solo la barra delle applicazioni (funzionante), ma il resto dello schermo era nero, e nere tuttlle le applicazioni. Da una quida di Moreno appresi che dovevo aggiungere tra i parametri del kernel radeon.modeset=1 (in pratica aggiungerla al posto giusto nel file /boot/grub/menu.lst).
Tutto bene col kernel 2.33.7, ma con i kernel successivi l'ambiente X non partiva neppure, e dopo la fase iniziale lo schermo rimaneva nero, senza neppure dare altri segni di vita. Ho rimosso la riga in questione (radeon.modeset=1) e stavolta l'ambiente X parte (con kernel 2.36), ma ancora solo la barra è visibile, il resto nisba.
Cosa fare ? L'ambiente failsafe funziona, dunque posso vedere i messaggi....

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

alangea ha scritto:

Salve !

Riprendo una vexata questio relativo alle schede ATI. Tempo fa chiesi aiuto per far funzionare (con Mandriva 2010.0) la mia ATI Radeon, poiché risultava visibile solo la barra delle applicazioni (funzionante), ma il resto dello schermo era nero, e nere tuttlle le applicazioni. Da una quida di Moreno appresi che dovevo aggiungere tra i parametri del kernel radeon.modeset=1 (in pratica aggiungerla al posto giusto nel file /boot/grub/menu.lst).
Tutto bene col kernel 2.33.7, ma con i kernel successivi l'ambiente X non partiva neppure, e dopo la fase iniziale lo schermo rimaneva nero, senza neppure dare altri segni di vita. Ho rimosso la riga in questione (radeon.modeset=1) e stavolta l'ambiente X parte (con kernel 2.36), ma ancora solo la barra è visibile, il resto nisba.
Cosa fare ? L'ambiente failsafe funziona, dunque posso vedere i messaggi....

A quanto pare con i nuovi kernel funzionano solo le VESA (ho fatto girare drakx11 in modalità failsafe, ho scelto Xorg|vesa, configurazione personalizzata della scheda). In tal modo ho perso gli effetti 3D Compiz (sono forse questi a dar fastidio ?), ma ora pare che il kernel 2.6.36 faccia partire il server X.
La domanda sorge spontanea: come mai la correzione di cui sopra funziona con driver proprietario sul vecchio kernel e su quello nuovo no ? C'è modo di risolvere il problema ?
E che succederà con la 2011 ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Mi sembra tutto molto strano. I tuoi problemi con i driver ATI non hanno spiegazione logica. Fai una prova. Loggati con un altro utente, non xguest, ma crealo ex-novo, e configura con il nuovo utente i driver ATI. Io ho avuto un porblema simile al tuo con nvidia sulla 2011, ma mi è bastato "resettare" l'utente (eliminando .kde4 dalla home) e tutto è tornato a funzionare a meraviglia.

Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Niente da fare...a questo punto userò il vecchio kernel, tanto funziona abbastanza bene, anche se il sistema pare un po' più arruginito...(colpa degli effetti 3D ?). Se proprio voglio usare il nuovo, pazienza: userò la scheda VESA. In attesa della 2011...
A proposito: volendola rinstallare da capo, mi conviene:

  1. fare l'immagine delle partizioni sistema/utente (p.e. con System rescue CD) digitare da su rpm |grep -qa >pippo.txt per elencare i pacchetti installati
    costruire uno script che installi i pacchetti (le dipendenze sono automaticamente ricercate)
    tutto questo per evitare di ricordarmi i software da me installati successivamente all'installazione di base

Ho detto bene ? (il comando per generare la lista forse è impreciso...)

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Il comando corretto è

rpm -qa > lista.txt

Ma non ti conviene lasciare la home così come e formattare solo /root? La cosa sensata di linux è proprio questa, non dover riformattare la propria home ad ogni installazione.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

Certo !
Qunado installo da capo una nuova release, formatto solo le partizioni di sistema e quella /usr (è questa che intendevo come utente) cove sono installati i pacchetti. Dato che quelli installati da me sono molti di più dell'installazione base, a meno di non tentare il riaggiornamento, mi occorre elencarli da qualche parte, in modo da installarli dopo l'installazione di base.
Devo solo fare in modo da non fare pasticci...suggerimenti ?

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

L'aggiornamento non puoi farlo passando alla 2011 dalla 2010 e in questo caso non credo neanche che ti serva tenere la /usr. Serve proprio un'installazione pulita che più pulita non si può! Smile
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di alangea
alangea
(Monster)
Offline
Monster
Iscritto: 16/02/2008
Messaggi: 460

alangea ha scritto:

alangea ha scritto:

Salve !

Riprendo una vexata questio relativo alle schede ATI. Tempo fa chiesi aiuto per far funzionare (con Mandriva 2010.0) la mia ATI Radeon, poiché risultava visibile solo la barra delle applicazioni (funzionante), ma il resto dello schermo era nero, e nere tuttlle le applicazioni. Da una quida di Moreno appresi che dovevo aggiungere tra i parametri del kernel radeon.modeset=1 (in pratica aggiungerla al posto giusto nel file /boot/grub/menu.lst).
Tutto bene col kernel 2.33.7, ma con i kernel successivi l'ambiente X non partiva neppure, e dopo la fase iniziale lo schermo rimaneva nero, senza neppure dare altri segni di vita. Ho rimosso la riga in questione (radeon.modeset=1) e stavolta l'ambiente X parte (con kernel 2.36), ma ancora solo la barra è visibile, il resto nisba.
Cosa fare ? L'ambiente failsafe funziona, dunque posso vedere i messaggi....

A quanto pare con i nuovi kernel funzionano solo le VESA (ho fatto girare drakx11 in modalità failsafe, ho scelto Xorg|vesa, configurazione personalizzata della scheda). In tal modo ho perso gli effetti 3D Compiz (sono forse questi a dar fastidio ?), ma ora pare che il kernel 2.6.36 faccia partire il server X.
La domanda sorge spontanea: come mai la correzione di cui sopra funziona con driver proprietario sul vecchio kernel e su quello nuovo no ? C'è modo di risolvere il problema ?
E che succederà con la 2011 ?

Anche con il kernel 2_3.0.3 la storia si ripete (siamo su Mandriva 2010.2):
se lascio i parametri di default, schermo non più nero, ma strisce blu, e buonanotte il secchio. Se inserisco nomodeset, casini, se inserisco radeon.modeset=0, l'ambiente X parte, compare la barra delle applicazioni, partono le aaplicazioni ma si vede tutto nero.
Ho notato che pur avendo installati i driver proprietari fglrx, non vi sono pacchetti specifici per i nuovi driver (mentre per quello funzionante, 2.33.7-2 ci sta).
Dipende da questo ?
Con i driver open sembra che le cose funzionino, ma con prestazioni grafiche penose...
A proposito, nella 2011 virtuale (host 2010.2), avendo caricato le fglrx e con nomodeset tra i parametri, sembra che le cose funzionino. Vacci a capire..

Configurazione: RAM: 8GB DDR3 1333 - Mother board: ASUS H67 B3 Revision
4 processori INTEL CORE I3-2120 (64bit) -Scheda video ASUS NVIDIA PhysX GeForce GT440 -SEAGATE HD 500 GB SATA 7200
OpenMandriva Lx 3.0- kernel-release-desktop-4.13.8-2omv- Plasma 5.10.5