Impossibile utilizzare il driver propretario Nvidia

7 risposte [Ultimo messaggio]
Ritratto di Ghost
Ghost
(Monster)
Offline
Monster
Iscritto: 24/11/2005
Messaggi: 320

Salve ho una mandriva 2010.1 aggiornata con il nuovo kde 4.5.5 ( quello mib ).
Sto provando a far partire il driver propietario della nvidia ( mi è sempre partita ma da un giorno all'altro ho avuto una schermata nera e ho reinstallato tutto ), tuttavia quando va a "compilare" all'avvio con dkms ( ho messo nelle virgolette perchè non so se è il termine giusto ) dopo qualche minuto di puntini mi dice mi da fallito e mi esce una specie di popup che mi avvisa che verranno utilizzati i driver non proprietari ( nvidu è possibile?? )

Hoprovato un po con tutti i kernel ( ovviamente installando anche i sorgenti ) ma mi da sempre lo stesso problema.
Dovrebbe essere tutto aggiornato alle ultime versione.
Avete qualche consiglio?

Asrock ALiveNF7G-HDReady - 4GBRam - Sagate 160 Gb + Samsung 80Gb - Amd64 4200+ - Nvidia 8200gs

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Hai installato anche i pacchetti devel del kernel? Il dkms richiede quel pacchetto psecifico per compilare, non i sorgenti.
Non ho mai avuto problemi con nvidia.
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Ghost
Ghost
(Monster)
Offline
Monster
Iscritto: 24/11/2005
Messaggi: 320

Si anche i devel....

Asrock ALiveNF7G-HDReady - 4GBRam - Sagate 160 Gb + Samsung 80Gb - Amd64 4200+ - Nvidia 8200gs

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

rpm -qa |grep dkms e rpm -qa|grep nvidia cosa ti danno come risultato?

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Ghost
Ghost
(Monster)
Offline
Monster
Iscritto: 24/11/2005
Messaggi: 320

[andrea@localhost ~]$ rpm -qa |grep dkms
dkms-nvidia-current-256.35-69mib2010.1
dkms-2.0.19-20mdv2010.1
dkms-minimal-2.0.19-20mdv2010.1
[andrea@localhost ~]$ rpm -qa|grep nvidia
dkms-nvidia-current-256.35-69mib2010.1
nvidia-current-doc-html-256.35-69mib2010.1
lib64kwinnvidiahack4-4.5.5-0mdv2010.2
x11-driver-video-nvidia-current-256.35-69mib2010.1
[andrea@localhost ~]$

Asrock ALiveNF7G-HDReady - 4GBRam - Sagate 160 Gb + Samsung 80Gb - Amd64 4200+ - Nvidia 8200gs

Ritratto di Nick78
Nick78
(Collaboratore)
Offline
Collaboratore
Iscritto: 19/01/2008
Messaggi: 1377

Nei backports Mandriva trovi i driver Nvidia aggiornati. Non vorrei che a creare qualche problemino siano i pacchetti del MIB (anche se non credo...). Fai una prova. Abilita le fonti backports, elimina i pacchetti MIB in questione e installa i driver Mandriva. Vediamo se così funziona!
Ciao ciao!!
Nicola

NiCk on Mandriva 2011 - Asus K61IC - P8700 - 4Gb Ram - KDE SC 4.6.5 - Kernel 3.0.1 - Nvidia GT_220M 1Gb - Linux registered user #496729 - www.nickworlds.it - Samsung Galaxy S3 Android 4.0.3

Ritratto di Ghost
Ghost
(Monster)
Offline
Monster
Iscritto: 24/11/2005
Messaggi: 320

Ok il problema era i driver, attivando i backports funziona bene.
Grazie Nick

Asrock ALiveNF7G-HDReady - 4GBRam - Sagate 160 Gb + Samsung 80Gb - Amd64 4200+ - Nvidia 8200gs

Ritratto di francofait
francofait
(Junior)
Offline
Junior
Iscritto: 11/09/2004
Messaggi: 41

Quante complicazioni per l' operazione più semplice esistente.
Da mandriva control center gestione software , aggiungi tutte le repositri , poi da gestione hardware scheda video , i driver di nvidia se li prende da se con tutti i pacchetti di cui ha bisogno per attivarli al riavvio .