digikam non si avvia (risolto)

8 risposte [Ultimo messaggio]
Ritratto di pietro61
pietro61
(Monster)
Offline
Monster
Iscritto: 18/06/2005
Messaggi: 413

Ho il  problema con digikam su kde 4.5.3 che non si avvia.
Sapete se è un problema conosciuto  o solo mio?
Grazie Pietro

Ritratto di manson
manson
(Monster)
Offline
Monster
Iscritto: 08/04/2009
Messaggi: 324

Ciao sulla mia macchina si avvia regolarmente senza problemi, Mandriva 2010.1 Free KDE 453 x86_64
Probabilmente è un problema legato al tuo utente, hai provato a vedere se si avvia da xguest? Ottieni qualche errore avviandolo dalla shell?
Da quale kde hai aggiornato 453?

[=4]Cooker x86_64 - Kde 4.5.76 kernel - 2.6.36-desktop-2mnb - Mandriva 2010.1 Free kde 4.5.3 - kernel 2.6.35.8-desktop-nrj.69mib - Pentium(R) Dual-Core CPU x86_64 E5200 2.50GHz - 2 Gb Ram - NVidia 256.44 GeForce 9600 GT - [b]

Ritratto di picard12
picard12
(Guru)
Offline
Guru
Iscritto: 12/09/2005
Messaggi: 2773

controlla di avere tutte le librerie di digikam della stessa versione.

Asus A8N-E;Opteron180X2/mandriva 2010.1Spring x64bit
VGA: Gigabyte gts250/1gb ddr3

Ritratto di pietro61
pietro61
(Monster)
Offline
Monster
Iscritto: 18/06/2005
Messaggi: 413

Ecco l'errore che mi da (anche con xguest)
[pf61@localhost ~]$ digikam
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
Time elapsed: 182 ms
Model: Time elapsed: 265 ms
TextureColorizer: Time elapsed: 56 ms
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/pf61/.kde4/socket-localhost/kdeinit4__0
QSocketNotifier: Invalid socket 30 and type 'Read', disabling...

[1]+  Stopped                 digikam
Non conosco tutte le librerie di digikam per controllare la versione.
Grazie e ciao
Pietro

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Sulla mia mandriva 64 bit, con kde 4.5.3 digikam funziona bene. Appena accesa la fotocamera mi chiede cosa fare, scelgo digikam e tutto va bene. Solo se, in successione, attacco un'altra fotocamera non parte più in automatico. Cioè: il notificatore dei dispositivi segnala la connessione alla fotocamera, proprone di aprire digikam ma poi non succede nulla. Devo aprire digikam, e fare importa. Poi tutto torna a funzionare.
Io ho avuto un problema tempo fa per questione di librerie sbagliate: prova a disinstallare digikam dal centro di controllo assieme a tutte le ricorrenze di digikam che trovi, e poi prova a reinstallarlo.
Ciao

Mandriva 2010.2 su Athlon x2_64

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Mmm, che versione del programma hai??

rpm -qa | grep digikam

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di manson
manson
(Monster)
Offline
Monster
Iscritto: 08/04/2009
Messaggi: 324

Ma l'applicazione digikam l'avevi mai avviata e configurata? Per caso hai cambiato qualche path che digikam richiede?
Potresti provare a rinominare la tu vecchia .kde4 in .kdeOLD e far creare al sistema la nuova .kde4.
Ripeto digiKam: 1.5.0 funziona perfettamente.

[=4]Cooker x86_64 - Kde 4.5.76 kernel - 2.6.36-desktop-2mnb - Mandriva 2010.1 Free kde 4.5.3 - kernel 2.6.35.8-desktop-nrj.69mib - Pentium(R) Dual-Core CPU x86_64 E5200 2.50GHz - 2 Gb Ram - NVidia 256.44 GeForce 9600 GT - [b]

Ritratto di epala
epala
(Monster)
Offline
Monster
Iscritto: 06/09/2006
Messaggi: 408

Anche a me funziona ... ma qualche volta fa le bizze se non trova disponibile il percorso degli album ...
Potresti fare quello che ti ha detto Manson ma forse anche solo con il file /home/epala/.kde4/share/config/digikamrc ... lo  rinomini come old e poi riavvi digikam (il quale lo ricrea nuova). Oppure puoi editarlo con kwrite (o queloo che preferisci) e modificare i percorsi dei database ...
Facci sapere!

 
 
 
 
 
 
 
 
 

Ernst

Toshiba Satellite PRO L670-11E - Mandriva Free 2010.1 KDE4

Ritratto di pietro61
pietro61
(Monster)
Offline
Monster
Iscritto: 18/06/2005
Messaggi: 413

Questa  è la versione di Digikam
digikam-1.5.0-1.1mdv2010.1
libdigikamcore1-1.5.0-1.1mdv2010.1
libdigikamdatabase1-1.5.0-1.1mdv2010.1
Proverò a disinstallare e installare un versione precedente.
Ho usato il programma qualche settimana fa e funzionava perfettamente. Credo che questa sia la prima volta che lo uso da quando ho aggiornato a kde 4.5.3.
Ieri ho cancellato la cartella digikam da  kde4/share/apps e un file da kde4/share/config.
Ho avviato digicam, ha eseguito tutta la procedura del primo avvio e poi è andato in crash
Ciao e grazie Pietro

Aggiornamento:
Installata la versione 1.3 con le due dipendenze  della stessa vesione, stesso risultato
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/pf61/.kde4/socket-localhost/kdeinit4__0

[1]+  Stopped                 digikam

Ciao Pietro

Aggiornamentto:
Aggiornato automaticamente all'ultima versione e adesso funziona perfettamente.
Ciao Pietro