mandriva e nvidia NV17

8 risposte [Ultimo messaggio]
Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Ciao a tutti... per la serie "Mandriva va proprio bene" ho appena installata la 2010 one (la remastered del MIB) su un vecchio Sony PCG del 2003 o giù di lì (athlon 2200+ XP-M, 40 gb di disco, 512(!) Mb di ram) e non ho nemmeno un unknow nell'elenco dell'hardware... e nonostante la macchina datata anche kde gira fluidamente... da non credere.
Solo un piccolo problema: il pc in questione porta una scheda video nvidia NV17 (geforce4 420 Go), che MCC gestisce come una geforce 2 to geforce 4.
Se la uso con il driver nv ovviamente funziona, ma se provo ad utilizzare il driver proprietario non va, o per lo meno ha un comportamento strano: lo schermo diventa nero e non si schioda da lì, ma intanto il caricamento va avanti e sento il suono di benvenuto di kde...
E' evidente che x è in funzione, senza però che io possa vedere nulla...
Avete qualche idea?
P.s. ho settato nopat nel kernel, altrimenti x non partiva
Ciao

Mandriva 2010.2 su Athlon x2_64

Ritratto di niubbo75
niubbo75
(Monster)
Offline
Monster
Iscritto: 21/10/2008
Messaggi: 410

Io ho una 7300 LE e ho riscontrato lo stesso problema quando avevo aggiornato prima il kernel e poi avevo installato i driver nvidia, schermata nera, X in funzione ma Xorg non rispondeva. Ho risolto passando al kernel precedente e installando i driver nvidia da li, poi ho aggiornato e, ad oggi, va tutto bene (poco fa stavo giocando ad Half-Life 2 che, se avessi avuto M$ al posto di Mandriva e con il mio hardware, non si sarebbe nemmeno caricato, qui gira perfettamente ed è anche bello fluido!!!!)

Linux kernel 2.6.35.4-desktop-nrj.69mib x86_64 AMD Athlon(tm) 64 Processor 3500+ GNU/Linux nVidia GeForce 7300 LE - KDE 4.4.3 on Mandriva Linux 2010.1, ofcourse! Rappresentante Italiano Mandriva (per suggerimenti, critiche o altro contattatemi in privato)

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

Guarda il risultato del comando:
lspci -nn | grep VGA
Ciò che interessa è il codice product. ID
Con questo numero risali alla versione legacy dei driver nvidia che ti servono.
Per esempio qui
http://www.nvidia.com/object/1.0-7184_supported_products.html
c'è un elenco.
Ciao

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

@ragamuffin
il comando da te suggerito da questo output:
[root@localhost stefano]# lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV17 [GeForce4 420 Go] [10de:0175] (rev a3)
ma non trovo alcun id corrispondente nella schermata del sito che mi hai linkato
Riguardo al kernel... 'azzo, ho installato la versione mib per averla up to date... e adesso devo tornare indietro???

Mandriva 2010.2 su Athlon x2_64

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

Beh, adesso con il numerino 0175 si può fare!!!
Da qui
http://www.nvidia.com/object/IO_18897.html
si vede che il driver (legacy) giusto è:

The 96.43.xx driver supports the following set of GPUs:

NVIDIA GPU Products:
GeForce2 MX/MX 400     0x0110
GeForce2 MX 100/200     0x0111
GeForce2 Go     0x0112
Quadro2 MXR/EX/Go     0x0113
GeForce4 MX 460     0x0170
GeForce4 MX 440     0x0171
GeForce4 MX 420     0x0172
GeForce4 MX 440-SE     0x0173
GeForce4 440 Go     0x0174
GeForce4 420 Go     0x0175
GeForce4 420 Go 32M     0x0176
GeForce4 460 Go     0x0177
Quadro4 550 XGL     0x0178
GeForce4 440 Go 64M     0x0179
ecc. ecc.

Scarica da qui
http://www.nvidia.com/object/linux_display_x86_96.43.07.html
ed installi con la solita procedura ampiamente descritta.
La riassumo (vado a memoria):
Esci da X
Ti logghi come root da ctrl-alt-F1
#./NVIDIA-Linux-x86-96.43.07-pkg1.run
ctrl-alt-F7
e rientri in X
Fatto!

Citazione:

Dici:
Riguardo al kernel... 'azzo, ho installato la versione mib per averla up to date... e adesso devo tornare indietro???

  

..................questa non l'ho capita. Cosa centra il kernel! Quello va bene, ci devono essere gli header naturalmente.

Ciao

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Alura...
[root@localhost stefano]# rpm -qa | grep nvidia
nvidia96xx-kernel-2.6.31.12-desktop-1mnb-96.43.13-7mdv2010.0
dkms-nvidia96xx-96.43.13-7mdv2010.0
nvidia96xx-doc-html-96.43.13-7mdv2010.0
nvidia96xx-kernel-desktop586-latest-96.43.13-1.20100126.7mdv2010.0
x11-driver-video-nvidia96xx-96.43.13-7mdv2010.0
nvidia96xx-kernel-2.6.31.12-desktop586-1mnb-96.43.13-7mdv2010.0
nvidia96xx-kernel-desktop-latest-96.43.13-1.20100126.7mdv2010.0

direi che i driver sono quelli richiesti... li ho installati dal centro di controllo seguendo la procedura classica... è il caso che installi quelli ufficiali e vedere come va?
Per quanto riguarda l'accenno al kernel... mi riferivo al post di niubbo75, non al tuo. Smile
Ciao

Mandriva 2010.2 su Athlon x2_64

Ritratto di ragamuffin
ragamuffin
(Guru)
Offline
Guru
Iscritto: 20/02/2007
Messaggi: 1523

Citazione:


.....................
direi che i driver sono quelli richiesti... li ho installati dal centro
di controllo seguendo la procedura classica... è il caso che installi
quelli ufficiali e vedere come va?

 
sì i driver sono quelli consigliati da nvidia corp. che ritengo affidabili.
A questo punto darei la colpa della schermata nera alla risoluzione impostata di default. o a qualcosa inerente il tuo monitor.

Ti potrei anche consigliare di leggere il manuale del Sony PCG, magari c'è qualche impostazione 'sfuggevole'.

Citazione:



Ciao

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Qui il problema era una schermata bianca al posto di quella nera però magari puoi darci un occhiata lo stesso visto che quel problema è stato risolto.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Va bene, credo che ci rinuncerò... tutto sommato funziona bene anche con nv...
Ho smanettato un po' con mcc in modalità testuale... avete presente il bottone prova?
Bene, impostati i driver nvidia, sia a 1024x 768 che a 1280x1024, a a 16 e a 24 bit, FUNZIONA!
Parte il logo nvidia e appare la schermata a righe verticali colorate...
al riavvio, però, tutto buio... non ci capisco più nulla!
Ciao

Mandriva 2010.2 su Athlon x2_64