installazione amarok su 2008.1 [RISOLTO]

8 risposte [Ultimo messaggio]
Ritratto di stanituo
stanituo
(Junior)
Offline
Junior
Iscritto: 21/03/2008
Messaggi: 17

Salve a tutti,
sto cercando di installare amarok sulla mia Mandriva 2008.1, ho KDE 3.5, e se provo tramite urpmi ho il seguente risultato:

# urpmi amarok
The following packages can't be installed because they depend on packages
that are older than the installed ones:
xine-plugins-1.1.11.1-4.3plf2008.1
amarok-engine-xine-1.4.8-12.2mdv2008.1
amarok-1.4.8-12.2mdv2008.1
libamarok0-1.4.8-12.2mdv2008.1
libamarok0-scripts-1.4.8-12.2mdv2008.1
amarok-scripts-1.4.8-12.2mdv2008.1
Continue installation anyway? (Y/n) y
Packages amarok-1.4.8-12.2mdv2008.1.i586, amarok-1.4.8-12mdv2008.1.i586 can not be installed
  

io non ho idee su da dove posso iniziare per trovare la soluzione, mi potete consigliare come muovermi?
Se c'è bisogno di altre informazioni chiedete pure.
Grazie per la pazienza

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Come dice chiaramente il messaggio stai cercando d'installare una versione vecchia di Amarok su di una più recente, probabilmente hai disabilitato o rimosso le sorgenti di update per cui ti esce questo strano messaggio.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di stanituo
stanituo
(Junior)
Offline
Junior
Iscritto: 21/03/2008
Messaggi: 17

Citazione:

probabilmente hai disabilitato o rimosso le sorgenti di update per cui ti esce questo strano messaggio

 
In realtà io ho configurato urpmi con i seguenti repository (aggiornati):
# urpmi --auto-update
 
medium "PLF Free" is up-to-date
 
medium "PLF Non-free" is up-to-date
 
medium "Main" is up-to-date
 
medium "Contrib" is up-to-date
 
medium "Non-free" is up-to-date
 
medium "Main Updates" is up-to-date
 
medium "Contrib Updates" is up-to-date
 
medium "Non-free Updates" is up-to-date
 
Packages are up to date
   
 Ho lasciato fuori solo i BACKPORTS e i TESTING, credi sia questo il problema?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

No No, amarok-1.4.8-12.2mdv2008.1.i586.rpm è proprio in updates mentre amarok-1.4.9.1-2mdv2008.1.i586.rpm è nei backports, probabilmente allora il messaggio che ricevi e dovuto a qualche bug della 2008.

In ogni caso Amarok 1.4.8-12.2 è già installato per cui non vedo perché installarlo ancora.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di stanituo
stanituo
(Junior)
Offline
Junior
Iscritto: 21/03/2008
Messaggi: 17

Citazione:

In ogni caso Amarok 1.4.8-12.2 è già installato per cui non vedo perché installarlo ancora.


si soltanto che l'ho disinstallato tempo fa, adesso mi sarebbe utile...
Adesso se faccio
# rpm -qa | grep amarock
non dà nessun output, non c'è un modo per ripristinarlo secondo te?

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

Hem se scrivi proprio rpm -qa | grep amarock non troverai mai nulla, bisogna scrivere rpm -qa | grep amarok

Ciao Ciao ,Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di stanituo
stanituo
(Junior)
Offline
Junior
Iscritto: 21/03/2008
Messaggi: 17

Citazione:

rpm -qa | grep amarok


 si giusto!
cmq il risultato non cambia
# rpm -qa | grep amarok
non dà nessun output

Ritratto di Moreno
Moreno
(Guru)
Offline
Guru
Iscritto: 24/09/2004
Messaggi: 16862

Ciao

A questo punto potrebbe essere il database danneggiato

mi pare che il comando sia

rpm --rebuilddb

o robe simili.

Ciao Ciao, Moreno

Addio, e grazie per tutto il pesce.
Avatar by moonlight-dream.

Ritratto di stanituo
stanituo
(Junior)
Offline
Junior
Iscritto: 21/03/2008
Messaggi: 17

Ok, ho risolto così

solo adesso mi accorgo che avevo i seguenti pacchetti installati (probabilmente a seguito di qualche aggiornamento o installazione)

# rpm -qa *xine*
libxinerama1-1.0.2-3mdv2008.1
libxine1-1.1.16.3-1plf2009.1

così ho disinstallato libxine1-1.1.16.3-1plf2009.1
# urpme libxine1-1.1.16.3-1plf2009.1
removing libxine1-1.1.16.3-1plf2009.1.i586
removing package libxine1-1.1.16.3-1plf2009.1.i586

e poi
# urpmi amarok
To satisfy dependencies, the following packages are going to be installed:
   Package                        Version      Release       Arch
(medium "PLF Free")
  libxine1                       1.1.11.1     4.3plf2008.1  i586
  xine-plugins                   1.1.11.1     4.3plf2008.1  i586
(medium "Main Updates")
  amarok                         1.4.8        12.2mdv2008.1 i586
  amarok-engine-xine             1.4.8        12.2mdv2008.1 i586
  amarok-scripts                 1.4.8        12.2mdv2008.1 i586
  libamarok0                     1.4.8        12.2mdv2008.1 i586
  libamarok0-scripts             1.4.8        12.2mdv2008.1 i586
33MB of additional disk space will be used.
16MB of packages will be retrieved.
Proceed with the installation of the 7 packages? (Y/n) y

così l'installazione va a buon fine e funziona tutto
Grazie Moreno per il supporto