Problemi con ATI radeon

5 risposte [Ultimo messaggio]
Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Salve.
Ho comprato il pc nuovo, ed ora ho un problema con la scheda video.
Mi sono preso un athlon 64 3200+, ci ho installato la mandrake 10.0 a 64 bit, e tutto è andato alla perfezione. Dischi sata, usb2.0, eth0, tutto riconosciuto e configurato correttamente.
Il problema è la scheda video, una shappire radeon 9200 atlantis con 266 mb di ram...
Pare che Mandrake la riconosca, la configura, se chiedo di fare il test mi fa correttamente vedere una schermata piena di colori, ma come riavvio, arrivato al momento di far partire il server x, tutto diventa nero ed il pc si pianta, l'unico rimedio è un bel reboot.
Ho scaricato i driver dal sito ATI ed il kernel source, seguendo le istruzioni, ma quando installo i driver mi spara un bell'errore di incompatibilità con xfree, e non installa un bel nulla.
Ovviamente l'avvio di x spara un bel po' di scritte...che non riesco a leggere, perchè lo schermo si scurisce in un lampo e poi devo spegnere...
Avete qualche suggerimento, a parte quello di cambiare scheda?Thinking
Ciao

Mandriva 2010.2 su Athlon x2_64

Ritratto di -bele-
-bele-
(Junior)
Offline
Junior
Iscritto: 14/09/2004
Messaggi: 22

ecco come ho fatto:

1- scaricato e installato l'rpm dei sorgenti
del kernel 2.6.3-7
2- aperto centro di controllo...
->gestione software
->installa
->kernel 2.6.3.7
3-su
cd /usr/src/linux
make mrproper
make clean
make xconfig
4-durante x-config ho selezionato
-solo radeon(dri support)
-solo il chipset della mia scheda madre
-salvato e uscito
5-make
make bzImage
make modules
make modules_install
make install
6-editato il file /etc/rc.d/rc.modules
aggiunto questa linea:
/sbin/modprobe fglrx
7- riavviato
8- uscito da x
installato i driver ati con:
rpm -ivh --force fglrx-4.3.0-3.9.0.i386.rpm
9- fglrxconfig
durante la procedura bisogna stare solo
attenti a rispondere si riguardo
all'uso di agpgart(y)
10- riavviato e il gioco è fatto!

n.b.
1-Accertati durante l'installazione di mettere un segno di spunta vicino a tutti gli strumenti di sviluppo(installerai parecchie librerie utilissime durante le compilazioni)
2-io ho una 9800 pro quindi non garantisco che tale procedura funzioni anche nel tuo caso
3-tentar non nuoce

cpu p42.4ghz_motherboard p4p800_ram1gb ddr400_radeon9800pro256mb_soundblaster audigy 2_master. philipsdvd+/-rw824_master. lg48x16x48_scheda satellitare skystar2_router d-link dsl-300g+

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Ti ringrazio... il mio problema è che comunque non riesco a entrare in x... mi si oscura lo schermo.
Comunque: ho installato da console il kernel source, non l'ho ancora compilato.
Su un'altra lista mi hanno fatto però notare che i driver proprietari di ATI non sono compatibili con linux64(sono per i386)
In ogni caso, leggendomi i log, ho scoperto che dà un errore nel caricamento del modulo agpgart, che risulta non esistere sulla mia macchina...
grazie, per ora!

Mandriva 2010.2 su Athlon x2_64

Ritratto di -bele-
-bele-
(Junior)
Offline
Junior
Iscritto: 14/09/2004
Messaggi: 22

la configurazione dovresti riuscire a farla anche in maniera testuale.
per quanto riguarda l'errore riguardo agpgart io avevo risolto usando anzichè"Uh"( come parametri per installare l'rpm) "Ivh" e non trovando il modulo agpgart me ne ha installato e compilato uno automaticamente.
Se usi Uh prova ivh.

cpu p42.4ghz_motherboard p4p800_ram1gb ddr400_radeon9800pro256mb_soundblaster audigy 2_master. philipsdvd+/-rw824_master. lg48x16x48_scheda satellitare skystar2_router d-link dsl-300g+

Ritratto di stefluni04
stefluni04
(Guru)
Offline
Guru
Iscritto: 08/09/2004
Messaggi: 1346

Ti ringrazio per le informazioni... comunque ho risolto scaricando il kernel aggiornato dal sito mandrake.Con il 2.6.3.16 funziona tutto a meraviglia (a parte qualche problemino con le porte USB...)
Ciao

Mandriva 2010.2 su Athlon x2_64

Ritratto di Ardsheal
Ardsheal
(Monster)
Offline
Monster
Iscritto: 09/09/2004
Messaggi: 206

Ma è necessario per forza di cose avere il kernel aggiornato alla 2.6? Io con la 2.4 non riesco a installare i driver: controllo la versione Xfree e scarico la versione di driver corrispondente ma appena cerco di installare mi dice che il driver non è compatibile con Xfree

Uff... Sad