hal ntfs-3g e caratteri accentati

1 risposta [Ultimo messaggio]
Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

Ciao se attacco l' HD esterno viene montato correttamente ntfs ma nn posso scrivere niente che abbia caratteri accentati..
se lo smonto e poi lo rimonto manualmente da konsole invece tutto bene..
leggendo un po' qua e là ho visto che:

"my locale is actually set to UTF-8.
so when through i.e. Konsole I mount (using sudo) an ntfs partition with
ntfs-3g I can get all files, even those which names contain non en_US
characters.
The problem is when I mount the partition with hal in konqueror. hal uses
the system UI language. I don't clearly know what it is, but i think as
I'm using kde in its original language hal uses slackware default charset,
iso-8859.
I would like that hal uses the locale charset."

quest'ultima cosa che lui vorrebbe fare è praticamente impossibile, bisognerebbe patchare hal e ricompilarlo e poi patchare kde e ricompilarlo..

qualcuno sa se questa cosa verrà risolta nel nuovo kde o un modo per cui risolvere adesso senza ogni volta dover montare manualmente? ho questo probl sulla 2007.1 e sulla 2008.0 e mi sembra anche sulla 2009 ma nn mi ricordo bene su quets'ultima dovrò verificare.. se qualcuno ha la 2009 si può vedere al volo: attacca un HD usb ntfs e lo apre in konqueror e prova a creare una nuova cartella che si chiama "là" senza virgolette..
ciao grazie!

Ritratto di rob_mdvita
rob_mdvita
(Monster)
Offline
Monster
Iscritto: 11/07/2007
Messaggi: 423

tutto si è risolto ritornando alla UTF-8 nel mio locale.. ciao!