installare nuovi catalyst mandriva 2009

7 risposte [Ultimo messaggio]
Ritratto di stige76
stige76
(Junior)
Offline
Junior
Iscritto: 09/10/2008
Messaggi: 6

Abbiate pazienza...ho provato anche da sola...ma ho fatto un disastro...mi sono scaricata..i catalyst nuovi...e ho eseguito il file .run disastro...non partiva + niente...ma ho rimediato....già cosa buona...ma come si fa ad installarli..ho tovato alcune guide per la 2008.0 ma non capito molto bene, mi spiegate in maniera facile facile....grazie Serenella

Ritratto di klick
klick
(Monster)
Offline
Monster
Iscritto: 04/04/2008
Messaggi: 442

ciao,

bella domanda ,è tutto il giorno che ci sbatto la testa,

per adesso ti conviene usare questa guida:

http://www.mandrakeitalia.org/modules/wfsection/article.php?articleid=285

ciao,ciao

Ritratto di stige76
stige76
(Junior)
Offline
Junior
Iscritto: 09/10/2008
Messaggi: 6

nada...la guida è per la 2008....e poi non capisco bene cosa fà...speriamo nell'aiuto di qualche guru...comunque grazie a tutti...ho fatto passi da gigante grazie a forum...mi sono tolta alcune soddisfazioni...grazie alle persone che mi hanno aiutata

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

ciao,

quante ne no penate anch'io con i driver ati...

beh...qualche esperienza è riportata
http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=13331&forum=7&post_id=84567#forumpost84567
http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=14591&viewmode=flat&order=ASC&start=0
http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=14567&forum=2&post_id=95606#forumpost95606

Ritratto di Dom-X
Dom-X
(Guru)
Offline
Guru
Iscritto: 12/11/2006
Messaggi: 1000

Con fglrx è sempre cervellotica l'installazione:

Se avete i repository configurati e funzionanti e la connesisone di rete a posto, riavviate in safe mode poi date il comando: XFdrake, rispettando maiuscole e minuscole, vi si aprirà una shell in cui potrete selezionare la vostra scheda video, dopo averla selezionata vi verrà segnalata la presenza di un driver proprietario per la vostra scheda, date l'ok..

Vi verrà installato il driver corretto con DKMS , al riavvio DKMS provvederà alla compilazione del driver per il kernel che state usando dopodichè dovreste essere in grado di fare login con il driver proprietario.

Tutto questo se non avete esageratamente pasticciato con i driver e le installazioni... ovvero se DKMS è in grado di effettuare la compilazione..

Se DKMS non installa/ fa confusione con i vari fglrx..(guardate con attenzione il log all'avvio, per visualizzarlo premete alt+esc quando compare la schermata coi pinguini) rifate la procedura con XFdrake da safemode e quando vi dice che esiste un driver proprietario rispondete no, il sitema utilizzera il driver di default radeon/radeonhd.. salvate riavviate e dovreste ritornare ad avere il supporto grafico

- Ripristino del driver corretto e dkms

Se DKMS va in crisi, l'unica via d'uscita che avete è di cancellare DKMS e tutti i fglrx installati. utilizzate con criterio da consolle e da superuser il comando: urpme fglrx .. poi urpme dkms .. ignorate le segnalazioni di pacchetti orfani.

Fatta l'operazione di disinstallazione potete riprovare a reinstallare dkms e poi fglrx.. da consolle e come superuser: urpmi fglrx dkms.

Poi riavviate in safe mode, XFdrake riscegliete la vostra scheda, e utilizzate il driver proprietario quando vi viene chiesto.

Spero possa esservi d'aiuto.

Mandriva 64 bit 2011, kernel MIb Nrj 3.0.8

Ritratto di klick
klick
(Monster)
Offline
Monster
Iscritto: 04/04/2008
Messaggi: 442

ciao,

grazie Dom-x, si questa è la procedura per i driver nei repo, io intendevo installare gli ultimi driver 8.11 appena usciti e che non sono ancora nei repo.
Questo è l'errore che mi da e che non capisco:

Generating package: Mandriva/2009                                      <br />Package build failed!                                                   <br />Package build utility output:                                            <br />&quot;rpm -b&quot; is deprecated, use &quot;rpmbuild -b&quot;                                <br />Executing(%prep): /bin/sh -e /root/tmp/ati.fAEeIe/tmp/rpm-tmp.32025<br />+ umask 022                                                              <br />+ cd /root/tmp/ati.fAEeIe/BUILD                                          <br />+ &#039;[&#039; 1 -eq 1 &#039;]&#039;                                                        <br />+ &#039;[&#039; 1 -eq 1 &#039;]&#039;                                                         <br />+ &#039;[&#039; 1 -eq 1 &#039;]&#039;                                                        <br />+  cd /root/tmp/ati.fAEeIe/BUILD                                          <br />+  rm -rf fglrx-8.552<br />+ /bin/mkdir -p fglrx-8.552 <br />+ cd fglrx-8.552 <br />+ ln -s /home/anto/rpm/ati/fglrx-install.AMlRXC/x710 /home/anto/rpm/ati/fglrx-install.AMlRXC/arch .  <br />+ cp -a /home/anto/rpm/ati/fglrx-install.AMlRXC/common . <br />+ cd common<br />+ echo &#039;Patch #0 (ati-8.32.5-uname_r.patch):&#039; <br />Patch #0 (ati-8.32.5uname_r.patch):<br />+ patch -p2 -s <br />2 out of 2 hunks FAILED -- saving rejects to file lib/modules/fglrx/build_mod/make.sh.rej <br />error: Bad exit status from /root/tmp/ati.fAEeIe/tmp/rpm-tmp.32025 (%prep)<br /><br /><br />RPM build errors:    <br />                    Bad exit status from /root/tmp/ati.fAEeIe/tmp/rpm-tmp.32025 (%prep)<br />Removing temporary directory: fglrx-install.AMlRXC<br /> [root@localhost ati]#

qualcuno ha avuto lo stesso problema

ciao,ciao

Ritratto di Dom-X
Dom-X
(Guru)
Offline
Guru
Iscritto: 12/11/2006
Messaggi: 1000

io non sono avvezzo alle consolle e ai log, cmq, mi pare di capire che tu abbia provato a creare l'rpm per mandriva, non l'installazione del driver.

Parere personale quando c'è l'RPM pronto e impacchettato, è sempre la soluzione migliore. Sopratutto quando l'RPM è ufficiale mandriva o arriva da qualche scienziato pazzo del Mib in grado di impachettare in rpm anche la suocera..

Se poi ti può consolare, tutti i miei tentativi di installazione dei driver Ati partendo dal tarball, si sono sempre conclusi con un errore 2 di Make.

Mi par di capire che l'errore 2 è quando Make non trova qualcosa che gli serve.

Cmq io sono più luser che geek qundi lascio la palla ai Guru

Mandriva 64 bit 2011, kernel MIb Nrj 3.0.8

Ritratto di bat86
bat86
(Guru)
Offline
Guru
Iscritto: 05/02/2007
Messaggi: 960

il sistema di generazione rpm integrato nei driver ati fa un po' quello che vuole.
assicurati di avere installato tutte le dipendenze.

cmq, tutto o quasi tutto quello che c'è da sapere e come fare è qui http://wiki.cchtml.com/index.php/Main_Page vedi anche http://wiki.cchtml.com/index.php/Mandriva.

se quella versione xy del driver non va è inutile perderci tempo.
tieni i driver che ti installa mamma mandriva finchè non ci sono netti/significativi miglioramenti....è un consiglio.